Revit Architecture

Reply
Member
acme3d
Posts: 3
Registered: ‎03-14-2011
Message 1 of 6 (3,397 Views)
Accepted Solution

Crop Region not visible

3397 Views, 5 Replies
03-14-2011 08:24 AM

I have a floor plan view that the crop region is not visible.  the properties of the view have crop view checked, the lightbulb button at the bottom is on.   the only way i can get the crop region to appear is to duplicate the view.  now the problem is i can't delete the original view because i get an error "This action has caused deletion of non-editable Workset ' View "Floor Plan: SECOND FLOOR PLAN - ELEVATION A  temp" '.  i click the button "Make Elements Editable" but it just keeps coming back. 

 

is there another place where the crop region is turned off?  is there a solution to the error of something being on the View workset?

 

Andrew

Employee
ryan.duell
Posts: 734
Registered: ‎06-01-2010
Message 2 of 6 (3,366 Views)

Re: Crop Region not visible

03-15-2011 07:05 AM in reply to: acme3d

I would first verify the following:


1.  View Properties > Crop View checked
2.  View Properties > Crop Region Visible checked
3.  Toggle Reveal Hidden Elements
4.  Check View Properties > Scope Box
5.  Change Visual Style > Wireframe


Specifically for the error message, this typically indicates a conflict in workset assignment in the Revit database.  When attempting to delete one of these elements or use purge unused, Revit cannot automatically reconcile this issue.

 

In many cases the project file needs to have the database manually corrected.  If you are on Autodesk Subscription I would recommend creating a support case for further assistance.

 

You may be able to verify if an element in the view is incorrectly assigned to a view workset.  I would test the following:

 

1.  In the View type VG > Worksets.

 

2.  Turn all Worksets on the list > Hide.

 

3.  Now make sure every model \ annotation category is checked active in the view under Model Categories and Annotation Categories.

 

4.  Hit OK to return to the model view.  If you still see any elements, select them and check the Properties for the workset. 

 

If you find any element[s] on a view workset you can correct this by setting the current workset under Collaborate > Worksets.  Then cut and paste the element to the same place.  This should move it from the view workset to the correct model workset.

 

5.  Try to delete the view afterward; this may be where the conflict was and manually correct the database.

 

Thank you,



Ryan Duell
Autodesk, Inc.

Revit Clinic
@revitclinic


Distinguished Contributor
eviele
Posts: 1,741
Registered: ‎12-02-2003
Message 3 of 6 (3,357 Views)

Re: Crop Region not visible

03-15-2011 02:19 PM in reply to: acme3d

Funny, my original post was in the new IE9 and it was a no show.

Perfect!

 

We had the exact same issue here Andrew, right down to the crop region showing when we duplicated the view, but not showing at all otherwise.

 

We're using Design Options and amazingly and magically when I went to the Visible In Option portion of the View Properties and switched it to "all", the crop region showed. I then switched the Visible In Option parameter back to whatever Design Option it was before and the crop region stayed.

 

If you're using Design Options give that a try.

Best of luck,

 

e.

Employee
loboarch
Posts: 978
Registered: ‎09-05-2003
Message 4 of 6 (3,329 Views)

Re: Crop Region not visible

03-16-2011 01:34 PM in reply to: eviele

eviele wrote:

Funny, my original post was in the new IE9 and it was a no show.

Perfect!

 

________________________________________________________________________________

 

That explains why the response I posted to another thread the other day was not showing up.  I was using IE 9 as well.  I will have to send that little gem along to the admin.

 

Thanks!

 



Jeff Hanson
Sr. Subject Matter Expert
Autodesk, Revit User Experience
Member
acme3d
Posts: 3
Registered: ‎03-14-2011
Message 5 of 6 (3,314 Views)

Re: Crop Region not visible

03-16-2011 07:53 PM in reply to: eviele

we use design options as well and as soon as i made this post i was looking at the properties again and saw that the visable in option was set to an option that didn't match the view and i changed it and it showed up.  maybe it's a glitch or something.

 

thanks for all suggestions.

Member
acme3d
Posts: 3
Registered: ‎03-14-2011
Message 6 of 6 (3,311 Views)

Re: Crop Region not visible

03-16-2011 08:03 PM in reply to: ryan.duell

thanks ryan for the explanation.  i've run into that error a few times.  once i found almost a whole room on a view workset and i was able cut it out and paste it back.  i think i tried it in this case but i could not find anything.  i must have forgotten to turn all the catergories.

 

andrew

You are not logged in.

Log into access your profile, ask and answer questions, share ideas and more. Haven't signed up yet? Register

Announcements
Are you familiar with the Autodesk Expert Elites? The Expert Elite program is made up of customers that help other customers by sharing knowledge and exemplifying an engaging style of collaboration. To learn more, please visit our Expert Elite website.

Need installation help?

Start with some of our most frequented solutions to get help installing your software.

Ask the Community


Revit Exchange Apps

Created by the community for the community, Autodesk Exchange Apps for Revit helps you achieve greater speed, accuracy, and automation from concept to manufacturing.

Connect with Revit

Twitter

Facebook

Blogs

Youtube