Navisworks General

Reply
Valued Contributor
revitforbreakfast
Posts: 51
Registered: ‎10-07-2010
Message 1 of 2 (136 Views)

advanced deployment Question

136 Views, 1 Replies
09-04-2012 07:41 AM

My Navisworks (NW) options won't take in the network deployment. At our company we create packages so deployments can be 'plug and play' once they are installed.

 

The problem with Navisworks is that you cannot reference the deployment needs to reference a network location to grab the option.xml file. We need this to be a local location as the users doing the install do not have the same administrative access to these folders as the creators. Also when we package a software we don't want the deployment to searching for a file over the network in a different continent.

 

So the question is how to manipulate Navisworks to run our options at the start of opening the program. Make our options the default.

 

I notice when I open navisworks and change the selection colour from blue to red (as an example) and close Navisworks; that when I reoped it the colour is still red.

 

So my thought process to trick Navisworks is to open my options is to open NW, load my custom options and close NW. Next I copy the lastsession.xml to a location I can store it. I will open NW and chane the selection colour to pink and close Navisworks.

 

Then I delete the lastsession.xml in the appdata for NW 2013. I will then paste in my lastsession.xml to replace it. This should theoretically give us our green selection colour. Open NW and check the selection colour.

 

It's pink, WTF? Where can I store these options so I can get them at least once when I launch Navisworks.

 

If I put the file in:

C:\Users\JohnSmith\AppData\Roaming\Autodesk Navisworks Manage 2013\global_options, does it need a certain file name.

 

I really need help with this. This issue is holding up the deployment of the software to about 400 users.

 

Thanks

Valued Mentor
Posts: 315
Registered: ‎02-19-2010
Message 2 of 2 (121 Views)

Re: advanced deployment Question

09-04-2012 10:34 PM in reply to: revitforbreakfast

The only solution I found was a batch file that is "Run as Administrator" and that does the following

1) starts the shortcut that was created with creating the deployment

2) copies over some files: in the Models subfolder I copy over the "Gatehouse.NWD"

in the Workspaces subfolder, I copy over my "company default" workspace.xml

In the progam folder I copy over the Licpath.lic and a settings.xml

3) I import a reg file that assigns *.NWD files to Freedom and *.NWF files to Simulate

4) I implement a Service Pack on top of the deployment

5) I start Simulate, open the "Gatehouse.NWD"

and then, I have to manually activate the workspace (for each user on that machine)

and I have to manually import my options.xml

 

Perhaps these last stepas are also scriptable (optionsmanager.exe with some parameters)

but this is as far I as I could automate it.

 

You are not logged in.

Log into access your profile, ask and answer questions, share ideas and more. Haven't signed up yet? Register

Announcements
Have API Questions?
New Dedicated Forum for Navisworks API

Need installation help?

Start with some of our most frequented solutions to get help installing your software.

Ask the Community