Navisworks General

Reply
Contributor
hand.jordan
Posts: 13
Registered: ‎04-06-2011
Message 1 of 9 (836 Views)
Accepted Solution

Tabular HTML Report and Excel

836 Views, 8 Replies
06-22-2011 05:59 AM

I am playing with the 2012 tabular report and excel import options. When I import into excel, the none of the images are properly aligned in the cells.

 

I am going to keep messing with excel to get it right, but if anyone else has run across a solution, please let me know.

 

 

Capture.PNG

Alumni
Posts: 359
Registered: ‎08-28-2009
Message 2 of 9 (818 Views)

Re: Tabular HTML Report and Excel

06-23-2011 05:04 PM in reply to: hand.jordan

Hi hand.jordan,


W
hich version of Excel are you using?

Could you provide more details on the import options? Are these excel application options or some other options specific to importing HTML?  At first I thought you may be using Data > Get External Data > From Web, but that ignores images.  Are you opening the file through File > Open?

From the looks of it, it appears that the images have the “don’t move or size with cells” object positioning property.  If you right click on one of the clash images and select size and properties is this stated as such in the Properties tab?  By default, it should be set to Move but don’t size with cells.

I also found that unfortunately selecting a row and selecting Format > Autofit Row Height does not work with the clash images as the row height shrinks down and the images appear to collapse on one another.  Is that the same result in your case?

Would you be able to send an xls or xlsx file that shows how it is coming in?  If the data
is sensitive, you could use one of the examples in the Examples folder under Programs Files > Autodesk > Navisworks Manage 2012.

Best regards,

John Lipp
autodesk_logo_signature.png
Product Support Specialist
Autodesk Product Support

Contributor
hand.jordan
Posts: 13
Registered: ‎04-06-2011
Message 3 of 9 (811 Views)

Re: Tabular HTML Report and Excel

06-24-2011 05:48 AM in reply to: john.lipp

I did everything in the video below from Autodesk.

 

http://youtu.be/YDtgXuDxs3Y

 

I am using excel 2007. I am opening through file->open. All of the images are set to "Move but don't size with cells". 

 

I experienced the same issue trying to uniformly resize all of the rows to accomodate the cells. 

 

On the video, it works with 2010. Unfortunately, there aren't a whole lot of settings in excel or Navis to modify the report.

 

I looked at using a macro to select all images on the worksheet and modify them at the same time, but I would like a cleaner solution.

 

Thanks,

Jordan

Alumni
Posts: 359
Registered: ‎08-28-2009
Message 4 of 9 (803 Views)

Re: Tabular HTML Report and Excel

06-24-2011 11:01 AM in reply to: hand.jordan

Hi hand.jordan,  


Perhaps your Excel application is having issues with the Style Sheet contained in the HTML.  In the HTML, there is a class listed as:

 

table.mainTable tr.contentRow{

   height: 100px;

}

This should make the row 100 pixels in height which should allow the 95 pixel square image to fit properly.

I’ve attached a test file SIMPLETEST.HTML along with one of your images cd000001.jpg that should be placed in the same folder.  Try opening this SIMPLETEST.HTML in Excel.  It should look like this:

2011-06-24_1052.png


Best regards,

John Lipp
autodesk_logo_signature.png
Product Support Specialist
Autodesk Product Support

Contributor
hand.jordan
Posts: 13
Registered: ‎04-06-2011
Message 5 of 9 (798 Views)

Re: Tabular HTML Report and Excel

06-24-2011 11:10 AM in reply to: john.lipp

Now we are getting somewhere. All of my row heights are correct (100px). The issue is related to the image size apparently as they are larger in excel 2007.

Alumni
Posts: 359
Registered: ‎08-28-2009
Message 6 of 9 (792 Views)

Re: Tabular HTML Report and Excel

06-24-2011 11:49 AM in reply to: hand.jordan

Hi hand.jordan,

Could you post a screenshot of what you see in Excel when you open the SIMPLETEST.HTML file.  I am testing on MS Excel 2007, and the screenshot I previously posted is how it looks when I open it on my end.

Best regards,

John Lipp
autodesk_logo_signature.png
Product Support Specialist
Autodesk Product Support

Contributor
hand.jordan
Posts: 13
Registered: ‎04-06-2011
Message 7 of 9 (790 Views)

Re: Tabular HTML Report and Excel

06-24-2011 11:55 AM in reply to: john.lipp

Capture.PNG

Alumni
Posts: 359
Registered: ‎08-28-2009
Message 8 of 9 (780 Views)

Re: Tabular HTML Report and Excel

06-24-2011 01:32 PM in reply to: hand.jordan

Hi hand.jordan,  

I think I may have found the issue:  Please check your DPI setting in Control Panel by opening Control Panel > Appearance and Personalization > Display.

I think yours is set to Medium, as when I tested with this setting, I see the same results in Excel as your screenshots.

Try changing the setting to Smaller 100% and log off/on so the setting takes effect.  Then try opening the HTML files in Excel.

Please let us know if this solves the issue on your end.


Best regards,

John Lipp
autodesk_logo_signature.png
Product Support Specialist

Autodesk Product Support

Contributor
hand.jordan
Posts: 13
Registered: ‎04-06-2011
Message 9 of 9 (762 Views)

Re: Tabular HTML Report and Excel

06-27-2011 06:02 AM in reply to: john.lipp

John,

 

That fixed it perfectly. Thank you for your help. 

You are not logged in.

Log into access your profile, ask and answer questions, share ideas and more. Haven't signed up yet? Register

Announcements
Have API Questions?
New Dedicated Forum for Navisworks API

Need installation help?

Start with some of our most frequented solutions to get help installing your software.

Ask the Community