Navisworks General

Reply
Active Member
x2dalyon
Posts: 10
Registered: ‎11-22-2011
Message 1 of 3 (327 Views)

Navisworks 2012 64bit takes 4 times longer to publish with data than 2010 32bit

327 Views, 2 Replies
09-21-2012 01:26 PM

We create lots of models twice a day. a few with data and then many more without.  When we moved to a 64 bit server with 24Gb of ram and 16 cores, We thought the publishing would be faster. Instead it takes 7 minutes for a file when it used to take less than 2.  We are running 2012 Simulate 64bit on Windows 2008 R2.  Is there anything we can do to help the publish run faster?  the data is being retrieved from an SQL instance on the same computer the publish is occuring on.

Alumni
john.lipp
Posts: 359
Registered: ‎08-28-2009
Message 2 of 3 (262 Views)

Re: Navisworks 2012 64bit takes 4 times longer to publish with data than 2010 32

09-26-2012 12:25 PM in reply to: x2dalyon
 

Navisworks 2012 does not support Windows 2008 which likely explains why it isn’t behaving as expected.  I believe the installer normally will display an error message and not allow you to install on an unsupported operating system, but this may not be the case.

http://usa.autodesk.com/adsk/servlet/ps/dl/item?siteID=123112&id=15407756&linkID=10382101

Likewise, Navisworks currently isn’t a multi-threaded application, so it won’t make use of the additional cores.  More information on this can be found on the following page under the “Processor” bullet:

http://beyonddesign.typepad.com/posts/2011/06/121-gigawatts-121-gigawatts-great-scott.html

I would recommend installing on a supported operating system.

Perhaps Navisworks is having issues with the multiple core processor, you can check this through the following :

1. Open Navisworks:


2. Opening the task manager on the machine through the CTRL+SHIFT+ESC key combination. 

3. Select the processors tab.

4. Locate the roamer. exe process and right click it and select “Set Affinity”

5. Unmark all the boxes except for CPU0

6. Click OK and then try publishing to see if it is any better.

But again, since you are running it in an untested/unsupported environment, I recommend installing it on a supported one as you may run into other issues.



John Lipp
Support Specialist
Product Support
Autodesk, Inc.

Active Member
x2dalyon
Posts: 10
Registered: ‎11-22-2011
Message 3 of 3 (256 Views)

Re: Navisworks 2012 64bit takes 4 times longer to publish with data than 2010 32

09-26-2012 12:48 PM in reply to: x2dalyon

We are also seeing the same issue running on Windows 7 64bit.  It installs and runs on Windwos 2008 R2 and almost as quick without data embed.  I will consider the single core solution.  Please consider supporting a server operating system in the future. We are batch processing using the api to create models for external parties and construction nightly.  2010 worked very well on Windows Server 2003, I would hope that Autodesk would look at improving embedding data speed on the next release.

You are not logged in.

Log into access your profile, ask and answer questions, share ideas and more. Haven't signed up yet? Register

Announcements
Have API Questions?
New Dedicated Forum for Navisworks API

Need installation help?

Start with some of our most frequented solutions to get help installing your software.

Ask the Community