Navisworks General Discussion

Reply
New Member
mlstoner
Posts: 2
Registered: ‎10-04-2007
Message 1 of 3 (691 Views)

Using Custom Colors.txt File With RVM Files

691 Views, 2 Replies
11-30-2009 02:34 PM
I'm trying to setup custom colors using the standard colors.txt and the PDMS_colors.txt that come with NW. I have placed a copy in the "...\Application Data\Autodesk NavisWorks Review 2009\rvm" folder. I have tried adding both new lines and modified existing ones. However I still get the same results a grey color of 153, 153, 153.

I know that I'm missing something but have not been successful in locating help topics on this process.

Any suggestions are appreciated.
Employee
JeffH_ADSK
Posts: 149
Registered: ‎10-29-2009
Message 2 of 3 (691 Views)

Re: Using Custom Colors.txt File With RVM Files

12-01-2009 03:56 AM in reply to: mlstoner
Forgive the silly question, but are you certain the file you're testing with actually references the colour value you are modifying?

The colour values are fetched from the colors.txt - the PDMS_colors.txt is a template that could be renamed to colors.txt if you wanted the PDMS standard colour scheme.

If, for example, the file refers to a colour value of 50, this is mapped to Wheat, which is mapped to 96,87,70 (RVM colour values go from 0-100). If you wanted a different resulting colour for Wheat, you'd change the entries to, say, 30,30,30 for a dark grey.

I hope that helps,

Jeff


Senior Software Engineer
Navisworks
Autodesk Ltd.
New Member
mlstoner
Posts: 2
Registered: ‎10-04-2007
Message 3 of 3 (691 Views)

Re: Using Custom Colors.txt File With RVM Files

12-01-2009 07:11 AM in reply to: mlstoner
Jeff,

All questions welcomed silly or not.

I was using the colors.txt file for my testing but I failed to adhere to the colour value range of 0-100 as you stated. After adjusting the colors and staying in the 0-100 range it worked fine.

I was confused because even the PDMS_colors.txt had colors defined above the 0-100 color range. I was trying to brighten the colors for use on a projector which seems to always be a little darker then the actual computer screen. This was pushing them way above the 100 range per the color dialog box within NW.

I wish I could get them a little brighter on the automated side but can work around that.

Appriciate the help,

Mark

You are not logged in.

Log into access your profile, ask and answer questions, share ideas and more. Haven't signed up yet? Register

Announcements
Have API Questions?
New Dedicated Forum for Navisworks API

Need installation help?

Start with some of our most frequented solutions to get help installing your software.

Ask the Community