Navisworks General Discussion

Reply
Distinguished Contributor
docsaintly
Posts: 196
Registered: ‎12-06-2006
Message 1 of 16 (1,363 Views)

Opening NWF is slow / not opening.

1363 Views, 15 Replies
05-25-2011 04:04 PM

I have an NWF file with many NWDs referenced in it. It's been working fine for months now; but now when I try to open it it stops at 45%. The other strange thing is that at 45% it shows it trying to load itself. E.g. if my file is ABC.nwf, at 45% it shows it trying to load ABC.nwf and stops progressing.

 

I copied the file to my desktop (from the network share) and it now gets to 90% (processing), but it still seems to lock up and not open the file.

 

Any suggestions would be greatly appreciated.

Product Support
lee.mullin
Posts: 479
Registered: ‎10-02-2007
Message 2 of 16 (1,350 Views)

Re: Opening NWF is slow / not opening.

05-27-2011 03:40 AM in reply to: docsaintly

I think the loading of the NWF file appearing in the loader bar may be a red herring. that is part of the file load process where we list the individual files we are loading as part of the part NWF file, followed by the loading of NWF Navisworks specific data (viewpoints, clash data etc), then optimisation of the geometry.

 

I'd check your memory usage at the time of loading, in the Task Manager > Performance, if this is maximised you may just be running out of memory. How many files are loading, how big are the files in total? Can all the NWD's be loaded on their own (i.e. without the parent NWF)?

 

In Options > Model > Performance do you have Close NWC/NWD on load switched on. If so try switching it off, this will stream the parts of the model you need from the location rather than try and load the entire model to memory. From what you describe with the improvement in performance locally then there may be some network performance issues which need to be addressed that would be out of our control, but you should still be able to open the file locally.

 

Was this a sudden change in loading the file or had you noticed a gradual degradation?

 

Have you tried this on any other machines? What results did you get?

 

When you load the file locally, you say it locks up, what locks up, the entire machine, or just Navisworks? Does it lock up with the Loading bar still displaying?

 

Can you upload a screenshot of the System Info under Help in Navisworks?


Lee Mullin
Product Support Specialist
Global Services
Autodesk Ltd.


Distinguished Contributor
docsaintly
Posts: 196
Registered: ‎12-06-2006
Message 3 of 16 (1,345 Views)

Re: Opening NWF is slow / not opening.

05-27-2011 10:33 AM in reply to: docsaintly

Thank you for your response.

 

We have found a workaround (and possibly solution) to the problem, but I will get to that after I answer each of your questions.

 

I highly doubt that memory or processing power is an issue. The machines we are using have 24GB of DDR3 ram and an Intel Xeon 6 core (@ 3ghz) processor. Here is the navisworks info snapshot:

 

At first, the "close nwc/nwd" option  was not selected, but we then tried this hoping it would help performance. It did not seem to make a difference.

 

The result was the same across 2 different machines. And Just navisworks lock up. The loading bar is still displaying when it locks up.

 

I don't have all the details since the main person who was working with this is out today. But we think we found the problem:

 

We had NWDs linked in to the NWF that were snapshots of some drawings. We got new drawings, so we created new NWDs. I think we either moved or renamed the original NWDs and then referenced in the new NWDs. This is when Navisworks started "misbehaving".

 

We guessed that it was probably looking for the files that had moved or been renamed, so we moved them back to where they were originally, and then Navisworks loaded up fine. We removed the references to these NWDs, saved the model, and then moved/renamed the NWDs to an archive folder. The NWF opens fine now.

 

If the issue is that navisworks gets stuck in a loop looking for those files, then it really needs to be fixed. There may be a scenario where someone is not able to reproduce the original files that Navisworks is looking for and will need to regenerate a new NWF (thus losing all their clashes / viewports).

 

There really should be a feature in Navisworks to clean up NWFs outside of Navisworks, or a "partial load" like AutoCAD has in order to prevent issues like this from making an NWF unusable.

Active Contributor
tfischer
Posts: 41
Registered: ‎08-06-2012
Message 4 of 16 (1,077 Views)

Re: Opening NWF is slow / not opening.

10-15-2012 11:11 AM in reply to: docsaintly

UPDATE: I was running into this same problem - I would hit the 45% mark and it would seem to "freeze" or "lock" up.

 

it was also after I was "overwritten" a bunch of .dwg files that wer directly linked into my NWF.

 

 

...Long story short, it took about an hour and half, but Navisworks FINALLY opened my NWF!! I thought it was freezing, apparently was just thinking... and thinking... and thinking.

 

Just wanted to update this as it is not a "probem" per se, but you would think that taking over an hour to open the file (it IS a large NWF, my CPU is pretty good too - i7, 8GB ram)

New Member
bscarbro
Posts: 2
Registered: ‎11-16-2012
Message 5 of 16 (965 Views)

Re: Opening NWF is slow / not opening.

11-16-2012 11:51 AM in reply to: tfischer

I am currently experiencing this problem.  I have it loading to 91% "Working ..." but it's just stopped there.

 

I have an NWF file with nwc, dwgs, and revit files appended.  Computer performance isn't the issue.  

 

I've let it load for about an hour now and am still hoping it just pops up.  But this is something that should be addressed by AutoDesk.  

New Member
bscarbro
Posts: 2
Registered: ‎11-16-2012
Message 6 of 16 (963 Views)

Re: Opening NWF is slow / not opening.

11-16-2012 12:38 PM in reply to: bscarbro

Apparently waiting 2 hours did the trick.

 

Opens normally now.

Valued Contributor
chris.kershaw
Posts: 79
Registered: ‎06-01-2004
Message 7 of 16 (945 Views)

Re: Opening NWF is slow / not opening.

11-20-2012 07:39 AM in reply to: docsaintly

I have experianced slow opening of NWF files here on a few PC's changing the DWG loader to 2012 solved the problem.

 

Simulate 2013

Member
crk4
Posts: 4
Registered: ‎06-01-2011
Message 8 of 16 (610 Views)

Re: Opening NWF is slow / not opening.

09-23-2013 01:17 PM in reply to: docsaintly

This thread has been dead for some time now, but I REALLY need some help here.

 

I am having the same problem here using Manage 2014.  This has been working for months and it really upsets me that I have to rebuild all my files and my views.  This is the second time this happened to me.  I have a twenty story building, and it currently is a 31 mb NWF file.  The NWF file references:

 

1) NWC files generated from Revit (Designer of record)

2) NWC file generated from IFC convert (Structural steel fabricator)

3) DWG master files (2 for each floor) (each one has ACAD XREF's of 2 to 4 files on the MS Sharepoint site.  These had to be created because the Curtain Wall and Metal Deck subs are drawing in 2D ACAD)

 

 

As you see with the attachment, all the files load up, and my resource monitor says I still have plenty of memory left.  It seems as if it got stuck on 45.1%.  Previously it was getting stuck on something like 90.2%, and I went in and checked the option to close NWC files upon load.  It then halved it to 45.1%.

 

Note that the files it is linking to are coming from a Microsoft Sharepoint Site.

 

Please advise if there are any fixes out there that are working.

 

Active Contributor
tfischer
Posts: 41
Registered: ‎08-06-2012
Message 9 of 16 (605 Views)

Re: Opening NWF is slow / not opening.

09-23-2013 01:22 PM in reply to: docsaintly

Do you have Service Pack 1 installed for Navisworks 2014?

 

Then, like others and I have stated, sometimes you must just wait it out.

 

If you are opening a file that contains "new versions" on previously linked in models, Navis will definitely bog down when loading these files. Sometimes it seems to slow much more than other times, which i don't see a common reason for.

 

I would open it, and when it gets "stuck" on 45.1% or whatever, just let it think. Even try to do it at the end of the day and then go home for the night... leaving the CPU on.

 

Wait it out... seriously. It seems the program isn't doing anything, but I have waited well over an hour or so for a Navis file to open when I had this same problem.

 

My CPU is i7, 8GB of RAM, so obviously could upgrade a little in that category too.

*Expert Elite*
dgorsman
Posts: 5,106
Registered: ‎10-12-2006
Message 10 of 16 (597 Views)

Re: Opening NWF is slow / not opening.

09-23-2013 01:26 PM in reply to: crk4

Are they coming *directly* from a Sharepoint site, or are you working off a local copy?

 

I can't help but think something in Sharepoint is causing Navisworks to see the file as either needing to be refreshed, or having problems updating the NWCs associated with the DWG files as it loads them.

----------------------------------
If you are going to fly by the seat of your pants, expect friction burns.
Adopt. Adapt. Overcome. Or be overcome.
A good question will be halfway to a good answer.


You are not logged in.

Log into access your profile, ask and answer questions, share ideas and more. Haven't signed up yet? Register

Announcements
Have API Questions?
New Dedicated Forum for Navisworks API

Need installation help?

Start with some of our most frequented solutions to get help installing your software.

Ask the Community