.NET

Reply
Active Member
Posts: 7
Registered: ‎05-05-2010
Message 1 of 8 (519 Views)
Accepted Solution

How to disable AEC warning message

519 Views, 7 Replies
12-18-2013 02:19 PM

We are trying to run an automated process on incoming AutoCAD drawings.  However, the process stops if a drawing has AEC object references, because the warning dialog opens (and the program does not deal with it).  Is there a programmatic way to disable the AEC warning dialog for opening?  Similar to turning off the Proxy warning?  Perhaps a Registry setting?  Thanks in advance for all your help.

*Expert Elite*
Posts: 1,981
Registered: ‎04-29-2006
Message 2 of 8 (512 Views)

Re : How to disable AEC warning message

12-18-2013 02:39 PM in reply to: elliottpd11

Hi,

 

Are you talking about the PROXYNOTICE sysvar? If so, just set it to 0.

Gilles Chanteau
Active Member
Posts: 7
Registered: ‎05-05-2010
Message 3 of 8 (498 Views)

Re: How to disable AEC warning message

12-18-2013 03:53 PM in reply to: elliottpd11

No that doesn't seem to affect the AEC warning.

Distinguished Contributor
SENL1362
Posts: 138
Registered: ‎07-20-2011
Message 4 of 8 (466 Views)

Re: How to disable AEC warning message

12-20-2013 12:14 AM in reply to: elliottpd11

http://adndevblog.typepad.com/autocad/fenton-webb/page/2/ :: Disable Task Dialogs programmatically

These ‘hide dialog’ settings are stored in your %APPDATA%\Autodesk\AutoCAD 2014\R19.1\enu\Support\Profiles\Unnamed Profile\fixedprofile.aws under the HideableDialogs section.

The messages comes from dictionaries stored in the Database(DWG). They can be removed after opening but that's too late to avoid the messages.
Unfortunately up to now i was not able to remove these AEC (proxy/zomby) object from the database before showing it in the Application. The next code failed:
...
aexDB.ReadDwgFile(aecPathname, FileOpenMode.OpenForReadAndWriteNoShare,true, null);
...
if (Regex.IsMatch(id.ObjectClass.DxfName, "Acad_Proxy_Object", RegexOptions.IgnoreCase))
{
//other ghost/zomby like objects
}

if (Regex.IsMatch(proxy.OriginalDxfName, "AEC", RegexOptions.IgnoreCase))

{

//AEC like objects

}

ADN Support Specialist
Balaji_Ram
Posts: 609
Registered: ‎03-21-2011
Message 5 of 8 (417 Views)

Re: How to disable AEC warning message

12-22-2013 09:57 PM in reply to: elliottpd11

Anton (SENL1362) has already provided the right answer. These settings are part of the profile settings.

Just wanted to add to it.

 

If you need to stop those warnings even before the drawing is opened in AutoCAD, you can directly edit the .aws file by parsing it as an XML.

 

Add the following as a child node under the <HideableDialogs>

 

<HideableDialog id="AecUiBase.PreviousVersionOpen" result="8" />

 

This change is to be done in the FixedProfile.aws

 

Regards,

Balaji



Balaji
Developer Technical Services
Autodesk Developer Network

Active Member
Posts: 7
Registered: ‎05-05-2010
Message 6 of 8 (401 Views)

Re: How to disable AEC warning message

12-23-2013 04:44 AM in reply to: Balaji_Ram

We are using AutoCAD 2012, and there is not a <HideableDialogs> node in the FixedProfile.aws, so I am wondering: Do I add a <HideableDialogs> section, and where in the tree does it go?

Distinguished Contributor
SENL1362
Posts: 138
Registered: ‎07-20-2011
Message 7 of 8 (397 Views)

Re: How to disable AEC warning message

12-23-2013 04:53 AM in reply to: elliottpd11
%AppData%\Roaming\Autodesk\AutoCAD Map 3D 2012\R18.2\enu\Support\Profiles


<Profile> <StorageRoot> <AcApData> <HideableDialogs> <HideableDialog id="DrawingOpen.ForeignDWGFile" title="Open - Foreign DWG File" category="Drawing Open" application="" result="1001"> <Preview> <TaskDialog Source="/AcTaskDialogs;component/TaskDialogs.xaml" Id="DrawingOpen.ForeignDWGFile" xmlns="clr-namespace:Autodesk.Windows;assembly=AdWindows"> </TaskDialog> </Preview> </HideableDialog> </HideableDialogs> </AcApData> </StorageRoot> <Name>*Fixed_Profile</Name> <Description> </Description> </Profile>

 

Compare this AWS before and after turning the message OFF

You can turn the messages on in AutoCAD: Options>System>Hidden Messages Settings...

 

 

 

 

Distinguished Contributor
SENL1362
Posts: 138
Registered: ‎07-20-2011
Message 8 of 8 (393 Views)

Re: How to disable AEC warning message

12-23-2013 04:59 AM in reply to: SENL1362

 

 

AWS after turning the AEC message OFF:

<Profile>
	<StorageRoot>
		<AcApData>
			<HideableDialogs>
				<HideableDialog id="DrawingOpen.ForeignDWGFile" title="Open - Foreign DWG File" category="Drawing Open" application="" result="1001">
					<Preview>
						<TaskDialog Source="/AcTaskDialogs;component/TaskDialogs.xaml" Id="DrawingOpen.ForeignDWGFile" 				xmlns="clr-namespace:Autodesk.Windows;assembly=AdWindows">
						</TaskDialog>
					</Preview>
				</HideableDialog>
				<HideableDialog id="AecUiBase.NewerVersionOpen" title="Open Drawing - New Versions of Objects in Drawing" category="Version Conflict Warning" application="AutoCAD Map 3D 2012" result="8">
					<Preview>
						C:\Users\avb\AppData\Local\Temp\AecUiBase.NewerVersionOpen.xaml
					</Preview>
				</HideableDialog>
			</HideableDialogs>
		</AcApData>
	</StorageRoot>
	<Name>
		*Fixed_Profile
	</Name>
	<Description></Description>
</Profile>

 

You are not logged in.

Log into access your profile, ask and answer questions, share ideas and more. Haven't signed up yet? Register

Announcements
Welcome to the new Autodesk Community!
If this is your first visit, click here to get started and make the most of the Community. Let us know what you think of the new experience in the Community Feedback Forum.

Need installation help?

Start with some of our most frequented solutions to get help installing your software.

Ask the Community