.NET

Reply
*Carlos
Message 1 of 5 (247 Views)

Debugging C#, "Start Application" is Unavailable

247 Views, 4 Replies
07-25-2005 05:13 PM
Hello,

I'd like to debug my applications using C#, AutoCAD 2005, and VS 2003, but
when I go to Project->Properties->Debugging the "Start Application" option
is greyed-out.

I feel like I've tried changing every setting in that thing, but it never
allows me to start in AutoCAD.

Any ideas? Has anyone else had this problem?

Thanks for any help.

-Carlos
*Laurence Skoropinski
Message 2 of 5 (247 Views)

Re: Debugging C#, "Start Application" is Unavailable

07-26-2005 12:33 AM in reply to: *Carlos
Carlos, download the labs at
http://usa.autodesk.com/adsk/servlet/index?siteID=123112&id=1911627 and in
lab1 there is information on how to set debug mode

Laurence

"Carlos" wrote in message
news:4910684@discussion.autodesk.com...
Hello,

I'd like to debug my applications using C#, AutoCAD 2005, and VS 2003, but
when I go to Project->Properties->Debugging the "Start Application" option
is greyed-out.

I feel like I've tried changing every setting in that thing, but it never
allows me to start in AutoCAD.

Any ideas? Has anyone else had this problem?

Thanks for any help.

-Carlos
*Carlos
Message 3 of 5 (247 Views)

Re: Debugging C#, "Start Application" is Unavailable

07-26-2005 01:39 PM in reply to: *Carlos
Hi,

That lab was actually what I was following when I was trying to have VS
start AutoCAD. I cannot complete this step:

To test this in AutoCAD we can have Visual Studio start a session of
AutoCAD. Right click on "Lab1" in Solution Explorer and select "Properties".
In the Lab1 Property Pages dialog select "Configuration Properties >
Debugging. In the Start Action area, choose 'Program' under "Debug" and in
"Start applications" use the ellipses button and browse to acad.exe. After
changing this setting hit F5 to launch a session of AutoCAD.

The "Start Action" area is greyed out, including all of its constituents.

I cannot enable this option for any C# applications that I create. Anyone
know what settings I have to have in order to enable this?

Thanks,

Carlos




"Laurence Skoropinski" wrote in message
news:4910794@discussion.autodesk.com...
Carlos, download the labs at
http://usa.autodesk.com/adsk/servlet/index?siteID=123112&id=1911627 and in
lab1 there is information on how to set debug mode

Laurence

"Carlos" wrote in message
news:4910684@discussion.autodesk.com...
Hello,

I'd like to debug my applications using C#, AutoCAD 2005, and VS 2003, but
when I go to Project->Properties->Debugging the "Start Application" option
is greyed-out.

I feel like I've tried changing every setting in that thing, but it never
allows me to start in AutoCAD.

Any ideas? Has anyone else had this problem?

Thanks for any help.

-Carlos
Distinguished Contributor
fantum
Posts: 313
Registered: ‎12-06-2004
Message 4 of 5 (247 Views)

Re: Debugging C#, "Start Application" is Unavailable

07-26-2005 02:22 PM in reply to: *Carlos
After selecting 'Program' under "Debug", Apply the changes.
*Carlos
Message 5 of 5 (247 Views)

Re: Debugging C#, "Start Application" is Unavailable

07-26-2005 03:30 PM in reply to: *Carlos
Oh my goodness,

I wasn't hitting Apply after changing it to Program. Sigh.

Thanks very much.

-Carlos


wrote in message news:4911738@discussion.autodesk.com...
After selecting 'Program' under "Debug", Apply the changes.

You are not logged in.

Log into access your profile, ask and answer questions, share ideas and more. Haven't signed up yet? Register

Announcements
Are you familiar with the Autodesk Expert Elites? The Expert Elite program is made up of customers that help other customers by sharing knowledge and exemplifying an engaging style of collaboration. To learn more, please visit our Expert Elite website.

Need installation help?

Start with some of our most frequented solutions to get help installing your software.

Ask the Community