.NET

Reply
Active Contributor
Chris Ludtke
Posts: 44
Registered: ‎04-12-2005
Message 1 of 8 (147 Views)

Debug mode works fine, Compiled .dll partially works

147 Views, 7 Replies
07-21-2005 04:03 PM
Does anyone have any suggestions?
*Mike Tuersley
Message 2 of 8 (147 Views)

Re: Debug mode works fine, Compiled .dll partially works

07-22-2005 04:45 AM in reply to: Chris Ludtke
> Does anyone have any suggestions?
Can you give more details? Kind of hard to determine if we don't know what
works/doesn't work

-- Mike
___________________________
Mike Tuersley
___________________________
the trick is to realize that there is no spoon...
Distinguished Contributor
thenrich
Posts: 267
Registered: ‎12-03-2003
Message 3 of 8 (147 Views)

Re: Debug mode works fine, Compiled .dll partially works

07-25-2005 06:28 AM in reply to: Chris Ludtke
My suggestion for you would be give us more specific's.

What you've done would be like me calling a mechanic, leaving a message on his answering machine saying my car doesn't run and blindly asking 'What's wrong' and then hang-up and expect an answer
Active Contributor
Chris Ludtke
Posts: 44
Registered: ‎04-12-2005
Message 4 of 8 (147 Views)

Re: Debug mode works fine, Compiled .dll partially works

07-25-2005 10:29 AM in reply to: Chris Ludtke
You are correct.

I have done some further investigation. It appears to be an issue with timing.

I think that it has something to do with nested transactions. I am trying to get more information.
Active Contributor
Chris Ludtke
Posts: 44
Registered: ‎04-12-2005
Message 5 of 8 (147 Views)

Re: Debug mode works fine, Compiled .dll partially works

07-25-2005 10:35 AM in reply to: Chris Ludtke
I have identified some issues.

I have code that creates a "View" object and a "PlotSetting" object. This code appears to work in debug mode.

When I run the portion of this code that is supposed to create the views (or Plotsettings) "Compiled" mode, the view does not appear with the rest of the Views.

The PlotSettings do not appear either.

I am in the process of boiling down the code to the size where I can identify and isolate the problem.

I still think that it has something to do with the way that I am using "Transactions".

So, This should give you some more detailed information. Sorry about the vague positng. Message was edited by: Chris Ludtke
Distinguished Contributor
thenrich
Posts: 267
Registered: ‎12-03-2003
Message 6 of 8 (147 Views)

Re: Debug mode works fine, Compiled .dll partially works

07-25-2005 12:06 PM in reply to: Chris Ludtke
That indeed sounds like timing. I'm assuming that when you use debug and use a breakpoint or something it works fine. The application has time to 'catch-up'. You can try using an application.DoEvents before what you suspect is the problem area.....
Active Contributor
Chris Ludtke
Posts: 44
Registered: ‎04-12-2005
Message 7 of 8 (147 Views)

Re: Debug mode works fine, Compiled .dll partially works

07-25-2005 04:55 PM in reply to: Chris Ludtke
I am learning more about this issue

In my application, I first create a series of Plotsettings and Views

That functionality appears to work fine. I am able manually use both the views and plotsettings after they are created by my utility.

The second half of my utility uses the .net PlotEngine to plot all of the plotsettings.

Through the debugger, this plotting functionality works great - It is really fast.

When ran from the "Compiled" code, it bombs at random points and places the error "Cannot Access PlotSettings Dictionary"

Any Clues?
Active Contributor
Chris Ludtke
Posts: 44
Registered: ‎04-12-2005
Message 8 of 8 (147 Views)

Re: Debug mode works fine, Compiled .dll partially works

07-27-2005 07:42 AM in reply to: Chris Ludtke
It appears that Plotting to File using the PlotEngine works fine in Debug mode regardless of the Value of the "BlotBackground" system variable. This variable needs to be set to "0" if you are trying to plot to a file using compiled code.

You are not logged in.

Log into access your profile, ask and answer questions, share ideas and more. Haven't signed up yet? Register

Announcements
Are you familiar with the Autodesk Expert Elites? The Expert Elite program is made up of customers that help other customers by sharing knowledge and exemplifying an engaging style of collaboration. To learn more, please visit our Expert Elite website.

Need installation help?

Start with some of our most frequented solutions to get help installing your software.

Ask the Community