.NET

Reply
New Member
Moon
Posts: 2
Registered: ‎06-29-2005
Message 1 of 1 (74 Views)

DWF Publish Reactor

74 Views, 0 Replies
06-29-2005 06:13 AM
Anyone knows how to set custom property by publish reactor
correctly? I have the code below,but it does not work! Help me
private static void Publisher_BeginEntity(object sender, PublishEntityEventArgs e)
{

ObjectIdCollection ids=new ObjectIdCollection();
Entity ent=e.get_Entity();
ObjectId id=ent.Id;
if (e.GetEntityNode(id,ids)==1) return;
int nodeid=e.GetNextAvailableNode();

DwfNode node=new DwfNode(nodeid,"dddd");
EPlotPropertyBag propbag=
new EPlotPropertyBag();

EPlotProperty prop1=new EPlotProperty("CCC","AAA");

propbag.Properties.Add(prop1);

propbag.Id=e.get_UniqueEntityId();

if (!e.AddPropertyBag(propbag))
MessageBox.Show("bag error");

if (!e.AddNodeToMap(id,ids,nodeid))
MessageBox.Show("map error\n");

if (!e.AddPropertiesIds(propbag,node))
MessageBox.Show("ids error:"+
CADApp.GetSystemVariable("ERRNO"));
}
}

It report ERRNO=2

Please Help me!

You are not logged in.

Log into access your profile, ask and answer questions, share ideas and more. Haven't signed up yet? Register

Announcements
Are you familiar with the Autodesk Expert Elites? The Expert Elite program is made up of customers that help other customers by sharing knowledge and exemplifying an engaging style of collaboration. To learn more, please visit our Expert Elite website.

Need installation help?

Start with some of our most frequented solutions to get help installing your software.

Ask the Community