Inventor General

Reply
Valued Contributor
Posts: 80
Registered: ‎06-02-2008
Message 1 of 8 (637 Views)
Accepted Solution

parts missing from view

637 Views, 7 Replies
10-01-2010 03:08 AM

in dwg's made from an assembly i someties see that the view does not include all parts. To add to the mystery, a projected view made from the base view that lacked the component(s) view can still include the part. The missing parts are not reference parts, and can sometimes be parts of a subassembly.

 

The attached pdf shows an example:

- view B and C show a horizontal ground plate not visible in the base view

- the projected view shows components visible in the area of detail D, which are not shown in the base view

- near section A-A there is a component missing of which a second item is shown on the left side of the base view.

 

Switching the hidden lines on shows the missing components, but these should not be hidden at all. No settings are altered for the views to include/exclude components. No parts are set to reference. And no design representations are used.

 

Whe i bin the views and start over again, the same thing happens to the same components. However, if i bin the whole DWG file and start over, the parts are present...

 

any suggestions?

 

misha

 

IV2009 / Vault2009 (including service packs etc)

Product Support
Posts: 523
Registered: ‎11-23-2005
Message 2 of 8 (596 Views)

Re: parts missing from view

10-07-2010 04:29 PM in reply to: ASCO-engineering

Hi Misha,

 

If no viewreps and no reference parts are involved and if the assembly and views are up-to-date, I have no immediate answr to your question.

 

Could you send me the dataset at bob.van.der.donck@autodesk.com so that I can have a look?

Let me know if the file size is prohibitive. If that is the case I will forward you a ftp location to dump the files.

 

Cheers.

Bob

Valued Contributor
Posts: 80
Registered: ‎06-02-2008
Message 3 of 8 (587 Views)

Re: parts missing from view

10-07-2010 11:03 PM in reply to: bobvdd

Hi Bob,

 

After having opened the assembly drawings of this machine as well of another machine, i found that the vanished components have now mysteriously re-appeared. I did alter a minor sub assembly that had no relation to the vanishing components. I guess this fored an update of the dwg which is why the components have resurfaced. I guess sending you de 55mb data set will not be of much use would it?

 

regards,

 

Misha

Product Support
Posts: 523
Registered: ‎11-23-2005
Message 4 of 8 (553 Views)

Re: parts missing from view

10-08-2010 09:31 AM in reply to: ASCO-engineering

Glad it worked out for you and that it was indeed a matter of fully updating the assembly.

If the problem reappears with this dataset feel free to ping me.

Bob 

Contributor
feet_first
Posts: 24
Registered: ‎01-24-2012
Message 5 of 8 (222 Views)

Re: parts missing from view

10-05-2012 08:31 AM in reply to: ASCO-engineering

I  have the same problem with parts missing from  a section view but updating the assembly or even editing the section line sketch did not work.  Nothing is hidden in the tree, the display options drop down is set to Always and the section participation is set to Section.   See attached screen shots.  Inventor 2011 x64

Distinguished Contributor
Posts: 141
Registered: ‎12-07-2009
Message 6 of 8 (193 Views)

Re: parts missing from view

10-05-2012 09:42 PM in reply to: feet_first

Hi,

I do have similar issue.

Also sectioning with colour is having more problem.

Try changing your section view into shaded and see what happens.

Thanks.

*Expert Elite*
Posts: 25,269
Registered: ‎04-20-2006
Message 7 of 8 (181 Views)

Re: parts missing from view

10-06-2012 05:02 AM in reply to: feet_first

Attach the imported parts here.

Please mark this response as "Accept as Solution" if it answers your question.
-----------------------------------------------------------------------------------------
Autodesk Inventor 2014 Certified Professional
Autodesk AutoCAD 2013 Certified Professional
Certified SolidWorks Professional
Inventor Professional 2014 Edu 64-bit
http://www.autodesk.com/edcommunity
http://home.pct.edu/~jmather/content/DSG322/inventor_surface_tutorials.htm
Contributor
feet_first
Posts: 24
Registered: ‎01-24-2012
Message 8 of 8 (128 Views)

Re: parts missing from view

10-09-2012 07:40 AM in reply to: ASCO-engineering

The problem was that the section view was cropped.  I had tried deleting the crop but that  did not work.  Editing the crop sketch did work and now I see both instances on the part,

You are not logged in.

Log into access your profile, ask and answer questions, share ideas and more. Haven't signed up yet? Register

Announcements
Welcome to the new Autodesk Community!
If this is your first visit, click here to get started and make the most of the Community. Let us know what you think of the new experience in the Community Feedback Forum.

Need installation help?

Start with some of our most frequented solutions to get help installing your software.

Ask the Community


Inventor Exchange Apps

Created by the community for the community, Autodesk Exchange Apps for Autodesk Inventor helps you achieve greater speed, accuracy, and automation from concept to manufacturing.

Connect with Inventor

Twitter

Facebook

Blogs

Pinterest

Youtube