Inventor General

Reply
*Expert Elite*
Mark_Wigan
Posts: 437
Registered: ‎03-07-2006
Message 11 of 13 (316 Views)

Re: home view after finishing a sketch

10-13-2012 07:57 AM in reply to: Mark_Wigan

i have an interesting development (partial solution) to this that i would like to share that may help others.

 

after having seen this painful behaviour for a couple of years now and having no apparent toggle for whether this is wanted or not i tried to show the workflow clearly to be able to pass this onto our helpful correspondant.

 

for so long experiencing this i thought it would be a simple task however this ended up quite confusing. the result was not consistent every single time i tried to record this workflow. i will cut to the chase to what i suspect will solve this at least for me.

 

i use several part & sheetmetal templates. all (or so i thought) have the home view setup on the iso and the home view is also set to "fit to view".

 

as far as i can tell so far (testing this while at the same time i am trying to get my current project completed) if you ensure that your .ipt templates have the following settings, you should not have the annoying behavior, or at least not as extreme anyway:

 

so, in your ipt template:

 

a) set your home view on the plane that you normally start your sketch on. if you have a sketch in your template then set your home view looking directly at that sketch to the level of zoom that you think will be least annoying (referring to your design spinning away from you as per OP).

b) choose whether to set your home view to "fit to view" or "fixed distance" depending on what you prefer to live with later on when you are designing.

 

what made this difficult to diagnose was that the spin-away behaviour is not so bad when you are merely within the part, but when you are carrying out an edit-in-place, within a large assembly, the spin-away action can be extreme, ie you go from looking at a part that is 100mm long, to finish sketch, to spin-away to be looking at the entire design which may be 50 meters long! you may very well not be finished messing with the sketch. or the other sketches in that part before you see the old spin-away, so that is why the F5 key was getting a workout!

 

i think this will help my situation, and i will keep testing it for a while. for now it seems to be ok. this may explain why sometimes this happens and sometimes this does not happen. i suspect that i have a few templates... some that i started and some that i have kept from time to time that i perhaps did not start, or setup the home view myself.

 

either way i wonder if any readers of this post would care to make a short and simple comment on whether you have tried this and consider it the issue resolved, advise whether your own templates are setup with the home view on the iso or square on the sketch, if any.

 

a quick comment may assist ADesk to follow up if they are able to.

 

ok, i have to get back to the job now :smileyhappy:

 

 

best regards,
- Mark

PDSU 2014 Windows 7, 64bit. (please consider Kudos or Tag as Solved if your issue is sorted)

Distinguished Contributor
petestrycharske
Posts: 150
Registered: ‎09-10-2012
Message 12 of 13 (221 Views)

Re: home view after finishing a sketch

03-06-2013 07:59 AM in reply to: Mark_Wigan

All,

   I teach Inventor classes and had a student ask me the same question you are asking.  From my observations, working with Inventor 2013, the models don't actually rotate back to the home view, but will rotate back to the orientation of the model when a sketch is created.  Therefore, I advise you to orient the part the way you want, then create / edit your sketch.  This will allow you to switch back to the previous orientation, once the sketch is completed.

   I share your frustration with the feature and this automatic rotate should really be a toggle option.  Anyway, if you have any questions, please do not hesitate to contact me.  Hope all else is well and have a most blessed day!

 

Peace,

Pete

New Member
alenard
Posts: 3
Registered: ‎07-26-2012
Message 13 of 13 (181 Views)

Re: home view after finishing a sketch

04-17-2013 02:34 PM in reply to: petestrycharske

Found a very simple workaround:

 

Go into application options and under the sketch tab, regardless of whether or not "Look at sketch plane on sketch creation" is checked, make sure it is checked, hit apply, the uncheck it and hit apply again.

 

You're done.

 

Worked for me, at least! This recycles whatever code is behind this option and reapplies it. Not sure how often I'll have to do this, but the undesirable functionality is now gone.

You are not logged in.

Log into access your profile, ask and answer questions, share ideas and more. Haven't signed up yet? Register

Announcements
Are you familiar with the Autodesk Expert Elites? The Expert Elite program is made up of customers that help other customers by sharing knowledge and exemplifying an engaging style of collaboration. To learn more, please visit our Expert Elite website.

Need installation help?

Start with some of our most frequented solutions to get help installing your software.

Ask the Community


Inventor Exchange Apps

Created by the community for the community, Autodesk Exchange Apps for Autodesk Inventor helps you achieve greater speed, accuracy, and automation from concept to manufacturing.

Connect with Inventor

Twitter

Facebook

Blogs

Pinterest

Youtube