Inventor General

Reply
Valued Contributor
Posts: 98
Registered: ‎09-10-2012
Message 1 of 3 (607 Views)

Stop an iLogic rule automatically running after edit

607 Views, 2 Replies
11-16-2012 01:40 AM

Hi there,

 

I have an ilogic rule which i only need to run when commanded to, as it was created to generate a bunch of drawings and may overwrite things that I have been working on.

 

The problem I have is that whenever I edit the rule, to save the changes I have to click 'OK' or click 'Cancel' then 'Yes' to save changes. Either way, the rule automatically runs.

 

Is there a way to stop this? If not, I thought about using a Yes/No message box which says "Are you sure you want to run this rule?" but I don't know how to write the code.  In the long run I want to make an input form for the rule but I am currently only using 2011.

 

A way around the problem would be to only edit the code, outside of Inventor but I need a better solution as I want to be able to pass this code onto my collegues for them to use.

 

Thanks,

 

Wayne

Wayne Helley
Inventor 2013 Certified Professional

Autodesk Inventor Professional 2011
Windows 7 Enterprise, 64-bit
*Expert Elite*
Posts: 1,020
Registered: ‎09-03-2008
Message 2 of 3 (580 Views)

Re: Stop an iLogic rule automatically running after edit

11-19-2012 12:09 PM in reply to: waynehelley

In the iLogic editor for this rule, go to the Options tab at the top.  Check the option for Suppressed.  When the rule is suppressed, the icon in the iLogic browser will be gray, but you can still run the rule manually by right-clicking the rule in the browser and choosing "Run Rule".

Valued Contributor
Posts: 98
Registered: ‎09-10-2012
Message 3 of 3 (564 Views)

Re: Stop an iLogic rule automatically running after edit

11-20-2012 01:06 AM in reply to: cwhetten

Hi cwhetten,

I have tried this method and it works for internal document rules but for external rules (which are what I need to use), suppressing through the options will make it so that the rule does not run automatically upon closing the rule editor for the first time around but when I return to the editor, the supression box is unchecked.

 

Wayne

Wayne Helley
Inventor 2013 Certified Professional

Autodesk Inventor Professional 2011
Windows 7 Enterprise, 64-bit

You are not logged in.

Log into access your profile, ask and answer questions, share ideas and more. Haven't signed up yet? Register

Announcements
Welcome to the new Autodesk Community!
If this is your first visit, click here to get started and make the most of the Community. Let us know what you think of the new experience in the Community Feedback Forum.

Need installation help?

Start with some of our most frequented solutions to get help installing your software.

Ask the Community


Inventor Exchange Apps

Created by the community for the community, Autodesk Exchange Apps for Autodesk Inventor helps you achieve greater speed, accuracy, and automation from concept to manufacturing.

Connect with Inventor

Twitter

Facebook

Blogs

Pinterest

Youtube