Inventor General

Reply
Active Member
sambaxter23
Posts: 10
Registered: ‎09-21-2011
Message 1 of 5 (365 Views)
Accepted Solution

Removing Obsolete Bitmap Reference From A Part

365 Views, 4 Replies
06-24-2012 10:06 PM

I presumed that such a thing would have been automatic but this one just won't go away!

 

I'm trying to vault of one my parts and it refuses to upload. It's refusing to upload because the part keeps refering to a certain bitmap image. I have removed the reference (from the styles library) to the bitmap image but it's still calling for it to be uploaded!

 

How can I find out why this part still calls for this bitmap image? Why is it still making reference to it even after I have deleted the style which uses it?

 

 

Thanks in advance.

 

Active Member
sambaxter23
Posts: 10
Registered: ‎09-21-2011
Message 2 of 5 (355 Views)

Re: Removing Obsolete Bitmap Reference From A Part

06-25-2012 12:00 AM in reply to: sambaxter23

I did a bit of searching and I have found that this has solved my problem:

http://forums.autodesk.com/t5/Autodesk-Inventor/Remove-texture-from-Project-Library/td-p/2172010

 

By going 'Tools' -> 'Links' I was able to remove the redundant reference.

 

Contributor
rwinokur
Posts: 11
Registered: ‎03-04-2006
Message 3 of 5 (292 Views)

Re: Removing Obsolete Bitmap Reference From A Part

01-07-2013 12:25 PM in reply to: sambaxter23
 

I have some files with hundreds of links and after using a recommended vba routine I found in the Inventor Discussion groups and I can get rid of all but 2.  If I try to get rid of those 2 invneotr crashes.  ONe of the files is our template.  The template file has 2 links remaiing in it that I can't break.  When I make a new doc from the template, the two links turn into 6 links. they multiply.

 

There is one file that ltersally has ove 800 of the these unbrakable lins. Everytime I get any file out of the fault, this file comes with it even if it is an entiely separte and unrelated job.

 

 

Any ideas?

New Member
ScottWSmith
Posts: 1
Registered: ‎02-27-2007
Message 4 of 5 (188 Views)

Re: Removing Obsolete Bitmap Reference From A Part

11-08-2013 05:40 AM in reply to: sambaxter23

I have a pretty good work around for this.

 

Save your idw as an Inventor dwg, open it in AutoCAD. Those pesky bitmaps will be listed as unreferenced Xrefs. Detach them, save. Open the dwg in INventor and either check it in to Vault as is or overright the IDW and check it back in.

 

Works like a charm

 

Scott

Contributor
rwinokur
Posts: 11
Registered: ‎03-04-2006
Message 5 of 5 (155 Views)

Re: Removing Obsolete Bitmap Reference From A Part

11-12-2013 12:17 PM in reply to: ScottWSmith

Scott,

Thanks for the reply.  My template is an Inventor DWG and has no bitmaps listed as xrefs in it. Still have not been able to get rid of them

You are not logged in.

Log into access your profile, ask and answer questions, share ideas and more. Haven't signed up yet? Register

Announcements
Are you familiar with the Autodesk Expert Elites? The Expert Elite program is made up of customers that help other customers by sharing knowledge and exemplifying an engaging style of collaboration. To learn more, please visit our Expert Elite website.

Need installation help?

Start with some of our most frequented solutions to get help installing your software.

Ask the Community


Inventor Exchange Apps

Created by the community for the community, Autodesk Exchange Apps for Autodesk Inventor helps you achieve greater speed, accuracy, and automation from concept to manufacturing.

Connect with Inventor

Twitter

Facebook

Blogs

Pinterest

Youtube