Inventor General

Reply
Contributor
michaelmcgovern
Posts: 17
Registered: ‎02-16-2010
Message 1 of 7 (471 Views)

Inventor stopped accepting text shortcuts (i.e.: "e" for extrude)

471 Views, 6 Replies
05-22-2012 05:34 AM

Until a couple weeks ago, I relied on several text shortcuts in Inventor (2012 Professional with SP1).  I don't know exactly what they're called, but for exemple I'd press "e" after creating a sketch and the extrude command would begin.  Also if I pressed "h", the hole command would begin.  These functions stopped working suddenly.

 

Now, whenever I press a letter key during Inventor operation, text appears at the bottom of the screen "Command alias input: [key]"  (See attached screenshot).

 

Any input would be greatly appriciated.

*Expert Elite*
PaulMunford
Posts: 891
Registered: ‎11-13-2006
Message 2 of 7 (451 Views)

Re: Inventor stopped accepting text shortcuts (i.e.: "e" for extrude)

05-22-2012 02:07 PM in reply to: michaelmcgovern

I think that you want to disable the command Alias input box:

http://wikihelp.autodesk.com/Inventor/enu/2012/Help/0073-Autodesk73/0285-Work_Env285/0303-Customiz30...

The CAD Setter Out Blog @CadSetterOut

Inventor Surfacing | AutoCAD | CAD Standards
 
Please use the Mark Solutions! Accept as Solution or Give Kudos! Kudos functions - Thank you!
Contributor
michaelmcgovern
Posts: 17
Registered: ‎02-16-2010
Message 3 of 7 (438 Views)

Re: Inventor stopped accepting text shortcuts (i.e.: "e" for extrude)

05-23-2012 08:33 AM in reply to: PaulMunford

That option is disabled in my Application Options.  If I check the "Command Alias Input" box, this causes a prompt to pop up when you start typing.  It appears to be very related to this, but that option is currently turned off and I'm still having problems with activating my shortcuts.

*Pro
sbixler
Posts: 1,869
Registered: ‎09-15-2003
Message 4 of 7 (426 Views)

Re: Inventor stopped accepting text shortcuts (i.e.: "e" for extrude)

05-23-2012 11:42 AM in reply to: michaelmcgovern

This has happened to a number of Inventor 2012 users, me included.  You will have to re-establish those shortcuts by Tools > Options > Customize > Keyboard.  When you've got them back the way you want, Export to a location you can remember.  If (when) it happens again, you just have to Import to get them all back.  I still have no idea what causes this, nothing I can relate it to.  It seems random, and usually only a subset of the keyboard shortcuts are lost.

Contributor
michaelmcgovern
Posts: 17
Registered: ‎02-16-2010
Message 5 of 7 (424 Views)

Re: Inventor stopped accepting text shortcuts (i.e.: "e" for extrude)

05-23-2012 11:55 AM in reply to: sbixler

Good to hear I am not the only one.  I'll give that a try.  Just found another feature that has stopped working:  When I am sketching shapes (rectangle, line, circle) the ability to type a dimension after the first click no longer exists.  I have to draw a shape (2 clicks) then use the dimension command to add the first dimension to the shape.  There are a few other shortcuts that have stopped working but they slip my mind right now.

 

It's as if somebody turned off every feature that speeds up Inventor and makes repetitive tasks easier. I feel like there should be a checkbox somewhere that reads something like "disable all shortcuts" that I have to uncheck...

Product Support
bobvdd
Posts: 527
Registered: ‎11-23-2005
Message 6 of 7 (394 Views)

Re: Inventor stopped accepting text shortcuts (i.e.: "e" for extrude)

05-30-2012 01:59 PM in reply to: michaelmcgovern

What happens if you reset your shortcut keys. Don't you get them back as one would expect?

You can do this in the Customize dialog > Keyboard tab > Reset all keys button

 

The dimension problem could be related to the following checkbox that is turned off:

 

Application Options > Sketch tab > Heads up display settings button > Create dimensions when inputting dimension value.

 

Bob

New Member
miloradrakić5843
Posts: 2
Registered: ‎04-09-2010
Message 7 of 7 (279 Views)

Re: Inventor stopped accepting text shortcuts (i.e.: "e" for extrude)

12-30-2012 07:50 AM in reply to: michaelmcgovern

Try this:

1. Open Language bar (in Win7) & change language  to EN (United States)

2. Go to Inv2013: Tools, Customize, Keyboard and select Reset All Keys, Ok

 

It works for me!

You are not logged in.

Log into access your profile, ask and answer questions, share ideas and more. Haven't signed up yet? Register

Announcements
Are you familiar with the Autodesk Expert Elites? The Expert Elite program is made up of customers that help other customers by sharing knowledge and exemplifying an engaging style of collaboration. To learn more, please visit our Expert Elite website.

Need installation help?

Start with some of our most frequented solutions to get help installing your software.

Ask the Community


Inventor Exchange Apps

Created by the community for the community, Autodesk Exchange Apps for Autodesk Inventor helps you achieve greater speed, accuracy, and automation from concept to manufacturing.

Connect with Inventor

Twitter

Facebook

Blogs

Pinterest

Youtube