Inventor General

Posts: 180
Registered: ‎10-07-2011
Message 1 of 5 (281 Views)
Accepted Solution

ILogic Edit Rule Error !!Help!!

281 Views, 4 Replies
10-04-2012 02:47 PM

I got this error popping up every time I open an iLogic edit rule and all my snippets are gone… I have no clue how this happened or how to fix it. Now it has started doing it on a different computer in our office. Can someone please help me fix this problem? The error dialog box is in the image below. Thank you for any help you might be able to give. 


Edit Rule.png

*Expert Elite*
Posts: 2,772
Registered: ‎03-08-2006
Message 2 of 5 (275 Views)

Re: ILogic Edit Rule Error !!Help!!

10-04-2012 03:40 PM in reply to: jddickson

Hi jddickson,


Is this Inventor 2013 running on Windows 7?


If so do you get the same thing if you close Inventor and then right-click on the Inventor icon and choose Run as Administrator?


I hope this helps.
Best of luck to you in all of your Inventor pursuits,

  solution.png  Did you find this reply helpful ? If so please use the Accept as Solution or  Kudos button below.

Posts: 180
Registered: ‎10-07-2011
Message 3 of 5 (243 Views)

Re: ILogic Edit Rule Error !!Help!!

10-05-2012 06:19 AM in reply to: Curtis_Waguespack

Yes I am running Inventor 2013 on Windows 7 and choosing Run as Administrator did fix the problem. Thank you for all your help. Do you know why it’s doing that and how to fix it long term?


Thank you again for your help this gets me back on my feet.

Posts: 16
Registered: ‎04-20-2012
Message 4 of 5 (127 Views)

Re: ILogic Edit Rule Error !!Help!!

04-04-2013 01:25 AM in reply to: jddickson


I hope you don't mind me tagging to this message string but I have the same problem and have done the "Run as Administrator" option but still get the same error message when entering the edit rule window.

I have to crash-out Inventor.

This is only on the one machine running Inventor 2013 & Win7. ( All up-to-date )

Many thanks in advance.




Posts: 16
Registered: ‎04-20-2012
Message 5 of 5 (121 Views)

Re: ILogic Edit Rule Error !!Help!!

04-04-2013 03:34 AM in reply to: jddickson

Oh really sorry, there was a bit of a clue in the Error Message that the user.config file had becaome read-only or hidden.


Simply unhiding the file makes everything work OK.


Apologies for the extra messages but it might help someone some day.



You are not logged in.

Log into access your profile, ask and answer questions, share ideas and more. Haven't signed up yet? Register

Are you familiar with the Autodesk Expert Elites? The Expert Elite program is made up of customers that help other customers by sharing knowledge and exemplifying an engaging style of collaboration. To learn more, please visit our Expert Elite website.

Need installation help?

Start with some of our most frequented solutions to get help installing your software.

Ask the Community

Inventor Exchange Apps

Created by the community for the community, Autodesk Exchange Apps for Autodesk Inventor helps you achieve greater speed, accuracy, and automation from concept to manufacturing.

Connect with Inventor