Inventor General

Reply
Member
Fruity13
Posts: 3
Registered: ‎10-20-2013
Message 1 of 4 (495 Views)
Accepted Solution

Fillet acting strange

495 Views, 3 Replies
10-20-2013 03:13 PM

Hello everyone,

 

I'm new at inventor and have done some tutorials already but not all. I've stopped at the 2nd assembly because I wanted to start a project of my own. Yet I have stumbled upon a strange behavior of the fillet command. It seems to work fine on one side of a part, but works odd on the other side. Inventor is telling me something is wrong but I can't pinpoint what it is I am doing wrong.

 

Can some wizards help me at this? I'm trying to fillet the handle of this part but this strange swirl happens.

 

Funny swirl (right side)                                          All is fine (left side)

swirl finished.png        fine finished.png

 

Now I don't know what happened. Can somebody tell me what I did wrong?

I'll put in the links to the part files below (Inventor 2013).

 

Left Plate (all is fine)

 

Right plate (swirly thingy)

 

Thank you for helping me out.

*Expert Elite*
JDMather
Posts: 26,251
Registered: ‎04-20-2006
Message 2 of 4 (484 Views)

Re: Fillet acting strange

10-20-2013 04:39 PM in reply to: Fruity13

You are missing many (all) dimensions and many geometry constraints.  (become very familiar with Tangent constraints)

The origin location does not have any logic.

 

I recommend you set this project aside for a couple of days and take the time to go through these.

http://home.pct.edu/~jmather/SkillsUSA%20University.pdf
http://inventortrenches.blogspot.com/p/inventor-tutorials.html
http://wikihelp.autodesk.com/enu?adskContextId=HELP_TUTORIALS&language=ENU&release=2014&product=Inve...

 

Then I recommend that you approach this model with multi-body solids technique.

Please mark this response as "Accept as Solution" if it answers your question.
-----------------------------------------------------------------------------------------
Autodesk Inventor 2014 Certified Professional
Autodesk AutoCAD 2013 Certified Professional
Certified SolidWorks Professional
Inventor Professional 2015 64-bit
http://www.autodesk.com/edcommunity
http://home.pct.edu/~jmather/content/DSG322/inventor_surface_tutorials.htm
Member
Fruity13
Posts: 3
Registered: ‎10-20-2013
Message 3 of 4 (463 Views)

Re: Fillet acting strange

10-21-2013 12:46 AM in reply to: JDMather

Thank you for taking the time to look at my issue.

I know some basics about constraints but I'm still struggling with them. The reason there are almost no constraints in this sketch is because the sketch is copied over from an image. I have no exact measurements nor needs for it to be constrained or centered in any way.

 

In the previous tutorials I have followed the sketches had predefined constraints (15 mm here, 45° there, ...) but on this sketch nothing is predefined.

What do you suggest to constrain on this sketch? When I add constraints to this sketch it deviates from my original plan.

Will constraining any of the curves on the handle make the fillet command work on both sides?

 

Thank you.

 

Member
Fruity13
Posts: 3
Registered: ‎10-20-2013
Message 4 of 4 (413 Views)

Re: Fillet acting strange

10-24-2013 05:32 AM in reply to: Fruity13

I got to a point that I am happy with the result but don't know what triggered the swirl.

 

I tried constraining the hell out of the sketch without changing the sketch. It wasn't easy, I could almost only dimension the sketch. I did not change the center point because it is a sketch-sketch. I copied it from a drawing and I have no intention to revolve it. Sadly after re-filleting the plate the swirl was still there on the right side while the left side was OK.

 

Tangent constraint did not work well, or I used it incorrectly. The sketch deviated off of the original. But the tangent made me think. There is a second option in the fillet command. The option "Tangent (G2) fillet" worked wonders. I could not see any noticeable difference between normal fillet and tangent fillet but the swirl was gone. So I went with the tangent fillet.

 

The original problem is fixed for me. Please post more comments and tips if you want. I would be happy to try some out.

You are not logged in.

Log into access your profile, ask and answer questions, share ideas and more. Haven't signed up yet? Register

Announcements
Are you familiar with the Autodesk Expert Elites? The Expert Elite program is made up of customers that help other customers by sharing knowledge and exemplifying an engaging style of collaboration. To learn more, please visit our Expert Elite website.

Need installation help?

Start with some of our most frequented solutions to get help installing your software.

Ask the Community


Inventor Exchange Apps

Created by the community for the community, Autodesk Exchange Apps for Autodesk Inventor helps you achieve greater speed, accuracy, and automation from concept to manufacturing.

Connect with Inventor

Twitter

Facebook

Blogs

Pinterest

Youtube