Inventor General Discussion

Reply
Member
gerry.salinas
Posts: 4
Registered: ‎06-29-2011
Message 1 of 4 (550 Views)
Accepted Solution

Solid body visibility in drawings

550 Views, 3 Replies
09-06-2012 03:15 PM

Hi,

 

I'm making drawings of assemblies in Inventor 2012 and was wondering how to turn off the visibility of specific solid bodies within a single part containing multiple bodies, or make it match the visibility in the assembly and part file itself.

 

In particular my situation is that I have a camera whose part model includes a solid body for its view cone. The visibility of this solid is turned off, so when opening the camera itself, or the assembly containing it, it doesn't appear, but when I place that assembly or part in a drawing it's included, and the only way I've figured out to get rid of it is to turn the whole camera's visibility off within the drawing.

 

Thanks for the help!

Employee
jingyi.liu
Posts: 120
Registered: ‎08-28-2007
Message 2 of 4 (536 Views)

Re: Solid body visibility in drawings

09-06-2012 06:33 PM in reply to: gerry.salinas

Hi Gerry

As you described, Inventor 2012 can't manage Solid visibility in its drawing, but you can make solids into components, then place the assembly in the drawing. In assembly environment, you can create different View Representation to control part visibility, then choose corresponding view .

 

BTW, Inventor 2013 has such capability of  visibility control in its drawing.

 

View.png

Inventor Professional 2015

Jingyi Liu
Quality Assurance Team
Autodesk
Contributor
neil.hamilton
Posts: 25
Registered: ‎04-22-2013
Message 3 of 4 (342 Views)

Re: Solid body visibility in drawings

07-17-2013 10:12 AM in reply to: jingyi.liu

I'm very happy to hear 2013 can do it. I have 2013. Can somebody please explain how?

"If wishes were horses,
we'd all be eating steak!"
*Expert Elite*
Curtis_Waguespack
Posts: 2,821
Registered: ‎03-08-2006
Message 4 of 4 (338 Views)

Re: Solid body visibility in drawings

07-17-2013 10:18 AM in reply to: neil.hamilton

Hi neil.hamilton,

 

  1. In the part file create a new View Representation.
  2. Then turn off the Visibility of the solid body.
  3. Then in your drawing file, make sure your view is using the View Representation that you created as shown in jingyi.liu's screen shot.

Related links:

http://wikihelp.autodesk.com/Inventor/enu/2013/Help/1310-Autodesk1310/1500-Parts1500/1603-Represen16...

http://www.inventortales.com/2011/04/view-representationns-in-part-files-new.html

 

I hope this helps.
Best of luck to you in all of your Inventor pursuits,
Curtis
http://inventortrenches.blogspot.com



  solution.png  Did you find this reply helpful ? If so please use the Accept as Solution or  Kudos button below.





You are not logged in.

Log into access your profile, ask and answer questions, share ideas and more. Haven't signed up yet? Register

Announcements
Are you familiar with the Autodesk Expert Elites? The Expert Elite program is made up of customers that help other customers by sharing knowledge and exemplifying an engaging style of collaboration. To learn more, please visit our Expert Elite website.

Need installation help?

Start with some of our most frequented solutions to get help installing your software.

Ask the Community


Inventor Exchange Apps

Created by the community for the community, Autodesk Exchange Apps for Autodesk Inventor helps you achieve greater speed, accuracy, and automation from concept to manufacturing.

Connect with Inventor

Twitter

Facebook

Blogs

Pinterest

Youtube