Inventor General Discussion

New Member
Posts: 2
Registered: ‎03-05-2013
Message 1 of 3 (198 Views)

Inventor Student Edition 2013 Model Import Gone Wrong

198 Views, 2 Replies
04-01-2013 02:05 PM

I have a project I'm working on and recently imported a model from  Now, whenever I try and edit the project I get the message: "Cannot modify the library file *.iam Component *.iam is not checked out to you.  Edits are not allowed on this file."  the only solution I could find is purging the files, which I don't know how to do and it was supposedly removed in the 2013 update anyways.  I also get a message "The file is being saved in a library folder.  Because files in a library folder are not editable, once you save this file you will not be able to modify it.  Do you wish to continue?"  I have tried saving everywhere, even the C drive (which is obviously not a folder to begin with).  What have I done?  And how can I fix it?

*Expert Elite*
Posts: 2,802
Registered: ‎03-08-2006
Message 2 of 3 (184 Views)

Re: Inventor Student Edition 2013 Model Import Gone Wrong

04-01-2013 02:16 PM in reply to: PR_RamFan

Hi PR_RamFan,


Here's a very similar post at this link from just a few weeks ago, there are some suggestions that might help:


I suspect that the import destination file location is causing an issue here, you might provide more information about the file paths, including your Inventor Project path, and maybe some screen shots.


I hope this helps.
Best of luck to you in all of your Inventor pursuits,

  solution.png  Did you find this reply helpful ? If so please use the Accept as Solution or  Kudos button below.

New Member
Posts: 2
Registered: ‎03-05-2013
Message 3 of 3 (169 Views)

Re: Inventor Student Edition 2013 Model Import Gone Wrong

04-01-2013 02:44 PM in reply to: Curtis_Waguespack

They are both (importer and importee) saved in Public Documents, but I have tried moving them to every other place I can think of (Desktop, C Drive, flash drive, etc), Even after deleting the component that resulted in the problem, the message persisted.  Unfortunately, I have made no backups that don't have the same problem.  I think it's more of a Vault problem.  I was creating the project unconnected to Vault and the object I imported was "claimed."  I think somehow it took over my project.  Does that help at all?

You are not logged in.

Log into access your profile, ask and answer questions, share ideas and more. Haven't signed up yet? Register

Are you familiar with the Autodesk Expert Elites? The Expert Elite program is made up of customers that help other customers by sharing knowledge and exemplifying an engaging style of collaboration. To learn more, please visit our Expert Elite website.

Need installation help?

Start with some of our most frequented solutions to get help installing your software.

Ask the Community

Inventor Exchange Apps

Created by the community for the community, Autodesk Exchange Apps for Autodesk Inventor helps you achieve greater speed, accuracy, and automation from concept to manufacturing.

Connect with Inventor