Inventor General Discussion

Reply
Distinguished Contributor
Karol-Or
Posts: 265
Registered: ‎11-28-2011
Message 1 of 8 (206 Views)

Hole with project edges doesn't move

206 Views, 7 Replies
01-01-2013 11:52 AM

In an assembly i project a circle.
I use the new center point with the hole wizard and save the assembly and the parts.
When i move the original circle the hole doesn't move with it, and when i try to edit the hole's sketch there are no dimensions.
So, i cannot move the hole.

*Pro
sbixler
Posts: 1,872
Registered: ‎09-15-2003
Message 2 of 8 (195 Views)

Re: Hole with project edges doesn't move

01-01-2013 01:49 PM in reply to: Karol-Or

Did you do this in an assembly sketch or in a part sketch?  That is, were you editing the part when you projected the hole?  It sounds as if you did this in the assembly, creating an assembly sketch and an assembly feature.  Is this what you intended to do?  If so, then after editing the part, changing the hole dimensions, you need to update the assembly.  Then the projected hole moves in the assembly sketch.

Distinguished Contributor
Karol-Or
Posts: 265
Registered: ‎11-28-2011
Message 3 of 8 (171 Views)

Re: Hole with project edges doesn't move

01-02-2013 07:33 AM in reply to: sbixler

no, i edit a part in an assembly. i made a sketch on a face, frojected a circulra edge and extruded a hole in that part.

Now, i moved the circular edge, but the hole in the part file, nor in the assembly, didn't move with it.

In the part's file there are no dimensions in the hole's sketch, just a Reference no, i guess to the assembly.

So, i cannot move the hole in no way: not by moving the circular edge and not manually.

*Pro
sbixler
Posts: 1,872
Registered: ‎09-15-2003
Message 4 of 8 (165 Views)

Re: Hole with project edges doesn't move

01-02-2013 07:54 AM in reply to: Karol-Or

Something isn't right.  What you are describing is Adaptive functionality, and it should work exactly as you have done it.  That is, when projecting the hole edge into a different part's sketch, you should see the adaptive symbol appear next to that part in the assembly browser, and also next to the sketch.  When the original part's hole is moved, the adaptive sketch (and any features made from it) should move when the assembly is updated.

*Expert Elite*
blair
Posts: 3,958
Registered: ‎11-13-2006
Message 5 of 8 (150 Views)

Re: Hole with project edges doesn't move

01-02-2013 09:02 AM in reply to: Karol-Or

Post the part here, so it can be looked at.

Did you find this reply helpful ? If so please use the Accept as Solution or Kudos button below.

IV2015 up1 PDSU / Sim Mech 2015 /
Win7-64
EVGA X79 - Classified, iCore7 3930k 32Gb Quad-Channel
950Gb (2 x 500Gb Sata III SSD RAID0 Adaptec 6805E Controller)
Nvidia GTX-690 Classified - 335.23
SpacePilot Pro 3.17.7, 6.17., 4.11
Distinguished Contributor
Karol-Or
Posts: 265
Registered: ‎11-28-2011
Message 6 of 8 (142 Views)

Re: Hole with project edges doesn't move

01-02-2013 10:45 AM in reply to: blair

There is adaptivity, but no use

*Expert Elite*
blair
Posts: 3,958
Registered: ‎11-13-2006
Message 7 of 8 (136 Views)

Re: Hole with project edges doesn't move

01-02-2013 10:54 AM in reply to: Karol-Or

Works fine here. Open Part4, place sketch on face, project hole from Part2, place centermark at center of projected hole from Part2. Exit sketch, use Hole Feature to create hole. Open Part2, change 20mm to 30mm, close sketch in Part2. Return to Assembly and hole in Part4 has moved to re-align with Part2.

 

I am on a newer version of Inventor so I am unable to set files back to you.

Did you find this reply helpful ? If so please use the Accept as Solution or Kudos button below.

IV2015 up1 PDSU / Sim Mech 2015 /
Win7-64
EVGA X79 - Classified, iCore7 3930k 32Gb Quad-Channel
950Gb (2 x 500Gb Sata III SSD RAID0 Adaptec 6805E Controller)
Nvidia GTX-690 Classified - 335.23
SpacePilot Pro 3.17.7, 6.17., 4.11
*Pro
sbixler
Posts: 1,872
Registered: ‎09-15-2003
Message 8 of 8 (129 Views)

Re: Hole with project edges doesn't move

01-02-2013 11:16 AM in reply to: Karol-Or

I don't know how it happened, but the hole in Part4 has its own center point separate from the center of the projected circle from Part2.  Edit Part4, edit Hole1, click on the Centers button, then select the center of the projected circle and ctrl-select (unselect) the other point in the sketch.

 

For future attempts like this, just change the center of the projected circle to a center point (use the Center Point tool to toggle between Point and Center Point).  Then there's no issue with an added point not constraining to that center (which is what I suspect happened in this case.).

 

Edit: I just figured out where that other point came from: it's the projected origin of your part.  You just picked the wrong hole center by mistake-- they must have been very close together originally.

 

Oh, one other thing-- always tell us what version you're using at the beginning.  It saves people time if they know they won't be able to open your file, or you won't be able to open theirs.

You are not logged in.

Log into access your profile, ask and answer questions, share ideas and more. Haven't signed up yet? Register

Announcements
Are you familiar with the Autodesk Expert Elites? The Expert Elite program is made up of customers that help other customers by sharing knowledge and exemplifying an engaging style of collaboration. To learn more, please visit our Expert Elite website.

Need installation help?

Start with some of our most frequented solutions to get help installing your software.

Ask the Community


Inventor Exchange Apps

Created by the community for the community, Autodesk Exchange Apps for Autodesk Inventor helps you achieve greater speed, accuracy, and automation from concept to manufacturing.

Connect with Inventor

Twitter

Facebook

Blogs

Pinterest

Youtube