Inventor General Discussion

Reply
Contributor
andyb
Posts: 13
Registered: ‎10-23-2012
Message 1 of 3 (793 Views)

Constraint problems in Assemblies in Inventor 2013

793 Views, 2 Replies
07-02-2013 02:27 AM

Morning

 

I am having a few weird senerios with constraints in my assemblies. I'm hoping others have experienced them and can share their knowldege on getting rid of them...they are driving me slowly crazy!!!

 

I have modelled a very simplistic rectangular tank with stiffening angles down either side. I did the normal thing, constrain one and pattern. One constraint is placed where I mate the angle to the back wall and offset -757mm. This constraint places fine. When I put the tank assembly into the top level assembly this constraint shows as an error. If I go into the tank and edit the constraint and click OK without changing anything the error is fixed. However, the next time i go and place on item and move a part in either the top level or sub assemblies this error arises again. If I remove this constraint another will do exactly the same.

 

It's annoying because I haven't done anything wrong yet IV loves to tell me I can't model correctly.

*Expert Elite*
JDMather
Posts: 26,259
Registered: ‎04-20-2006
Message 2 of 3 (782 Views)

Re: Constraint problems in Assemblies in Inventor 2013

07-02-2013 03:56 AM in reply to: andyb

Attach the assembly here.

Please mark this response as "Accept as Solution" if it answers your question.
-----------------------------------------------------------------------------------------
Autodesk Inventor 2014 Certified Professional
Autodesk AutoCAD 2013 Certified Professional
Certified SolidWorks Professional
Inventor Professional 2015 64-bit
http://www.autodesk.com/edcommunity
http://home.pct.edu/~jmather/content/DSG322/inventor_surface_tutorials.htm
Contributor
andyb
Posts: 13
Registered: ‎10-23-2012
Message 3 of 3 (744 Views)

Re: Constraint problems in Assemblies in Inventor 2013

07-16-2013 12:56 AM in reply to: JDMather

Hi sorry for the late reply, I've been away for a few days. I got around the problem by turning the adaptivity off of another part and hay presto no more clashing constraints (even though the constraints weren't realted???) I suppose it is just another strange happening in Inventor Land!

You are not logged in.

Log into access your profile, ask and answer questions, share ideas and more. Haven't signed up yet? Register

Announcements
Are you familiar with the Autodesk Expert Elites? The Expert Elite program is made up of customers that help other customers by sharing knowledge and exemplifying an engaging style of collaboration. To learn more, please visit our Expert Elite website.

Need installation help?

Start with some of our most frequented solutions to get help installing your software.

Ask the Community


Inventor Exchange Apps

Created by the community for the community, Autodesk Exchange Apps for Autodesk Inventor helps you achieve greater speed, accuracy, and automation from concept to manufacturing.

Connect with Inventor

Twitter

Facebook

Blogs

Pinterest

Youtube