Inventor Engineer-to-Order

Reply
Distinguished Contributor
ludesroc
Posts: 155
Registered: ‎05-03-2005
Message 1 of 2 (85 Views)

ETO Studio 2013 vs Rule Annotations

85 Views, 1 Replies
01-29-2013 11:23 AM

Hi,

 

When accessing parameters through the ETO Model Browser in VS...It seams that VS doesn't recognize the rule annotations...

 

 

For example:

 

' Insulation.
<%%Category("Door Configuration"),_
%%DisplayName("Door Insulation"),_
%%Prompt("Door insulation"),_
%%Choices("Fiberglass|Urethane"),_
%%EvalChoices("False"),_
%%ChoicesDelimiter("|") >_
Parameter Rule DoorInsulationMaterial As String = "Fiberglass"

 

The parameter window only shows "Fiberglass"...and not the other choice option for this rule. 

 

Is there a setting that needs to be configured so VS displays the annotations correctly?

 

I'm using Visual Studio 2010 Professional.

 

Regards,

Ludesroc
Board Manager
Posts: 220
Registered: ‎08-23-2006
Message 2 of 2 (81 Views)

Re: ETO Studio 2013 vs Rule Annotations

01-29-2013 12:35 PM in reply to: ludesroc

This is one of the changes between the "old" Inventor-based IDE and the new ETO Studio IDE.  ETO Studio is meant to be a "developer" interface, not a pseudo-end-user interface.  Hence we changed the behavior of the new "Parameters" dialog, as compared to the old-IDE "Part Editor" dialog.  The new Parameters dialog expects that you, as a developer, will input a formula to specify the value for each parameter ... and hence does not respect the rule-annotations regarding data (non-formula) input.

 

I.e., this means you have to input strings with double-quotes, and Names with a leading colon.

 

Personally, I think we (that is, "I") took this a step too far with respect to Name-type parameters.  It would have been easy to use the rule-annotations to "suggest" appropriate values, or something like that, and insert it with the leading colon.

 

Note that rule-annotations don't go away.  They're just not quite as useful.  ETO Studio respects other annotations, e.g., %%DisplayName for the Model Browser window and %%Category, etc., for the Model Properties window.

 

As much as I want people to use ETO Studio, I will point out that the old IDE is still available, just disabled by default.

 

 



Jon Balgley
Autodesk Configurator 360 / Inventor ETO team
Autodesk, Inc.

You are not logged in.

Log into access your profile, ask and answer questions, share ideas and more. Haven't signed up yet? Register

Announcements
Manufacturing Community
The Manufacturing Community provides additional access to tips, tutorials, blogs and networking with peers.

Need installation help?

Start with some of our most frequented solutions to get help installing your software.

Ask the Community


Inventor Exchange Apps

Created by the community for the community, Autodesk Exchange Apps for Autodesk Inventor helps you achieve greater speed, accuracy, and automation from concept to manufacturing.

Connect with Inventor

Twitter

Facebook

Blogs

Pinterest

Youtube