Inventor Customization

Reply
rmn
Member
Posts: 3
Registered: ‎11-15-2012
Message 1 of 4 (228 Views)
Accepted Solution

iLogic error can not find excel file after saving file as a template

228 Views, 3 Replies
12-06-2012 12:02 PM

I'm linking an excel file to an .ipt file with iLogic code determining if the Material type is a certian value it will find the correct material thickness. These file work great when working on them thru Vault but when I "Save As Template" and create this file where our other template files are located (not Vault) this fuction does not work. I have realized that I had to place the a copy of the excel file in the same file folder as the template ipt, but even this does not fix the issue. 

 

I recieve this error:

Error in rule: Material, in document: Part6

'MWW Materials (Inventor).xlsx' could not be found. Check the spelling of the file name, and verify that the file location is correct.

If you are trying to open the file from your list of most recently used files, make sure that the file has not been renamed, moved, or deleted.

 

It seems completly countintutive that just saving the file as a template file would cause this not to work when all files that are required are located in the same file folder.

 

Maybe I need a referance to the excel document within the iLogic code. I'm at a loss on this, any suggestions would be welcome.

rmn
Member
Posts: 3
Registered: ‎11-15-2012
Message 2 of 4 (227 Views)

Re: iLogic error can not find excel file after saving file as a template

12-06-2012 12:04 PM in reply to: rmn

Additional info that did not get attached

ADN Support Specialist
xiaodong.liang
Posts: 1,198
Registered: ‎06-12-2011
Message 3 of 4 (178 Views)

Re: iLogic error can not find excel file after saving file as a template

01-06-2013 10:05 PM in reply to: rmn

hi,

 

It looks this post was marked as solved by mistake? 

 

anyway, the original description shows the Excel file cannot be found. Have you tried with absolute path to see if it works? e.g.

 

MultiValue.List("Material") = GoExcel.CellValues("C:\MWW Materials (Inventor).xlsx", "VP", "A2", "A600")


Xiaodong Liang
Developer Technical Services
Autodesk Developer Network

rmn
Member
Posts: 3
Registered: ‎11-15-2012
Message 4 of 4 (167 Views)

Re: iLogic error can not find excel file after saving file as a template

01-15-2013 06:07 PM in reply to: xiaodong.liang
Yes, in this instance when using Vault and creating a template it is necessary to give an absolute path which I have done and solves the problem. The only additional requirement was to add this path as a library in the .ipj. Thanks for your response.

You are not logged in.

Log into access your profile, ask and answer questions, share ideas and more. Haven't signed up yet? Register

Announcements
Are you interested in helping shape the Autodesk Community?
We’re looking at a few different ways to improve the “All Forums” landing page and need your feedback! If interested, please take a few minutes to fill out the following Usability Study. Thank you for your time!

Need installation help?

Start with some of our most frequented solutions to get help installing your software.

Ask the Community


Inventor Exchange Apps

Created by the community for the community, Autodesk Exchange Apps for Autodesk Inventor helps you achieve greater speed, accuracy, and automation from concept to manufacturing.

Connect with Inventor

Twitter

Facebook

Blogs

Pinterest

Youtube