Installation & Licensing

Reply
New Member
Posts: 2
Registered: ‎02-21-2013
Message 11 of 16 (621 Views)

Re: Silent Uninstall of AutoCAD 2011 via SCCM

02-21-2013 11:10 AM in reply to: tmpamlrs

After installation of autodesk product , we will get the registry with uninstal string of autodesk silent parameter.

"""C:\Program Files\Autodesk\Inventor 2012\Setup\Setup.exe"" /q /P {7F4DD591-1664-0409-0000-7107D70F3DB4} /R INVENTOR /LANG en-US /Wait", 1, True

Example for Autocad inventor.

 

chaitu

Member
Posts: 4
Registered: ‎07-29-2013
Message 12 of 16 (447 Views)

Re: Silent Uninstall of AutoCAD 2011 via SCCM

07-29-2013 12:53 PM in reply to: tmpamlrs

Has anyone successfully remotely uninstalled Autocad 2011? I am using EMCO remote installer 4 and have not been able to get it to work with any parameter.

I have used
/x/q
msiexec /x {5783F2D7-9005-0409-0102-0060B0CE6BBA} /q
Setup.exe /x {5783F2D7-9005-0409-0102-0060B0CE6BBA}
Setup.exe /x {5783F2D7-9005-0409-0102-0060B0CE6BBA} /q

and many more combinations without success.

Also, does anyone have a recommendation for deploying Autocad 2014 via EMCO, AD, SCCM, etc????

Thanks

*Expert Elite*
Posts: 891
Registered: ‎09-07-2004
Message 13 of 16 (444 Views)

Re: Silent Uninstall of AutoCAD 2011 via SCCM

07-29-2013 01:01 PM in reply to: jlewis808

Do you have the right coding, your screen capture shows Mechanical but that is not mentioned in your post?

 

msiexec /x {B96F1390-23DD-4002-B183-EF0560D784E9} /qb! /Passive /l*v ACAD2011WSPlugIn_UI.log
msiexec /x {42E572CC-6D4C-4A3E-B937-7594D36B2B44} /qb! /Passive /l*v ACAD2011SubAdvPack_UI.log
msiexec /x {711883AE-ED83-4327-9DFA-053F969344CA} /qb! /Passive /l*v ACAD2011CivilOE_Uninstall.log
msiexec /x {6EFD3469-9001-4A85-B52F-2B6C27E946BE} /qb! /Passive /l*v ACAD2011RasterDesignOE_UI.log
msiexec /x {5783F2D7-9001-0409-0002-0060B0CE6BBA} /qb! /Passive /l*v ACAD2011_R18.1.208.0_UI.log
msiexec /x {5783F2D7-9001-0409-1002-0060B0CE6BBA} /qb! /Passive /l*v ACAD2011LanguagePack_UI.log
msiexec /x {CD1E078C-A6B9-47DA-B035-6365C85C7832} /qb! /Passive /l*v ACAD2011BaseImage_UI.log
msiexec /x {9DEABCB6-B759-4D52-92F8-51B34A2B4D40} /qb! /Passive /l*v ACAD2011MaterialLibrary_UI.log
msiexec /x {951B0F30-9F1A-4BF6-B3DA-99EB0E917B1C} /qb! /Passive /l*v FARO_LSSDK_UI.log

 

Member
Posts: 4
Registered: ‎07-29-2013
Message 14 of 16 (436 Views)

Re: Silent Uninstall of AutoCAD 2011 via SCCM

07-29-2013 01:13 PM in reply to: GTVic

I suppose not. How would I uninstall it?

The GUID that I have is the 5783F2D7-9005-0409-0102-0060B0CE6BBA.

Thanks for the quick response by the way!

*Expert Elite*
Posts: 891
Registered: ‎09-07-2004
Message 15 of 16 (423 Views)

Re: Silent Uninstall of AutoCAD 2011 via SCCM

07-29-2013 03:12 PM in reply to: jlewis808

My post shows the commandline that works. You can get the correct GUIDs from your computer registry.

 

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\

 

If you use the command line format the log file will give you additional details about what is wrong

Member
Posts: 4
Registered: ‎07-29-2013
Message 16 of 16 (413 Views)

Re: Silent Uninstall of AutoCAD 2011 via SCCM

07-30-2013 08:50 AM in reply to: GTVic

I had the correct GUID from the registry.

 

I ended up trying PSExec.

 

I already had PSEXEC dowloaded.

 

Went to Start > Run> typed: Runas /user:administrator@DOMAINNAME cmd

I used this command: 

C:\PSTools>PSEXEC \\COMPUTERNAME msiexec /x {5783F2D7-9005-0409-0102-0060B0CE6BBA} /qb! /Passive /l*v ACAD2011Mechanical_Uninstall.log

 

This was the response (took about 3 - 5 minutes ):

msiexec exited on CP188 with error code 0.

 

code 0 means all good.

 

Checked remote machine and AutoCad 2011 Mechanical was uninstalled.

 

What I didn't realize is that EMCO goes out to the registry and looks for the Uninstall String of the Product.

You will see the Command it is sending in the attached screenshots.

It was trying to run:

C:\Program Files\Autodesk\ACADM 2011\Setup\Setup.exe /P {5783F2D7-9005-0409-0102-0060B0CE6BBA} /M/ACM /lang en-US

THEN ATTACHING MY COMMAND OF 

msiexec /x {5783F2D7-9005-0409-0102-0060B0CE6BBA} /qb! /Passive /l*v ACAD2011Mechanical_Uninstall.log

TO THE END OF THE ENTIRE COMMAND

 

Now I just have to figure out how the tell EMCO Remote Installer to use this command instead of the whole thing.

 

Thanks again.

 

 

 

You are not logged in.

Log into access your profile, ask and answer questions, share ideas and more. Haven't signed up yet? Register

Announcements
Welcome to the new Autodesk Community!
If this is your first visit, click here to get started and make the most of the Community. Let us know what you think of the new experience in the Community Feedback Forum.

Need installation help?

Start with some of our most frequented solutions to get help installing your software.

Ask the Community




Connect with Us

Twitter

Pinterest

Blog

Youtube