Installation & Licensing

Posts: 3
Registered: ‎02-16-2012
Message 1 of 3 (1,076 Views)
Accepted Solution

Mechanical 2012 - Issues running through Citrix xenApp

1076 Views, 2 Replies
02-16-2012 01:54 AM



we have Autocad Mechanical 2012 installed on a Windows 2008 R2 Server and running through Citrix.


There are no problems starting the application directly on the server, but when running from xenApp, it tries to install the language pack and ends up deleting the registry values in HCU\Software\Autodesk\AutoCAD\R18.2\ACAD-A005:409. Running procmon shows that it fail locating "AppData\Local\Autodesk\AutoCAD Mechanical 2012\R18.2\enu\" just before this. I also get the "Customization file load failed. File not found: acad" error message.


If I then apply some edited registry settings from another user to restore ACAD-A005:409, it opens without any problems, but if I log out/in to xenApp, the same issue appear again.


I suspect this beeing an issue with roaming profiles, but for some reason I can't find any information about it.

Are there any obvious changes I might have forgotten when setting this up for citrix?


Any assistance would be appriciated :smileyhappy:

Posts: 3
Registered: ‎02-16-2012
Message 2 of 3 (1,025 Views)

Re: Mechanical 2012 - Issues running through Citrix xenApp

02-21-2012 05:07 AM in reply to: Tonbo

When testing I made a new profile\.ARG file and tried to load Autocad through citrix with it, but I can't seem to get the system variables like %RoamableRootFolder% %LocalRootFolder% and %InstallFolder% correct.


I assume  it would usually look for these folder paths in HKEY_USERS\.DEFAULT\Software\Autodesk\AutoCAD\R18.2\ACAD-A005:409 and so on, but becase the values hasn't been reconstructed after Autocad deletedthem, I get folder paths like "%LocalRootFolder%\\acadm\\template" instead.


I know for sure now that my registry got deleted becuse appdata\local reset every time we log out, but I find it odd if it try to rebuild the profile without restoring all the progra values in HKU\\..\AutoCAD\R18.2\ACAD-A005:409 first.


I hope I made myself understandable here. Didn't have much experience with this application before now.

Posts: 3
Registered: ‎02-16-2012
Message 3 of 3 (1,005 Views)

Re: Mechanical 2012 - Issues running through Citrix xenApp

02-24-2012 12:29 AM in reply to: Tonbo

Finnaly managed to solve this issue by using the solution found in the following thread, mostly from napper.brian post.


The application were installed from C:\Temp and is required for first time users, but citrix users didn't have access to run the files here. Moved the files, chanced the product registries values and it worked like a charm ^^


I will leave this as an archive here just in case other happens to stumble over the same problem.



You are not logged in.

Log into access your profile, ask and answer questions, share ideas and more. Haven't signed up yet? Register

Are you familiar with the Autodesk Expert Elites? The Expert Elite program is made up of customers that help other customers by sharing knowledge and exemplifying an engaging style of collaboration. To learn more, please visit our Expert Elite website.

Need installation help?

Start with some of our most frequented solutions to get help installing your software.

Ask the Community

Up & Ready Blog

Boldly Install, Configure and Deploy Autodesk Software.

AutodeskHelp Blog

Your one-stop shop for the latest solutions, breaking news, and behind the scenes access to the world of Autodesk support.

Connect with Us