Installation & Licensing

Installation & Licensing

Posts: 5
Registered: ‎02-04-2011
Message 1 of 4 (2,310 Views)
Accepted Solution

Maya 2011 Mac Network License Hostname Lmgrd Trouble

2310 Views, 3 Replies
06-01-2011 05:38 PM

Recently I recplaced the computer that we had serving our Maya 2011 network license with a new computer. Our old license server was a regular Mac, but the new one (same IP address) is running Mac OS Server. I requested a new license key from Autodesk and received it.


When it didn't work, I searched the forums and followed these instructions where others had the same problem.


It is my understanding that lmgrd is not supported on Mac OS Server, although at least one of the replies in that thread claims to have gotten it to work.


I keep getting hostname errors. My host is named "nausicaa" (without quotes). When I type "hostname" in Terminal, it returns "nausicaa". Our license file specifies nausicaa.


Here are the errors I'm getting:


sudo /sbin/SystemStarter start adsknlm

12:14:22 (lmgrd) The license server manager (lmgrd) running as root:
12:14:22 (lmgrd)     This is a potential security problem
12:14:22 (lmgrd)     and is not recommended.
nausicaa:~ administrator$ 12:14:22 (lmgrd) Unknown host: nausicaa

And when I tried this:


sudo ./lmutil lmstat -a -c /var/flexlm/license.dat


lmutil - Copyright (c) 1989-2010 Flexera Software, Inc. All Rights Reserved.
Flexible License Manager status on Tue 5/24/2011 18:17

License server status: 27000@
    License file(s) on /var/flexlm/adsk_server.lic: license server UP v11.9

Vendor daemon status (on

  adskflex: The desired vendor daemon is down. (-97,121)

I tried running:

sudo /sbin/SystemStarter start adsknlm

And I keep getting the following error:

16:34:16 (lmgrd) The license server manager (lmgrd) running as root:
16:34:16 (lmgrd)     This is a potential security problem
16:34:16 (lmgrd)     and is not recommended.
nausicaa:flexnetserver administrator$ 16:34:16 (lmgrd) Unknown host: nausicaa
16:34:16 (lmgrd) EXITING DUE TO SIGNAL 33 Exit reason 1

I also tried this:

cd /usr/local/flexnetserver/

./lmgrd -z -c "/usr/local/flexnetserver/adsk_server.lic"

And got this error again:

19:04:59 (lmgrd) Unknown host: nausicaa
19:04:59 (lmgrd) EXITING DUE TO SIGNAL 33 Exit reason 1

I have tried to edit the file:





To say this instead:


SERVER nausicaa 0


And it doesn't make any difference at all.


I am hestitant to serve the license from a non-server... is that my only option?

Product Support
Posts: 1,459
Registered: ‎05-21-2010
Message 2 of 4 (2,290 Views)

Re: Maya 2011 Mac Network License Hostname Lmgrd Trouble

06-03-2011 01:37 AM in reply to: SonyaArtis3255

i hope you don't have multiple network cards,teamed network cards or multiple ips to the same card.


please try "" as the hostname in the license file.


Also try to do a log file when starting with lmgrd (-l /folder/logfilename.log)


this would give more info.


also you could try to add nausicaa  to the /etc/hosts with the ip


If my post answers your question, please mark it as an Accepted Solution, so that others can find answers quickly!
For more tips & tricks:

Hashim Mundol
Autodesk Product Support
Autodesk, Inc.

Posts: 5
Registered: ‎02-04-2011
Message 3 of 4 (2,281 Views)

Re: Maya 2011 Mac Network License Hostname Lmgrd Trouble

06-03-2011 03:16 PM in reply to: hashim.mundol

I spent a lot of time on the phone with Maya support, and we ultimately decided to serve the license from a non-Server with the regular Mac OS. The subscriptions department generated a new license. We decided to use the IP address instead of the computer name.


But then, out of curiousity, I went back to the server to try again... with some success!


I tried renaming the server "" in System Preferences --> Sharing


I also renamed it in the Terminal, using this command:


sudo scutil --set HostName


Then, I made sure that in the var/flexlm folder I had the adsk_server.lic file, and that file contained the license. I pasted in there for the hostname.


Next, I ran this command:


sudo /sbin/SystemStarter start adsknlm


Which seemed to work a lot better for me than sudo ./lmgrd  -c /var/flexlm/adsk_server.lic when I was working with the support technician.


The server then started up!


As per your suggestion, I tried to make a log file with (-l /folder/logfilename.log), but I'm perhaps not savvy enough to figure out how to get it to work. I tried putting it in the /var file for lack of any other ideas: sudo /sbin/SystemStarter start adsknlm -l /var/logfile.log


But that didn't work and spit back some instructions on how to use -l.


So anyway, I used the temp license we (Maya support and I) were working with yesterday on the Mac OS Server and got a client computer to use it. Of course, the new license we just generated today is for a different machine, but this gives me hope that we can run the license off the server after all.

Product Support
Posts: 1,352
Registered: ‎06-18-2008
Message 4 of 4 (2,263 Views)

Re: Maya 2011 Mac Network License Hostname Lmgrd Trouble

06-07-2011 01:19 PM in reply to: SonyaArtis3255

Thanks for this post.  I will reference it to:


Thanks Erin (06502947) and Sonya!

David Lau
Are you familiar with the Autodesk Expert Elites? The Expert Elite program is made up of customers that help other customers by sharing knowledge and exemplifying an engaging style of collaboration. To learn more, please visit our Expert Elite website.
Need installation help?

Start with some of our most frequented solutions or visit the Installation and Licensing Forum to get help installing your software.