Installation & Licensing

Reply
*Expert Elite*
TravisNave
Posts: 9,538
Registered: ‎01-14-2005
Message 1 of 9 (24,386 Views)
Accepted Solution

Install .NET Framework Language Pack Failed Installation aborted, Result=1603

24386 Views, 8 Replies
04-16-2013 03:03 PM

Problem:  When installing your Autodesk product, your installation fails and the resulting installation.log file on the summary screen (and your %TEMP% folder) shows the following error:

 

Install .NET Framework Runtime Language Pack Failed Installation aborted, Result=1603

Reason:  It is possible that the .NET Framework preinstalled in some Windows 7 and Windows 8 machines is not the full installation and the update for the language pack cannot install if a previous version or newer version is already installed.  This is a very similar issue in the past with the Prerequisite 1603 failures for .NET Framework and Visual C++ Redistributables failing.  This guide acts as a supplement to that article.

 

Note:  There is not an English version of the Language pack for this program.  More information about this can be found at the following Microsoft resource:

 

http://www.microsoft.com/en-us/download/details.aspx?id=3324

 

Work Around:  To best avoid this error on newer Autodesk installations, it is best if you first install the prerequisite first and then modify the setup.ini file in the installation source to ignore the failure of the language pack install. 

 

Step 1:  Copy the contents of your install media to your local hard drive.  If you have the downloaded version, then you already have completed this step.

 

Step 2:  Locate the file in the root source folder named Setup.ini and make a backup of this file.  Open the file in Notepad for editing. 

 

Step 3:  Perform a search to find the [DOTNET4LANG] located in this file.  Later versions may have newer language file prerequisites, such as [DOTNET45LANG], etc. 

 

Step 4:  Add the following line to the prerequisite grouping under the existing EXE_ settings:

 

IGNORE_FAILURE=YES 

 

Your resulting Prereq should look similar to this:

 

[DOTNET4LANG]
PRODUCT_NAME=.NET Framework Runtime 4.0 Language Pack
EXE_PATH=3rdParty\NET\4\wcu\dotNetFramework\dotNetFx40LP_Full_x86_x64_%lang%.exe
EXE_PARAM=/q
EXE_LANGS=1036;1040;1031;1034;1046;1041;1042;2052;1028;1029;1038;1045;1049
IGNORE_FAILURE=YES
DISKCOST=3000000 VC_FUNC=DotnetLangPacksVerCheck VC_SOURCE=Setup\SetupUi.dll VC_PARAM=%lang%;4.0.30319

 

 Step 5:  Save the file and run the installer. 

 

As always, make sure that you are installing with local Administrator Rights, UAC turned off, and anti-virus temporarily disabled. 

 

Attached is a copy of the Autodesk AutoCAD 2014 (vanilla) setup.ini file that I have modified for this example.  Use this file only as a reference and not as your file. 

 

Travis Nave Send TravisNave a Private Message                       Need help in your post? Mention me with @TravisNave
*Expert Elite*
TravisNave
Posts: 9,538
Registered: ‎01-14-2005
Message 2 of 9 (24,382 Views)

Re: Install .NET Framework Language Pack Failed Installation aborted, Result=160

04-16-2013 03:05 PM in reply to: TravisNave

In some instances, it may be best to remove the check for the prerequisite altogether.  For more information on how to modify the setup.ini file for this purpose, see my 2nd post for the Advanced Solution here:

http://forums.autodesk.com/t5/Installation-Licensing/Some-Products-Fail-to-Install-Result-1603/td-p/...

Good Luck!

Travis Nave Send TravisNave a Private Message                       Need help in your post? Mention me with @TravisNave
*Expert Elite*
TravisNave
Posts: 9,538
Registered: ‎01-14-2005
Message 3 of 9 (24,019 Views)

Re: Install .NET Framework Language Pack Failed Installation aborted, Result=160

06-04-2013 08:38 AM in reply to: TravisNave

I wanted to add David.Lau's post to this as a reference for similar failures on prerequisites.  This one tends to be a good registry fix.

 

Thanks David!

 

http://forums.autodesk.com/t5/Installation-Licensing/Installation-of-AutoCAD-stalls-at-the-Visual-C-...

 

 

Travis Nave Send TravisNave a Private Message                       Need help in your post? Mention me with @TravisNave
New Member
Posts: 1
Registered: ‎08-16-2013
Message 4 of 9 (21,086 Views)

Re: Install .NET Framework Language Pack Failed Installation aborted, Result=160

08-16-2013 06:32 PM in reply to: TravisNave

You are my hero.

*Expert Elite*
TravisNave
Posts: 9,538
Registered: ‎01-14-2005
Message 5 of 9 (20,690 Views)

Re: Install .NET Framework Language Pack Failed Installation aborted, Result=160

08-22-2013 11:24 AM in reply to: TravisNave

Here is an Autodesk Chronicle video that I posted that provides a visual explanation of modifying the setup.ini. 

 

Travis Nave Send TravisNave a Private Message                       Need help in your post? Mention me with @TravisNave
Contributor
Posts: 22
Registered: ‎01-02-2010
Message 6 of 9 (20,680 Views)

Re: Install .NET Framework Language Pack Failed Installation aborted, Result=160

08-22-2013 12:04 PM in reply to: TravisNave

You're really GREAT! )

Distinguished Contributor
Posts: 145
Registered: ‎06-27-2006
Message 7 of 9 (20,606 Views)

Re: Install .NET Framework Language Pack Failed Installation aborted, Result=160

08-23-2013 02:02 AM in reply to: TravisNave

Is it just me or have these installation issues become more of an issues recently and if so why is it that the other major CAD package that we use manages to install itself without any problems simply because it runs a prerequisite pack before attempting to install the CAD side of the product!

 

Also having to edit ini files so not to install 360 even though you tell it in the deployment that you don’t want it and Recap edit the registry to get the correct service pack!

 

I know that they like to get the new shiny product out to the users so that they can see something for their money but really does anybody bother to test the basic deployment installation for getting it out to the end users?

 

Still it makes life interesting for us still employed to sort these problems out for our users although some think all we do all day is complain and play with the software.

 

:smileyvery-happy:

New Member
Posts: 1
Registered: ‎09-26-2013
Message 8 of 9 (18,260 Views)

Re: Install .NET Framework Language Pack Failed Installation aborted, Result=160

09-26-2013 11:56 AM in reply to: TravisNave

u R the BEST,

its the best way für win8 , in 2sec. finisch mit netframwork error !!.

New Member
Posts: 1
Registered: ‎01-31-2014
Message 9 of 9 (2,229 Views)

Re: Install .NET Framework Language Pack Failed Installation aborted, Result=160

03-24-2014 09:55 AM in reply to: TravisNave

I try to do this, but when I change the INI file, appears a message saying that the comunication has failed. What am I doing wrong?

You are not logged in.

Log into access your profile, ask and answer questions, share ideas and more. Haven't signed up yet? Register

Announcements
Welcome to the new Autodesk Community!
If this is your first visit, click here to get started and make the most of the Community. Let us know what you think of the new experience in the Community Feedback Forum.

Need installation help?

Start with some of our most frequented solutions to get help installing your software.

Ask the Community




Connect with Us

Twitter

Pinterest

Blog

Youtube