Installation & Licensing

Reply
Active Contributor
scotta
Posts: 29
Registered: ‎05-27-2005
Message 1 of 8 (487 Views)

Error starting Inventor after a network license has been borrowed.

487 Views, 7 Replies
06-25-2010 06:13 AM

We have an engineer that is overseas and Inventor is giving him problems.  Before he left the country, he borrowed a license to use Inventor.  He says he made sure that it worked before he left and the borrowed license worked.  Now he gets the following error message : "Your application was not able to obtain a license because the FLEXnet license server manager could not determine where to find the licesnsing data it needs.  Please choose one of the following:"  " Specify the License Server System" or " Specify the License File".  I checked LMTools and it says that he is still using a license.   Has anyone else had this problem and know how to correct it?

 

Thanks

Scott

*Expert Elite*
TravisNave
Posts: 10,023
Registered: ‎01-14-2005
Message 2 of 8 (483 Views)

Re: Error starting Inventor after a network license has been borrowed.

06-25-2010 08:15 AM in reply to: scotta

This issue often exists with laptops for a couple of reasons.  The most common is if the laptop has a docking station.  When docked, the laptop has a different hardware ethernet MAC address.  The borrowed license is attached to this connection.  When undocked, the hardware address is changed to the internal NIC and thus the license becomes invalid.  This also happens if the user borrows while on the LAN NIC and then disables and goes WiFi (or vice versa.)  In rare cases, like my laptop for example, my NLM is tied to the BlueTooth device.  So when it is disabled, my licenses are invalid.  In addition, the borrowed license is also attached to the user account.  So even in events where the license is tied to the correct NIC, the user may login as a domain user while on the LAN and then login as a local account while offline. This can cause the same problematic result.  To solve the problem, you need to determine what changes with the laptop when the user borrows the license and then leaves the network.  Your solution will exist there. 

Travis Nave Send TravisNave a Private Message                       Need help in your post? Mention me with @TravisNave
Active Contributor
scotta
Posts: 29
Registered: ‎05-27-2005
Message 3 of 8 (480 Views)

Re: Error starting Inventor after a network license has been borrowed.

06-25-2010 09:09 AM in reply to: TravisNave

Travis,

 

The computer in question was connecting to our network with the built in wireless card when he borrowed the license.  It is also setup to automatically log him into his user acount so that shouldn't have changed.  Just to verify what you are saying.......If the wireless card is not active, he will get this error.  Is that correct.  The computer he is using is a Dell M6300 and I'm not sure if he has bluetooth on it or not.  I'll tell him to make sure that both are active and we'll see if that helps.  He's 12 or 13 hours ahead of us so I won't find out if it works until tomorrow.

 

Thanks

*Expert Elite*
TravisNave
Posts: 10,023
Registered: ‎01-14-2005
Message 4 of 8 (478 Views)

Re: Error starting Inventor after a network license has been borrowed.

06-25-2010 09:16 AM in reply to: scotta

Correct.  The borrowed license is tied to a hardware MAC address.  Whichever one it chooses to associate with when the borrowing occurs (and sometimes it isn't even the active NIC) will need to be active to ensure that the license can be used. 

Travis Nave Send TravisNave a Private Message                       Need help in your post? Mention me with @TravisNave
Active Member
fëanor
Posts: 9
Registered: ‎01-14-2006
Message 5 of 8 (108 Views)

Re: Error starting Inventor after a network license has been borrowed.

06-28-2013 01:26 PM in reply to: TravisNave

I seem to have encountered the same exact issue.  I want to confirm that I'm not missing something here; I now have no possible way to get my offline user a license until he is able to reconnect to the license server.  Correct?

 

If you are correct about the port replicator MAC address being the cause, this sounds like a huge flaw in FlexNET's license borrowing schema.  The MAC address is a poor choice to use as a UID when the point of borrowing a license is to remove the network as a factor.  The fact that it seems to select a random adapter is even more ridiculous.

 

Now that we know, I will advise my users to always disconnect from the port replicator and connect an Ethernet cable directly to their laptop before borrowing a license.    That sounds like a PITA for them, but hopefully it helps.

 

Have I mentioned that Autodesk network licensing is killing me this week? :smileyfrustrated:

*Expert Elite*
TravisNave
Posts: 10,023
Registered: ‎01-14-2005
Message 6 of 8 (104 Views)

Re: Error starting Inventor after a network license has been borrowed.

06-28-2013 01:47 PM in reply to: fëanor

You are correct in stating that there is no way to get an offline user a borrowed license.  Your only possible work-around would be to registry fix it back to stand-alone and see if it will run as a 30 day trial.  Not much luck doing this though since 2010 was released. 

 

As for the licensing, it's not really Autodesk's fault since they use a 3rd party licensing program.

Travis Nave Send TravisNave a Private Message                       Need help in your post? Mention me with @TravisNave
Active Member
fëanor
Posts: 9
Registered: ‎01-14-2006
Message 7 of 8 (95 Views)

Re: Error starting Inventor after a network license has been borrowed.

06-28-2013 05:07 PM in reply to: TravisNave
Thank you for confirming. I'm just making sure I leave no stone unturned.

I suppose we will have to agree to disagree about it being Autodesk's fault...I know I'm not the one who selected Flexera as their partner so it certainly isn't my fault. I checked with the guy next to me and he didn't make that decision either so I am still leaning towards Autodesk as the culprit :smileytongue:

Anyway thanks again for the explanation!
*Expert Elite*
TravisNave
Posts: 10,023
Registered: ‎01-14-2005
Message 8 of 8 (92 Views)

Re: Error starting Inventor after a network license has been borrowed.

06-28-2013 05:44 PM in reply to: fëanor
Well said.
Travis Nave Send TravisNave a Private Message                       Need help in your post? Mention me with @TravisNave

You are not logged in.

Log into access your profile, ask and answer questions, share ideas and more. Haven't signed up yet? Register

Announcements
Are you familiar with the Autodesk Expert Elites? The Expert Elite program is made up of customers that help other customers by sharing knowledge and exemplifying an engaging style of collaboration. To learn more, please visit our Expert Elite website.

Need installation help?

Start with some of our most frequented solutions to get help installing your software.

Ask the Community


Up & Ready Blog

Boldly Install, Configure and Deploy Autodesk Software.

AutodeskHelp Blog

Your one-stop shop for the latest solutions, breaking news, and behind the scenes access to the world of Autodesk support.

Connect with Us

Twitter

Pinterest

Blog

Youtube