Installation & Licensing

Reply
Member
bradleyalanwhite
Posts: 5
Registered: ‎04-19-2010
Message 1 of 13 (2,090 Views)

Civil 3D install and uninstall HELP!

2090 Views, 12 Replies
04-19-2010 10:43 AM
I installed C3D 2010 it wouldn't start and said it was missing some dll files. I tried to install again and and it wouldn't let me select to install C3D. I tried to uninstall, but it said the same error as trying to run it. It was missing a dll file. How can I uninstall this thing so I can re-install it now??????? HELP!!!!!!!!!! IT won't let me install over the existing installation and I can't uninstall because it is missing some dll?????
Alumni
DouglasLauritsen
Posts: 642
Registered: ‎04-16-2008
Message 2 of 13 (2,090 Views)

Re: Civil 3D install and uninstall HELP!

04-19-2010 10:50 AM in reply to: bradleyalanwhite


What is the error message for the missing .dll file(s)? What is the result of trying a repair install from Add and Remove Programs? Is the error message the same? Can you provide Screen Shots? If you have more than one you can imbed them into a word file or .zip and post to this thread.



Douglas Lauritsen, Autodesk Product Support

Edited by: DouglasLauritsen on Apr 19, 2010 10:50 AM


Douglas Lauritsen
Support Specialist
Product Support
Autodesk, Inc.

Member
bradleyalanwhite
Posts: 5
Registered: ‎04-19-2010
Message 3 of 13 (2,090 Views)

Re: Civil 3D install and uninstall HELP!

04-19-2010 11:02 AM in reply to: bradleyalanwhite
It doesn't show up in the add/ remove programs? The dll files I started to add manually from the installation directory, but it is missing several. I d/l'd this from the trial here. My best guess is it didn't locate the second file properly during my install? I don't know how to change the registry so the install program thinks there is no C3D on the machine.
Alumni
DouglasLauritsen
Posts: 642
Registered: ‎04-16-2008
Message 4 of 13 (2,091 Views)

Re: Civil 3D install and uninstall HELP!

04-19-2010 11:34 AM in reply to: bradleyalanwhite

Do either of these registry keys exists?


HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Installer\UserData\S-1-5-18\Products\7D2F387500089040002000060BECB6AB


HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Installer\UserData\S-1-5-18\Products\7D2F387500089040012000060BECB6AB


Douglas Lauritsen, Autodesk Product Support


Douglas Lauritsen
Support Specialist
Product Support
Autodesk, Inc.

Member
bradleyalanwhite
Posts: 5
Registered: ‎04-19-2010
Message 5 of 13 (2,091 Views)

Re: Civil 3D install and uninstall HELP!

04-19-2010 12:03 PM in reply to: bradleyalanwhite
yes they are both there.
Member
bradleyalanwhite
Posts: 5
Registered: ‎04-19-2010
Message 6 of 13 (2,091 Views)

Re: Civil 3D install and uninstall HELP!

04-19-2010 12:53 PM in reply to: bradleyalanwhite
correction the first one is. Not the second entry!
Alumni
DouglasLauritsen
Posts: 642
Registered: ‎04-16-2008
Message 7 of 13 (2,091 Views)

Re: Civil 3D install and uninstall HELP!

04-19-2010 02:32 PM in reply to: bradleyalanwhite

Right-click on 7D2F387500089040002000060BECB6AB in HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Installer\UserData\S-1-5-18\Products\7D2F387500089040002000060BECB6AB

and choose Export.


Once it is backed up, and not before, delete it then try the installer again.


When the export completes and you have Civil 3D installed and operating again you can delete the .reg file.


Douglas Lauritsen, Autodesk Product Support
We appreciate your quick feedback on this forum!



Douglas Lauritsen
Support Specialist
Product Support
Autodesk, Inc.

Member
bradleyalanwhite
Posts: 5
Registered: ‎04-19-2010
Message 8 of 13 (2,091 Views)

Re: Civil 3D install and uninstall HELP!

04-19-2010 03:02 PM in reply to: bradleyalanwhite
It looked like all was well.... but then it failed and here is the log.


=== Verbose logging started: 5/14/2010 13:55:15 Build type: SHIP UNICODE 4.05.6001.00 Calling process: C:\DOCUME~1\Angel\LOCALS~1\Temp\_AI1CE.tmp\setup.exe ===
MSI (c) (CC:80) [13:55:15:171]: Resetting cached policy values
MSI (c) (CC:80) [13:55:15:171]: Machine policy value 'Debug' is 0
MSI (c) (CC:80) [13:55:15:171]: ******* RunEngine:
******* Product: C:\Autodesk\AutoCAD Civil 3D 2010\x86\C3D\C3D.msi
******* Action:
******* CommandLine: **********
MSI (c) (CC:80) [13:55:15:171]: Client-side and UI is none or basic: Running entire install on the server.
MSI (c) (CC:80) [13:55:18:171]: Failed to grab execution mutex. System error 258.
MSI (c) (CC:80) [13:55:18:171]: Cloaking enabled.
MSI (c) (CC:80) [13:55:18:171]: Attempting to enable all disabled privileges before calling Install on Server
MSI (c) (CC:80) [13:55:18:171]: Incrementing counter to disable shutdown. Counter after increment: 0
MSI (s) (F0:64) [13:55:18:187]: Running installation inside multi-package transaction C:\Autodesk\AutoCAD Civil 3D 2010\x86\C3D\C3D.msi
MSI (s) (F0:64) [13:55:18:187]: Grabbed execution mutex.
MSI (s) (F0:A8) [13:55:18:187]: Resetting cached policy values
MSI (s) (F0:A8) [13:55:18:187]: Machine policy value 'Debug' is 0
MSI (s) (F0:A8) [13:55:18:187]: ******* RunEngine:
******* Product: C:\Autodesk\AutoCAD Civil 3D 2010\x86\C3D\C3D.msi
******* Action:
******* CommandLine: **********
MSI (s) (F0:A8) [13:55:18:187]: Machine policy value 'TransformsSecure' is 0
MSI (s) (F0:A8) [13:55:18:187]: User policy value 'TransformsAtSource' is 0
MSI (s) (F0:A8) [13:55:18:187]: Machine policy value 'DisableUserInstalls' is 0
MSI (s) (F0:A8) [13:55:18:187]: Specified instance {5783F2D7-8000-0409-0002-0060B0CE6BBA} via transform C:\DOCUME~1\Angel\LOCALS~1\Temp\_AI1CE.tmp\C3D\C3D-standalone.mst is already installed. MSINEWINSTANCE requires a new instance that is not installed.
MSI (s) (F0:A8) [13:55:18:187]: MainEngineThread is returning 1639
MSI (s) (F0:64) [13:55:18:187]: User policy value 'DisableRollback' is 0
MSI (s) (F0:64) [13:55:18:187]: Machine policy value 'DisableRollback' is 0
MSI (s) (F0:64) [13:55:18:187]: Incrementing counter to disable shutdown. Counter after increment: 0
MSI (s) (F0:64) [13:55:18:187]: Note: 1: 1402 2: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Installer\Rollback\Scripts 3: 2
MSI (s) (F0:64) [13:55:18:187]: Note: 1: 1402 2: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Installer\Rollback\Scripts 3: 2
MSI (s) (F0:64) [13:55:18:203]: Note: 1: 1402 2: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Installer\InProgress 3: 2
MSI (s) (F0:64) [13:55:18:203]: Note: 1: 1402 2: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Installer\InProgress 3: 2
MSI (s) (F0:64) [13:55:18:203]: Decrementing counter to disable shutdown. If counter >= 0, shutdown will be denied. Counter after decrement: -1
MSI (s) (F0:64) [13:55:18:203]: Restoring environment variables
MSI (c) (CC:80) [13:55:18:203]: Decrementing counter to disable shutdown. If counter >= 0, shutdown will be denied. Counter after decrement: -1
MSI (c) (CC:80) [13:55:18:203]: MainEngineThread is returning 1639
=== Verbose logging stopped: 5/14/2010 13:55:18 ===


here is the setup log

2010/5/14:13:01:21 Angel A-CFFB9AD0FD7F4 === Setup ended ===

2010/5/14:13:45:51 Angel A-CFFB9AD0FD7F4 === Setup started on A-CFFB9AD0FD7F4 by Angel ===
2010/5/14:13:46:07 Angel A-CFFB9AD0FD7F4 === Setup started on A-CFFB9AD0FD7F4 by Angel ===
2010/5/14:13:46:20 Angel A-CFFB9AD0FD7F4 === Setup ended ===

2010/5/14:13:54:42 Angel A-CFFB9AD0FD7F4 Install DirectX 9.0 Runtime Succeeded
2010/5/14:13:55:13 Angel A-CFFB9AD0FD7F4 Install Microsoft Visual Basic Power Packs 3.0 Succeeded
2010/5/14:13:55:18 Angel A-CFFB9AD0FD7F4 Install AutoCAD Civil 3D 2010 Failed Installation aborted, Result=1639
2010/5/14:13:58:32 Angel A-CFFB9AD0FD7F4 === Setup ended ===
Alumni
DouglasLauritsen
Posts: 642
Registered: ‎04-16-2008
Message 9 of 13 (2,091 Views)

Re: Civil 3D install and uninstall HELP!

04-21-2010 12:41 PM in reply to: bradleyalanwhite

Can you post the .log files that were written to the user's temp folder? The information you posted indicates it would be here C:\DOCUME~1\Angel\LOCALS~1\Temp\. But to be sure you can type %temp% in the Windows Explorer address bar or in Start > Run. There should be several so please zip them up and post the .zip as you can only upload a single file per message. This way you don't have to post many messages to the thread.


Douglas Lauritsen, Autodesk Product Support
We appreciate your quick feedback on this forum!



Douglas Lauritsen
Support Specialist
Product Support
Autodesk, Inc.

*Expert Elite*
TravisNave
Posts: 9,936
Registered: ‎01-14-2005
Message 10 of 13 (2,091 Views)

Re: Civil 3D install and uninstall HELP!

04-21-2010 01:02 PM in reply to: bradleyalanwhite
A 1639 error is an invalid command line argument. Are you installing this via a script, GPO, or some other modification? Also, are you installing a service pack at the same time? There seems to be a problem with the installation method here.
Travis Nave Send TravisNave a Private Message                       Need help in your post? Mention me with @TravisNave

You are not logged in.

Log into access your profile, ask and answer questions, share ideas and more. Haven't signed up yet? Register

Announcements
Are you familiar with the Autodesk Expert Elites? The Expert Elite program is made up of customers that help other customers by sharing knowledge and exemplifying an engaging style of collaboration. To learn more, please visit our Expert Elite website.

Need installation help?

Start with some of our most frequented solutions to get help installing your software.

Ask the Community


Up & Ready Blog

Boldly Install, Configure and Deploy Autodesk Software.

AutodeskHelp Blog

Your one-stop shop for the latest solutions, breaking news, and behind the scenes access to the world of Autodesk support.

Connect with Us

Twitter

Pinterest

Blog

Youtube