Installation & Licensing

New Member
Posts: 2
Registered: ‎10-18-2010
Message 1 of 3 (1,417 Views)
Accepted Solution

Cannot Uninstall Civil 3D 2011

1417 Views, 2 Replies
01-13-2011 02:46 AM

My Civil 3D 2011 would not start. It just blinks and disappears. 

I tried to repair/reinstall Civil 3D. During the middle of the session, it gives an error and rolls back the "installation. Then I tried uninstalling 3D to the same effect


I searched the blogs for solution. One of them said I need to uninstall Materials Base Library, Materials Library IN THAT ORDER and uninstall Civil 3D. Still the same error message crops up. And in this process my AutoCad 2011 also stopped working.


Now one of the forum answers told me to uninstall ALL autodesk products including materials library and do a clean install. This time also I decided to bite the bullet. I was able to uninstall ALL the autodesk products except, yes you guessed it, Civil 3D.


Now Please tell me how to UNINSTALL/REPAIR/REINSTALL Civil 3D 2011. Thanks.




PS: And yes, I did uninstall my .Net framework and reinstalled it and updated it using Windows update. By the way I run Civil 3D on 32-bit Windows 7 Ultimate.

*Expert Elite*
Posts: 9,927
Registered: ‎01-14-2005
Message 2 of 3 (1,397 Views)

Re: Cannot Uninstall Civil 3D 2011

01-13-2011 06:06 PM in reply to: bkballa

Use the Microsoft Installer Cleanup Utility to remove your Civil 3D.  Then manually delete the Civil files under Program Files.  Your initial problem may have been caused by a corrupt CascadeInfo.cas file, but you are beyond that now.


For more detailed information about the CascadeInfo.cas file, please refer to the Autodesk Support Knowledge Base article found here:


Installation problems may be resolved using the Microsoft Installer Clean Up Utility. For more information on this program, please my forum post here:

Travis Nave Send TravisNave a Private Message                       Need help in your post? Mention me with @TravisNave
New Member
Posts: 2
Registered: ‎10-18-2010
Message 3 of 3 (1,314 Views)

Re: Cannot Uninstall Civil 3D 2011

01-25-2011 06:02 AM in reply to: TravisNave


The microsoft uninstaller utility worked like a charm. I was aware of the utility, but was reluctant to use it as microsoft "retired" it (presumbly for MS-Office related problems).


Anyways problem solved :smileyhappy: I did reinstall Civil 3D 2011, however I decided not to reinstall AutoCAD 2011 as 3D has bult-in AutoCAD.


Thanks once again.



You are not logged in.

Log into access your profile, ask and answer questions, share ideas and more. Haven't signed up yet? Register

Are you familiar with the Autodesk Expert Elites? The Expert Elite program is made up of customers that help other customers by sharing knowledge and exemplifying an engaging style of collaboration. To learn more, please visit our Expert Elite website.

Need installation help?

Start with some of our most frequented solutions to get help installing your software.

Ask the Community

Up & Ready Blog

Boldly Install, Configure and Deploy Autodesk Software.

AutodeskHelp Blog

Your one-stop shop for the latest solutions, breaking news, and behind the scenes access to the world of Autodesk support.

Connect with Us