Installation & Licensing

Reply
Active Member
cristiantrillos
Posts: 6
Registered: ‎10-08-2012
Message 1 of 4 (5,179 Views)
Accepted Solution

Autocad MEP 2013 Installation fails code 1603 ngenCreate

5179 Views, 3 Replies
10-09-2012 10:09 AM

Hello,

 

failed Autocad MEP 2013 Student new installation

 

(other Autodesk products present: 2013: Autocad, Inventor, Revit, 3dsMax Design)

 

 

On turning on verbose mode for Windows Installer I get:

 

VERBOSE MODE LOG:


MSI (s) (88:C4) [21:03:58:552]: Executing op: CustomActionSchedule(Action=NgenCreate,ActionType=1025,Source=BinaryData,Target=NgenCreate,CustomActionData=C:\Windows\Microsoft.NET\Framework64\v4.0.30319\Ngen.exe;;C:\Program Files\Autodesk\AutoCAD 2013\acad.exe)
MSI (s) (88:F4) [21:03:58:555]: Invoking remote custom action. DLL: C:\Windows\Installer\MSI7F8B.tmp, Entrypoint: NgenCreate
CustomAction NgenCreate returned actual error code 1603 (note this may not be 100% accurate if translation happened inside sandbox)

 

 

 

NORMAL MODE LOG:

2012/10/4:20:50:25    Cristian    CRISTIAN-THINK    === Setup started on CRISTIAN-THINK by Cristian ===
2012/10/4:20:50:25    Cristian    CRISTIAN-THINK    Launch
2012/10/4:20:50:32    Cristian    CRISTIAN-THINK    PageOpen    LaunchDialog        
2012/10/4:20:50:34    Cristian    CRISTIAN-THINK    PageOpen    LicenseDialog        
2012/10/4:20:50:37    Cristian    CRISTIAN-THINK    PageOpen    ProductInfoDialog        
2012/10/4:20:51:46    Cristian    CRISTIAN-THINK    PageOpen    ProductSelectionDialog2        
2012/10/4:21:01:13    Cristian    CRISTIAN-THINK    PageOpen    FullProgressDialog        
2012/10/4:21:01:13    Cristian    CRISTIAN-THINK    Installing DirectX Runtime: C:\Autodesk\AutoCAD_MEP_2013_English_Win_64Bit\3rdParty\DirectX\DXSETUP.exe /silent
2012/10/4:21:01:56    Cristian    CRISTIAN-THINK    Install    DirectX Runtime    Succeeded    
2012/10/4:21:02:03    Cristian    CRISTIAN-THINK    Installing AutoCAD® MEP 2013:  TRANSFORMS="C:\Autodesk\AutoCAD_MEP_2013_English_Win_64Bit\x64\en-us\MEP\MEP.mst;C:\Users\Cristian\AppData\Local\Temp\_AI6D4.tmp\x64\MEP\MEP-standalone.mst" ADSK_EULA_STATUS=#1 MUILANG=en-us ADSK_SOURCE_ROOT="C:\Autodesk\AutoCAD_MEP_2013_English_Win_64Bit\" INSTALLDIR="C:\Program Files\Autodesk\AutoCAD 2013\" FILESINUSETEXT="" REBOOT=ReallySuppress ADSK_SETUP_EXE=1

 2012/10/4:21:04:41    Cristian    CRISTIAN-THINK    Install    AutoCAD® MEP 2013    Failed    Installation aborted, Result=1603
2012/10/4:21:04:41    Cristian    CRISTIAN-THINK    Rollback    DirectX Runtime    Failed    Failure is ignored, Result=1619
2012/10/4:21:04:42    Cristian    CRISTIAN-THINK    PageOpen    InstallCompleteDialog        
2012/10/4:21:06:18    Cristian    CRISTIAN-THINK    === Setup ended ===

 

I have checked in other forum posts and the issue is usually down to a component already present in the system, but here is failing at a ngenCreate step (not the first one as it performs plenty of these actions before it fails) which is more complicated to diagnose.

 

How could I further troubleshoot ?

 

In attachment the full verbose log.

 

thanks,

Valued Mentor
mdhutchinson
Posts: 2,288
Registered: ‎11-18-2003
Message 2 of 4 (5,162 Views)

Re: Autocad MEP 2013 Installation fails code 1603 ngenCreate

10-09-2012 03:22 PM in reply to: cristiantrillos

We had similar issues with our last migration to 2012... three computers out of a couple dozen were a nightmare.

The 1603 errors are most commonly lack of permissions to certain registry keys.

This time for 2013 we took a couple measures to prevent it. Assuming you have Windows 7... These include...

Diabled Virus Software (last time we didn't even have it installed)

Click Start... in the Search Programs and Files edit box... type UAC... to bring up User Account Control Settings... back to slider down to 'Never Notify'. You'll need to reboot to apply the changes.

When you launch the executable to install... right click on it and do 'Run As Administrator'

This is all we did... havn't had 1603 errors yet.

I would like to know if this worked for you... since you are just a few hours away from the issue.

 

 

 

 

Active Member
cristiantrillos
Posts: 6
Registered: ‎10-08-2012
Message 3 of 4 (5,133 Views)

Re: Autocad MEP 2013 Installation fails code 1603 ngenCreate

10-10-2012 07:53 AM in reply to: mdhutchinson

Hello!

 

Thanks for your reply.

 

However, the problem remains unsolved.

 

suming up:

 

w7 64 sp1 up to date i7 quad on isv certified hw.

 

What it has been tried and hasn't worked:

 

- disable AV/firewall etc

- running as Administrator

- running from Administrator account (manually enabling windows Administrator account (net user administrator /active:yes)) (and then logging into that account from login screen)

- uninstalling .NET framework 4 so the Autodesk Autocad MEP 2013 Installer installs the version that the sw was developed around

- adding *.autodesk.com to ControlPanel-InternetOptions-TrustedSites and turning down security to its minimum

- trying with different install options (i.e only Global content)

- manually disabling UAC and trying from real Administrator account and user with Administrator rights

 

so far I have succesfully Installed Autocad, Revit, 3dsMax, Showcase

 

it always fails at the ngencreate at the very first one attempt.

(I had said before some of this operations were being successful but, on closer inspection, I noticed that the first "successful operations" were related to adding the "rollback" property so not performing any real action but just preparing.)

 

It always fails at:

 

MSI (s) (88:C4) [21:03:57:331]: Executing op: ActionStart(Name=NgenCreateRollback,Description=Rolling back the creation of native image for assembly.,Template=Compiler: [1]
Assembly Path: [2])
MSI (s) (88:C4) [21:03:57:333]: Executing op: CustomActionSchedule(Action=NgenCreateRollback,ActionType=1281,Source=BinaryData,Target=NgenDelete,CustomActionData=C:\Windows\Microsoft.NET\Framework64\v4.0.30319\Ngen.exe;C:\Program Files\Autodesk\AutoCAD 2013\acdbmgd.dll;C:\Program Files\Autodesk\AutoCAD 2013\acad.exe)
MSI (s) (88:C4) [21:03:57:340]: Executing op: ActionStart(Name=NgenCreate,Description=Generating native image for assembly.,Template=Compiler: [1]
Assembly Path: [2])
MSI (s) (88:C4) [21:03:57:342]: Executing op: CustomActionSchedule(Action=NgenCreate,ActionType=1025,Source=BinaryData,Target=NgenCreate,CustomActionData=C:\Windows\Microsoft.NET\Framework64\v4.0.30319\Ngen.exe;C:\Program Files\Autodesk\AutoCAD 2013\acdbmgd.dll;C:\Program Files\Autodesk\AutoCAD 2013\acad.exe)
MSI (s) (88:F0) [21:03:57:345]: Invoking remote custom action. DLL: C:\Windows\Installer\MSI7AC9.tmp, Entrypoint: NgenCreate
MSI (s) (88:C4) [21:03:58:525]: Executing op: ActionStart(Name=NgenCreateRollback,Description=Rolling back the creation of native image for assembly.,Template=Compiler: [1]
Assembly Path: [2])
MSI (s) (88:C4) [21:03:58:543]: Executing op: CustomActionSchedule(Action=NgenCreateRollback,ActionType=1281,Source=BinaryData,Target=NgenDelete,CustomActionData=C:\Windows\Microsoft.NET\Framework64\v4.0.30319\Ngen.exe;;C:\Program Files\Autodesk\AutoCAD 2013\acad.exe)
MSI (s) (88:C4) [21:03:58:551]: Executing op: ActionStart(Name=NgenCreate,Description=Generating native image for assembly.,Template=Compiler: [1]
Assembly Path: [2])
MSI (s) (88:C4) [21:03:58:552]: Executing op: CustomActionSchedule(Action=NgenCreate,ActionType=1025,Source=BinaryData,Target=NgenCreate,CustomActionData=C:\Windows\Microsoft.NET\Framework64\v4.0.30319\Ngen.exe;;C:\Program Files\Autodesk\AutoCAD 2013\acad.exe)
MSI (s) (88:F4) [21:03:58:555]: Invoking remote custom action. DLL: C:\Windows\Installer\MSI7F8B.tmp, Entrypoint: NgenCreate
CustomAction NgenCreate returned actual error code 1603 (note this may not be 100% accurate if translation happened inside sandbox)

 

 

 

thanks!

Active Member
cristiantrillos
Posts: 6
Registered: ‎10-08-2012
Message 4 of 4 (5,066 Views)

Re: Autocad MEP 2013 Installation fails code 1603 ngenCreate

10-12-2012 04:14 PM in reply to: cristiantrillos

Hello,

 

The problem has been solved.

 

On researching the web i, somehow, didn't manage to come across the correct post that explains the behavior and points out the solution, it was only when I tried to search-engine my own post that the other one appeared.

 

The solution is at "Up and Ready"

 

http://upandready.typepad.com/up_and_ready/2012/10/error-ngenexe-and-installing-any-autocad-product....

 

to sum it up the problem comes down to the SP1 for ACAD 2013 which has to be manually uninstalled (from Control Panel, Programs, Updates) so as to make it possible for ACAD MEP to go through.

 

(an article comment suggests SP1 for ACAD MEP would also cause anyother autocad product to fail to install)

 


thanks in any case

 

 

You are not logged in.

Log into access your profile, ask and answer questions, share ideas and more. Haven't signed up yet? Register

Announcements
Are you familiar with the Autodesk Expert Elites? The Expert Elite program is made up of customers that help other customers by sharing knowledge and exemplifying an engaging style of collaboration. To learn more, please visit our Expert Elite website.

Need installation help?

Start with some of our most frequented solutions to get help installing your software.

Ask the Community


Up & Ready Blog

Boldly Install, Configure and Deploy Autodesk Software.

AutodeskHelp Blog

Your one-stop shop for the latest solutions, breaking news, and behind the scenes access to the world of Autodesk support.

Connect with Us

Twitter

Pinterest

Blog

Youtube