Installation & Licensing

Reply
Active Contributor
jdaulton
Posts: 32
Registered: ‎05-10-2010
Message 1 of 13 (2,044 Views)

AutoCAD Map 3D 2011 Deployment Fails

2044 Views, 12 Replies
05-12-2010 11:04 AM
Greetings,

When trying to create a deployment of Map 3D 2011 it fails because it cannot do the copy functions of the HelpHTML folder/files. I have read the KB article about this (http://usa.autodesk.com/adsk/servlet/ps/dl/item?siteID=123112&id=14950602&linkID=9240857) however I cannot do what is suggested because the deployment image is deleted(AdminImage folder is deleted) after clicking "OK" on the error prompt. Below is what is the in the Setup.log file.

Deployment ACAD CopySharedContent failed! 266

Any help would be much appreciated.

Thanks!

**UPDATE**
This is still not working. I copied the contents of the DVD to a folder and ran setup.exe from there. I get all the way through the deployment process and it fails because it cannot copy the HelpHTML folder/files. Once this fails the deployment is "undone" or deleted which removes the adminimage folder. Since this occurs I cannot perform the steps mentioned in the link in my original post.

Surely someone has ran into this? Has anyone at least created a deployment image with Map 3D 2011? Successful or not? I'm going to create another thread in the installation issue's forum but only because I did not see that forum until after I posted the original.
**UPDATE**
Alumni
DouglasLauritsen
Posts: 642
Registered: ‎04-16-2008
Message 2 of 13 (2,044 Views)

Re: AutoCAD Map 3D 2011 Deployment Fails

05-13-2010 04:53 PM in reply to: jdaulton
My guess is that you have a bad DVD, or troublesome DVD drive or drivers. Try a different computer and/or copy the DVD to a network share. Then create the Deployment from there. Also, try logging into the Subscription portal, download the Map 3D 2011 installer, or ordering replacement media.

The download is a self-extracting WinRAR archive that extracts to C:\Autodesk by default. You can specify a different location if you wish. Clicking the Install button extracts the archive and launches the setup.exe. The extracted files remain after the Installer is exited.

The Technical Solution, and a corresponding entry in the Map 3D 2011 readme, is for customized Deployments after their AdminImage is created.

I’d like to see a screen shot of the error and the log file on the client running the Deployment Wizard. Type %temp% in the address bar of Windows Explorer then look for a file called “AutoCAD Map 3D 2011 Setup.log”.

Douglas Lauritsen, Autodesk Product Support


Douglas Lauritsen
Support Specialist
Product Support
Autodesk, Inc.

Active Contributor
jdaulton
Posts: 32
Registered: ‎05-10-2010
Message 3 of 13 (2,044 Views)

Re: AutoCAD Map 3D 2011 Deployment Fails

05-17-2010 07:47 AM in reply to: jdaulton
Thanks for the reply.

I have tried the deployment on two different computers (one workstation running Windows 7, and a server running Windows Server 2003). The first few times I ran the deployment from the workstation straight from the DVD. Which resulted in the same error. After some research I copied the DVD to a share but still had same problem.

Attached is a screenshot of the error message for you to look at. Below is the log file that you requested. I will wait until I get a reply before I consider downloading the installer.

**SETUP LOG**

2010/5/12:11:17:33 forceadmin CLUSTER-NODE1 === Setup started on CLUSTER-NODE1 by forceadmin ===
2010/5/12:11:30:49 forceadmin CLUSTER-NODE1 === Setup ended ===

2010/5/12:11:24:29 forceadmin CLUSTER-NODE1 === Setup started on CLUSTER-NODE1 by forceadmin ===
2010/5/12:11:38:03 forceadmin CLUSTER-NODE1 === Setup ended ===

2010/5/12:13:33:46 forceadmin CLUSTER-NODE1 === Setup started on CLUSTER-NODE1 by forceadmin ===
2010/5/12:13:34:31 forceadmin CLUSTER-NODE1 === Setup ended ===

2010/5/12:13:34:20 forceadmin CLUSTER-NODE1 === Setup started on CLUSTER-NODE1 by forceadmin ===
2010/5/12:13:40:34 forceadmin CLUSTER-NODE1 Deployment VCREDIST2005X86 CreateAdminImage succeeded!
2010/5/12:13:40:34 forceadmin CLUSTER-NODE1 Deployment VCREDIST2005X86 Finalize succeeded!
2010/5/12:13:40:35 forceadmin CLUSTER-NODE1 Deployment VCREDISTX86 CreateAdminImage succeeded!
2010/5/12:13:40:35 forceadmin CLUSTER-NODE1 Deployment VCREDISTX86 Finalize succeeded!
2010/5/12:13:41:03 forceadmin CLUSTER-NODE1 Deployment DOTNET CreateAdminImage succeeded!
2010/5/12:13:41:03 forceadmin CLUSTER-NODE1 Deployment DOTNET Finalize succeeded!
2010/5/12:13:41:04 forceadmin CLUSTER-NODE1 Deployment ADR CreateTransform succeeded!
2010/5/12:13:41:13 forceadmin CLUSTER-NODE1 Deployment ADR CreateAdminImage succeeded!
2010/5/12:13:41:13 forceadmin CLUSTER-NODE1 Deployment ADR CopyUserFiles succeeded!
2010/5/12:13:41:13 forceadmin CLUSTER-NODE1 Deployment ADR Finalize succeeded!
2010/5/12:13:41:16 forceadmin CLUSTER-NODE1 Deployment KB958481 CreateAdminImage succeeded!
2010/5/12:13:41:16 forceadmin CLUSTER-NODE1 Deployment KB958481 Finalize succeeded!
2010/5/12:13:41:16 forceadmin CLUSTER-NODE1 Deployment KB958483 Finalize succeeded!
2010/5/12:13:41:16 forceadmin CLUSTER-NODE1 Deployment DOTNETUPDATE Finalize succeeded!
2010/5/12:13:41:16 forceadmin CLUSTER-NODE1 Deployment VCREDIST2005X64 Finalize succeeded!
2010/5/12:13:41:17 forceadmin CLUSTER-NODE1 Deployment VCREDISTX64 CreateAdminImage succeeded!
2010/5/12:13:41:17 forceadmin CLUSTER-NODE1 Deployment VCREDISTX64 Finalize succeeded!
2010/5/12:13:41:19 forceadmin CLUSTER-NODE1 Deployment DIRECTX CreateAdminImage succeeded!
2010/5/12:13:41:19 forceadmin CLUSTER-NODE1 Deployment DIRECTX Finalize succeeded!
2010/5/12:13:41:22 forceadmin CLUSTER-NODE1 Deployment FaroSDK CreateAdminImage succeeded!
2010/5/12:13:41:22 forceadmin CLUSTER-NODE1 Deployment FaroSDK Finalize succeeded!
2010/5/12:13:41:24 forceadmin CLUSTER-NODE1 Deployment MSXML CreateAdminImage succeeded!
2010/5/12:13:41:24 forceadmin CLUSTER-NODE1 Deployment MSXML Finalize succeeded!
2010/5/12:13:41:24 forceadmin CLUSTER-NODE1 Deployment WMF CreateAdminImage succeeded!
2010/5/12:13:41:24 forceadmin CLUSTER-NODE1 Deployment WMF Finalize succeeded!
2010/5/12:13:42:06 forceadmin CLUSTER-NODE1 Deployment CM CreateAdminImage succeeded!
2010/5/12:13:42:06 forceadmin CLUSTER-NODE1 Deployment CM Finalize succeeded!
2010/5/12:13:42:37 forceadmin CLUSTER-NODE1 Deployment CMILL CreateAdminImage succeeded!
2010/5/12:13:42:37 forceadmin CLUSTER-NODE1 Deployment CMILL Finalize succeeded!
2010/5/12:13:42:38 forceadmin CLUSTER-NODE1 Deployment ACAD CreateTransform succeeded!
2010/5/12:13:46:55 forceadmin CLUSTER-NODE1 Deployment ACAD CreateAdminImage succeeded!
2010/5/12:13:46:55 forceadmin CLUSTER-NODE1 Deployment ACAD CopyUserFiles succeeded!
2010/5/12:13:46:57 forceadmin CLUSTER-NODE1 Deployment ACAD CreateGPOMsi succeeded!
2010/5/12:13:46:57 forceadmin CLUSTER-NODE1 Deployment ACAD Finalize succeeded!
2010/5/12:13:48:55 forceadmin CLUSTER-NODE1 Deployment ACAD_en-us CreateAdminImage succeeded!
2010/5/12:13:48:55 forceadmin CLUSTER-NODE1 Deployment ACAD_en-us Finalize succeeded!
2010/5/12:13:50:26 forceadmin CLUSTER-NODE1 Deployment CMILM CreateAdminImage succeeded!
2010/5/12:13:50:26 forceadmin CLUSTER-NODE1 Deployment CMILM Finalize succeeded!
2010/5/12:13:50:26 forceadmin CLUSTER-NODE1 Deployment ADR CopySharedContent succeeded!
2010/5/12:13:50:55 forceadmin CLUSTER-NODE1 Deployment ACAD CopySharedContent failed! 3
2010/5/12:13:51:32 forceadmin CLUSTER-NODE1 === Setup ended ===

2010/5/17:10:10:38 forceadmin CLUSTER-NODE1 === Setup started on CLUSTER-NODE1 by forceadmin ===
2010/5/17:10:11:19 forceadmin CLUSTER-NODE1 === Setup ended ===

**SETUP LOG**
Alumni
DouglasLauritsen
Posts: 642
Registered: ‎04-16-2008
Message 4 of 13 (2,044 Views)

Re: AutoCAD Map 3D 2011 Deployment Fails

05-17-2010 04:27 PM in reply to: jdaulton
When I research this, either internally or on the web, I only find this thread and your thread on the AutoCAD Map 3D forum. Therefore there is not much to go on here and the log file is not very specific as to the reason it cannot create the copy of these resources in the AdminImage. It could be read problems with the source, write or permission problems with the destination, Group Policy Objects, a back ground application, driver, virus, or many other possibilities.

The “The system cannot find the path specified” may be a generic error that an experienced Windows Certified IT person may have to troubleshoot.

Have you test installed directly from the DVD, download, or image on the hard drive? What is the result?

Are both Share and NTFS permissions appropriately set on the volume with the Share defined? Maybe appropriate NTFS permissions were not set and there is a permissions problem.

Your UNC path for the Deployment may be too long. Try sharing at Autodesk, then run the Deployment wizard to the shorter location. This reduces the length of every file path in the deployment by 26 characters, reducing the chance you exceed Microsoft limits on path length.

Also, try running the Installer as an Administrator by right-clicking on the setup.exe, then choosing the “Run as…” option. What is this result?

The \\Data-fc\Autodesk\Help folder structure does not make sense. If you had copied the DVD to a folder called \Data-fc\Autodesk the child folders contained within would have been language (IE en-US), Eula, Map 3D, Msi, and x64. The installer would be \\Data-fc\Autodesk\setup.exe. Also it looks like it is copying from the Deployment to this other folder; the reverse of copying to the AdminImage folder. What is this \\Data-fc\Autodesk\Help folder? What is the path of the source location of the setup.exe? What is the destination folder you are designating in the Deployment Wizard? Is the name of the Deployment Map3D?

I assume forceadmin is a Domain Admin? What are the results if you create a new container with no GPO’s and move this user to the new container in Active Directory for testing?

Douglas Lauritsen, Autodesk Product Support


Douglas Lauritsen
Support Specialist
Product Support
Autodesk, Inc.

Active Contributor
jdaulton
Posts: 32
Registered: ‎05-10-2010
Message 5 of 13 (2,045 Views)

Re: AutoCAD Map 3D 2011 Deployment Fails

05-18-2010 08:38 AM in reply to: jdaulton
I have not tested an install from the DVD, etc. but I have tested the deployment image creation on my PC and a Server and both get the same errors. This has been with two different user accounts. Forceadmin is the end all be all account and I know it's permissions are not an issue. I know that NTFS permissions are not an issue because I have created deployments for other Autodesk products (AutoCad, 3DSMax, Architecture) all 2011 and they have all worked. All permissions are inherited to all child objects below "Autodesk" and the accounts (mine and Forceadmin) have full control of this share so it's definitely not a security/permissions issue.

All shared content (plotters, templates, textures, help, etc.) are located in a single shared folder "Autodesk" which has been used for all other working deployments that I have created. I have separated the DVD directory from the AdminImage directory. The setup.exe is located in "\\data-fc\Appinstall\Administrative\Autodesk\Map3D DVD". The "Specify the Administrative Image location" are located with the rest of our application installs. For example "\\data-fc\Appinstall\Administrative\Autodesk\Map3D" is the path to our Map3D AdminImage which has been named "fdiMAP3D2011".

I have considered the UNC path being too long but the other deployments haven't had any issue. Which I know, isn't saying much. I will try an install directly from the DVD. Maybe it is just bad media.

Thanks for the reply.
Alumni
DouglasLauritsen
Posts: 642
Registered: ‎04-16-2008
Message 6 of 13 (2,044 Views)

Re: AutoCAD Map 3D 2011 Deployment Fails

05-18-2010 05:34 PM in reply to: jdaulton
I Got it. Thank you for the update. You are using the “Custom folders” option on the “Select Installation Folders for Support Content” page of the Deployment Wizard and specifying the Help files location as \\Data-fc\Autodesk. I just tested the same scenario and duplicated the error. I have a couple of solution ideas to try. I’ll post my findings in the next 24 hours.
Douglas Lauritsen, Autodesk Product Support


Douglas Lauritsen
Support Specialist
Product Support
Autodesk, Inc.

Alumni
DouglasLauritsen
Posts: 642
Registered: ‎04-16-2008
Message 7 of 13 (2,044 Views)

Re: AutoCAD Map 3D 2011 Deployment Fails

05-19-2010 03:03 PM in reply to: jdaulton

This can happen when specifying a network location for either the "Single shared folder" or the Help files location for the "Custom folders" options on the "Select Installation Folders for Support Content" page of the Deployment Wizard. The cause is the same as is documented in the noted Technical Solution and the Readme.


To work around this pre-seed the deployment location with this directory structure: "file://hostcomputer/ShareName/.../DeploymentName/AdminImage/X86/EN-US/ACAD/ACAD/PROGRAM%20FILES/ROOT...". Then copy the HelpHTML folder into the Root folder. The Deployment wizard will build the AdminImage around these folders and files. Result is that as the Deployment Wizard nears completion it will be able to write files to this shared network location. Otherwise the Deployment Wizard fails when it cannot install the shared files to the network location.


Douglas Lauritsen, Autodesk Product Support
We appreciate your quick feedback on this forum!



Douglas Lauritsen
Support Specialist
Product Support
Autodesk, Inc.

Active Contributor
jdaulton
Posts: 32
Registered: ‎05-10-2010
Message 8 of 13 (2,044 Views)

Re: AutoCAD Map 3D 2011 Deployment Fails

05-20-2010 05:54 AM in reply to: jdaulton
Whoohoo! Finally! I was worried that the contents would be overwritten if I were to do this but thankfully it prompts you if you want to overwrite or not. Thanks for your assistance and support Douglas! Autodesk may have to add the details of this case to the KB article.

Thanks again,

Jeremy
Alumni
DouglasLauritsen
Posts: 642
Registered: ‎04-16-2008
Message 9 of 13 (2,044 Views)

Re: AutoCAD Map 3D 2011 Deployment Fails

05-20-2010 08:48 AM in reply to: jdaulton
I am glad to help. I have already started the process of getting this information into a Technical Solution. I’ll post something here when it is live.
Douglas Lauritsen, Autodesk Product Support


Douglas Lauritsen
Support Specialist
Product Support
Autodesk, Inc.

Alumni
DouglasLauritsen
Posts: 642
Registered: ‎04-16-2008
Message 10 of 13 (2,044 Views)

Re: AutoCAD Map 3D 2011 Deployment Fails

05-26-2010 09:20 AM in reply to: jdaulton

You will find the Technical Solution for this cannot find the path specified error here:

The system cannot find the path specified error when Creating Administrative Images for Custom Netwo...

Douglas Lauritsen, Autodesk Product Support



Douglas Lauritsen
Support Specialist
Product Support
Autodesk, Inc.

You are not logged in.

Log into access your profile, ask and answer questions, share ideas and more. Haven't signed up yet? Register

Announcements
Are you familiar with the Autodesk Expert Elites? The Expert Elite program is made up of customers that help other customers by sharing knowledge and exemplifying an engaging style of collaboration. To learn more, please visit our Expert Elite website.

Need installation help?

Start with some of our most frequented solutions to get help installing your software.

Ask the Community


Up & Ready Blog

Boldly Install, Configure and Deploy Autodesk Software.

AutodeskHelp Blog

Your one-stop shop for the latest solutions, breaking news, and behind the scenes access to the world of Autodesk support.

Connect with Us

Twitter

Pinterest

Blog

Youtube