Area :: Header
3ds Max 2015 Extension 1 is here

With new tools to power your pipeline
Discussion Groups

Installation - Hardware - OS

Reply
Member
Avonthalonus
Posts: 5
Registered: ‎06-02-2010

Slow Component Selection in Maya

368 Views, 13 Replies
09-16-2010 08:49 AM
I'm running Maya 2011 and whenever I enter a component selection mode such as vertex or faces on objects with 35K polygons or more, viewport navigation (rotating, panning, and zooming the view) starts getting really slow and jerky, and selection of individual components (i.e. vertices, edges, faces) also has considerable lag. If I move my cursor over a vertex or face, it takes a while before the face highlights. If I try to drag a bounding box to make a selection, I have to wait several seconds before the bounding box actually shows, and when I release the button, it takes a while for the selection to be recognized. Using paint or drag selection tools are also really slow, and sometimes extraneous vertices totally outside where I've painted or dragged get randomly selected. I would have thought that with a first-class workstation graphics card, I shouldn't have issues like these; are my expectations too high? Is this just normal behavior that happens anytime your polygon count gets too high? I didn't think 35K quads was that high...

Details about my system:
CPU: core i7 860 2.8 GHz
OS: Windows 7 Ultimate 64-bit
Memory: 8 GB RAM
GPU: ATI Firepro V8750, driver version: 8.702.3

Any advice or feedback from others who have similar experiences would be welcome. Thanks.
Please use plain text.
Member
Stimps
Posts: 3
Registered: ‎10-12-2010

Re: Slow Component Selection in Maya

10-12-2010 03:35 PM in reply to: Avonthalonus
Same problem here, i have logged a bug report with Autodesk, no response. We are using Maya 2011 SP1. (repro on vanilla and HF1-3)

We are getting this one multiple machines in the office

Most common specs:

CPU: core i5 750 2.6 GHz
OS: Windows 7 Professional 64-bit
Memory: 4 GB RAM
GPU: Nvidia GTS 250 or 9800 GT, driver version: latest

Very very annoying, tried many hardware and driver configurations.
Please use plain text.
Distinguished Contributor
MichielDuvekot3232
Posts: 1,581
Registered: ‎03-25-2010

Re: Slow Component Selection in Maya

10-12-2010 05:22 PM in reply to: Avonthalonus
GPU: Nvidia GTS 250 or 9800 GT, driver version: latest


It would be tremendously helpful and make this information relevant to people viewing it later, if you posted the actual version of the drivers instead of referring to it as "latest".
Please use plain text.
Member
Stimps
Posts: 3
Registered: ‎10-12-2010

Re: Slow Component Selection in Maya

10-12-2010 06:07 PM in reply to: Avonthalonus
Sorry:
driver version: 258.96_desktop_win7_winvista_64bit_english_whql.exe

tried a few older ones also, same result.
Please use plain text.
Distinguished Contributor
MichielDuvekot3232
Posts: 1,581
Registered: ‎03-25-2010

Re: Slow Component Selection in Maya

10-13-2010 11:07 AM in reply to: Avonthalonus
Did you try version 197.45
Please use plain text.
*Expert Elite* | Moderator
cg_oglu
Posts: 2,989
Registered: ‎08-22-2006

Re: Slow Component Selection in Maya

10-13-2010 11:40 AM in reply to: Avonthalonus
a friend of mine had the same problem caused by his ani-virus software...
----------------------------------------------------------------------
http://www.linkedin.com/pub/christoph-schaedl/6/558/73b
Please use plain text.
Contributor
francoman
Posts: 16
Registered: ‎03-19-2007

Re: Slow Component Selection in Maya

10-13-2010 01:55 PM in reply to: Avonthalonus
For me the lag is when I select or deselect an object and try to move the viewport cam. You can tell theres a lag also by looking at how long it takes for the name of the object you are selecting to appear in the rename option box in the status line. It should be pretty instant but not for me.

I had thought I'd managed to fix it by forcing off 'vertical sync' in the nvidia 3d settings..but the lag came back after about 10 secs...which is just plain wierd.

I've tried numerous drivers including 197.45.
Please use plain text.
Contributor
sim.on
Posts: 21
Registered: ‎08-23-2006

Re: Slow Component Selection in Maya

10-16-2010 02:04 AM in reply to: francoman
what you can try is to add these 2 lines of code into your "Maya.env"
that is what i sometimes add in my Maya.env , when i have problems with Geforce-cards on any computer .

MAYA_GEFORCE_SKIP_OVERLAY = 1
MAYA_NO_VERTEX_ARRAY_SELECT = 1


i am not 100% sure what the MAYA_NO_VERTEX_ARRAY_SELECT does , but it think , it might fix your problem .

-------
another thing i experienced on "HIGHRES_POLYGoN-MESHES" ( e.g. like 100 000 vertecies ) when selecting components : it can take quite some time to add e.g. some faces to the selection - and that seems to be because of the "UNDO"-stack , which always creates a NEW selection and saves to old one in order to do an UNDO lateron / each time , once you modify your selection ... and i personally experienced a "lag" of 3-10 seconds , in a former project .

then a collegue recommended me to "switch of" the UNDO in the preferences , and it helped .
Please use plain text.
Contributor
francoman
Posts: 16
Registered: ‎03-19-2007

Re: Slow Component Selection in Maya

10-16-2010 08:14 PM in reply to: Avonthalonus
yeah tried that, still no fix. The issue I have is also with just a single sphere in scene.

Thanks though
Please use plain text.
Contributor
francoman
Posts: 16
Registered: ‎03-19-2007

Re: Slow Component Selection in Maya

10-18-2010 01:26 PM in reply to: Avonthalonus
I wonder if theres a chance someone from autodesk will respond to this issue?
Please use plain text.