Infrastructure Map Server General Discussion

Infrastructure Map Server General Discussion

Reply
Valued Contributor
Keith.Campbell1
Posts: 93
Registered: ‎12-10-2003
Message 1 of 3 (78 Views)

MG Enterprise in Production

78 Views, 2 Replies
09-14-2006 07:14 AM
Just wandered how many people actually have any production sites running MGE. We use MG6.3 heavily and based on my assessment of MGE so far, I'd be very reluctant to migrate our live applications.

There are a number of reasons:-

1. ODBC data provider seems to be very slow. This has been commented on by others in this and the OSGeo forum. The problem increases hugely if an ODBC data source is used in a secondary join to another feature (SDF). As a comparison, to turn on a layer, select an object and view the properties, then turn it off, it took 6 secs with an SDF-only layer, 22 secs ODBC-only layer, 78 secs with an SDF-joined to ODBC.

2. SQL Server data provider only allows layers to be created if the data in SQL has been created with Map 2007 (as far as I can tell). What if the SQL data already exists? Haven't managed to successfully display a layer based on an SDF joined to a SQL Server data provider.

3. No support for reading views/queries in databases.

4. Memory leaks. I suspect these have been addressed in the Open Source version 1.0.1 and in the upcoming service pack, but for now they exist.

5. Mapagent application errors. On the server, Windows reports unhandled exception errors. Don't know what event has lead to these. May have been fixed as above.

On the whole, I like where MGE is going. It performs well (given limited testing) with SDF based layers. It looks good and the fact that a plug-in is not required is a big plus. However, I don't think it's ready yet for production. Any body else like to comment on this?

Keith
*James Card
Message 2 of 3 (78 Views)

Re: MG Enterprise in Production

09-14-2006 09:01 AM in reply to: Keith.Campbell1
On Thu, 14 Sep 2006 07:14:30 -0700, Keith.Campbell1 wrote:

> Just wandered how many people actually have any production sites running
> MGE. We use MG6.3 heavily and based on my assessment of MGE so far, I'd
> be very reluctant to migrate our live applications.

We have one site in active use built on MGOS, and another in final
testing. Both are relatively simple datasets.

> On the whole, I like where MGE is going. It performs well (given limited
> testing) with SDF based layers. It looks good and the fact that a
> plug-in is not required is a big plus. However, I don't think it's ready
> yet for production. Any body else like to comment on this?

I agree. MapGuide Enterprise looks promising for a year or two out, but
for right now it is very limiting. We've got one customer that wants to
upgrade a MapGuide LiteView site we built for them a couple of years ago,
but it looks like we might have to switch to Mapserver because MGE's WMS
support is so buggy right now.

--
James Card
Valued Contributor
Keith.Campbell1
Posts: 93
Registered: ‎12-10-2003
Message 3 of 3 (78 Views)

Re: MG Enterprise in Production

09-18-2006 02:13 AM in reply to: Keith.Campbell1
Just wondered - is the LiteView site not performing well? There have been some adverse comments on this forum in the past. We have not implemented any LiteView apps, but are looking for a good plug-in free option.

Keith
Announcements
Are you familiar with the Autodesk Expert Elites? The Expert Elite program is made up of customers that help other customers by sharing knowledge and exemplifying an engaging style of collaboration. To learn more, please visit our Expert Elite website.
Need installation help?

Start with some of our most frequented solutions or visit the Installation and Licensing Forum to get help installing your software.