Infrastructure Map Server General

Reply
Contributor
sdalakov
Posts: 11
Registered: ‎02-18-2007
Message 1 of 6 (115 Views)

Feature joins problem

115 Views, 5 Replies
02-19-2007 04:33 AM
I see this issue was commented before, but still I don't know if there is a solution. I want to connect an SDF data to an ACCESS table. Everything seems OK, but when trying to create a theme, based on a field from ACCESS, I get "Parameter was not found " error. I am using Studio 2007 with SP1 and MapGuide OS 1.1. Records in both sources are exactly matching.
Employee
dswilson
Posts: 728
Registered: ‎09-14-2006
Message 2 of 6 (115 Views)

Re: Feature joins problem

02-20-2007 07:52 AM in reply to: sdalakov
What are the datatypes of the columns you are joining on? They have to match for the join to succeed. Does the join work correctly without theming? What datatype are you trying to theme on?

Regards,
Dave


Dave Wilson
SQA Analyst
AEC IM
Autodesk, Inc.

Contributor
sdalakov
Posts: 11
Registered: ‎02-18-2007
Message 3 of 6 (115 Views)

Re: Feature joins problem

02-20-2007 05:34 PM in reply to: sdalakov
In SDF file key values are Char- they look like "100.01.56". In MS ACCESS they are defined as text. Seems that the join works (How to test ?) as I see in the list of fields, available for theming, all fields from ACCESS, I see no error messages. I attach here both SDF and ACCESS files - in case you are so kind (and have time of course) to have a look at.
Contributor
sdalakov
Posts: 11
Registered: ‎02-18-2007
Message 4 of 6 (115 Views)

Re: Feature joins problem

02-20-2007 05:37 PM in reply to: sdalakov
I am trying to have a theme on based on a "long integer" field.

Regards
Stefan
*Andy Morsell
Message 5 of 6 (115 Views)

Re: Feature joins problem

02-20-2007 06:31 PM in reply to: sdalakov
I was able to theme this data without a problem. I used the SDF NAME field
and the Access table IMOT field as the key fields (the SDF KEY field did not
correlate with the Access data). I then themed on the long integer ADDRCODE
field from the Access database.

Do you have MapGuide Enterprise Service Pack 1 applied? I know there were
some problems with data extensions on non-integer keys prior to the service
pack.

--
Andy Morsell, P.E.
Spatial Integrators, Inc.
http://www.SpatialGIS.com


wrote in message news:5493824@discussion.autodesk.com...
In SDF file key values are Char- they look like "100.01.56". In MS ACCESS
they are defined as text. Seems that the join works (How to test ?) as I see
in the list of fields, available for theming, all fields from ACCESS, I see
no error messages. I attach here both SDF and ACCESS files - in case you are
so kind (and have time of course) to have a look at.
Contributor
sdalakov
Posts: 11
Registered: ‎02-18-2007
Message 6 of 6 (115 Views)

Re: Feature joins problem

02-21-2007 01:11 AM in reply to: sdalakov
Thanks a lot Andy
I switched to the right field and now its OK.
Sorry to spend your time on my faults

Regards
Stefan Dalakov

You are not logged in.

Log into access your profile, ask and answer questions, share ideas and more. Haven't signed up yet? Register

Announcements
Are you familiar with the Autodesk Expert Elites? The Expert Elite program is made up of customers that help other customers by sharing knowledge and exemplifying an engaging style of collaboration. To learn more, please visit our Expert Elite website.

Need installation help?

Start with some of our most frequented solutions to get help installing your software.

Ask the Community