Infrastructure Map Server General Discussion

Infrastructure Map Server General Discussion

Reply
Active Member
wcrichton
Posts: 6
Registered: ‎02-09-2006
Message 1 of 5 (161 Views)

Feature Join with SQL Server not displaying geometry

161 Views, 4 Replies
09-23-2006 02:43 PM
I have set up a feature join as part of a data definition.

The Feature source was loaded from a SHP and converted to SDF.
There are three properties associated with the geometry, FeatId, STRKEY, INTKEY

The joined feature source is a SQL Server database connected through ODBC. I have tried to establish the link using both textual data and integer data and have the same issue with both attempts.

When I reference this feature source in a layer, I have the option of viewing either the primary feature class or the joined feature class.

Selecting the primary feature class in the layer definition displays my geometry but not the joined fields.
Selecting the joined feature class in the layer definition shows my joined fields but no geometry.

Can anyone give me some pointers on linking an SQL Server database to an SDF layer?

Thanks,
Will
Employee
dswilson
Posts: 728
Registered: ‎09-14-2006
Message 2 of 5 (161 Views)

Re: Feature Join with SQL Server not displaying geometry

09-25-2006 04:29 PM in reply to: wcrichton
Hi Will,

please ensure that the primary feature source is the SDF. if the primary resource is the ODBC connection you likely won't have geometry associated with it and that may explain what you are seeing. You should select the new Joined feature class. DO NOT select the new Joined geometry. Use the existing one from the SDF.

That should be it.

Dave


Dave Wilson
SQA Analyst
AEC IM
Autodesk, Inc.

Contributor
katjaalbrecht
Posts: 14
Registered: ‎04-09-2003
Message 3 of 5 (161 Views)

Re: Feature Join with SQL Server not displaying geometry

01-29-2007 07:20 AM in reply to: wcrichton
I’m having exactly the same problem even though sdf is the primary feature class (please see the enclosed screeshots).
But this is the way to label geometrie with data-fields from the joined feature, isn’t it? At least it should be?
I use MapGuide Studio SP1
Thanks for any help, Katja
Employee
dswilson
Posts: 728
Registered: ‎09-14-2006
Message 4 of 5 (161 Views)

Re: Feature Join with SQL Server not displaying geometry

01-31-2007 12:16 PM in reply to: wcrichton
Everything looks correct Katja.

What data types are the columns you are joining on? The join does work on string and integer values. If the values are decimal they may not match because of precision issues.

Dave


Dave Wilson
SQA Analyst
AEC IM
Autodesk, Inc.

Contributor
katjaalbrecht
Posts: 14
Registered: ‎04-09-2003
Message 5 of 5 (161 Views)

Re: Feature Join with SQL Server not displaying geometry

02-02-2007 01:47 AM in reply to: wcrichton
Hi Dave, thanks for your reply. The data types were all right, the problem was, as we just found out, a obviously invalid character in a column name! We didn't even use the column, called SVG-NR. But as soon as we changed the name to SVG_NR, everything worked!
Ypieh!
Thanks, Katja

You are not logged in.

Log into access your profile, ask and answer questions, share ideas and more. Haven't signed up yet? Register

Announcements
Are you familiar with the Autodesk Expert Elites? The Expert Elite program is made up of customers that help other customers by sharing knowledge and exemplifying an engaging style of collaboration. To learn more, please visit our Expert Elite website.

Need installation help?

Start with some of our most frequented solutions to get help installing your software.

Ask the Community