Infrastructure Map Server Developer

Reply
New Member
Posts: 1
Registered: ‎09-16-2013
Message 1 of 2 (150 Views)

Error or bug in OSGeo FDO Provider for SQL Server Spatial in Autodesk Studio2014

150 Views, 1 Replies
09-16-2013 02:38 PM

I was wondering if you could tell me if this is a bug or else how to configuring this correctly? I receive the following error when trying to test my connection using the built-in OSGeo FDO Provider for SQL Server Spatial from Autodesk Studio 2014 to a MS SQL Server Spatial server (v 10.50.4000)...

 

An exception occurred in FDO component.
RDBMS: [Microsoft][SQL Server Native Client 10.0][SQL Server]The server principal "myLoginHere" is not able to access the database "WrongDatabaseNotMyDefault" under the current security context.  (Cause: , Root Cause: RDBMS: [Microsoft][SQL Server Native Client 10.0][SQL Server]The server principal "myLoginHere" is not able to access the database "WrongDatabaseNotMyDefault" under the current security context. )

 

Additional details:

- The database listed in the error above is not what I expected. I was expecting the FDO to try and connect to the default database configured to my login id.

-I am able to connect and see data but am not able to select geometry from AIMS Studio using the OSGeo FDO Provider for ODBC.

-I am able to connect and see data and geometry rows using Microsoft SQL Management Studio.

-I can see other database names from Microsoft SQL Management Studio but I do not have permissions to view any details about these databases.

-The first database listed in the databases I can see is the "WrongDatabaseNotMyDefault" database from the error!

 

Thanks For Your Help,

 

Nathan

 

 

 

Valued Mentor
Posts: 317
Registered: ‎10-10-2003
Message 2 of 2 (22 Views)

Re: Error or bug in OSGeo FDO Provider for SQL Server Spatial in Autodesk Studio

04-10-2014 06:07 AM in reply to: ndeneau
There is a requirement that the user you log into SQL Server with AIMS, needs to be able to connect to all Databases on the SQL Server, even if they don't have rights.
This is a weird bug, and Using the Microsoft SQL Server Management Studio, you will have to use the Security>Logins - and under Properties for that user, enable all "User Mapping" to all databases on the server.

Yucky I know, but that is the work around for that bug in AIMS 2014 and older.

You are not logged in.

Log into access your profile, ask and answer questions, share ideas and more. Haven't signed up yet? Register

Announcements
Are you interested in helping shape the Autodesk Community?
We’re looking at a few different ways to improve the “All Forums” landing page and need your feedback! If interested, please take a few minutes to fill out the following Usability Study. Thank you for your time!

Need installation help?

Start with some of our most frequented solutions to get help installing your software.

Ask the Community