InfraWorks General

Reply
*Expert Elite*
BrianHailey
Posts: 2,749
Registered: ‎04-27-2005
Message 1 of 7 (719 Views)
Accepted Solution

Odd Image Display

719 Views, 6 Replies
09-02-2012 12:13 AM

So, I downloaded 70+ images from the nationalmap.gov website. Now, I don't want to add each one of these individually so I select the multiple files when I add the images and they look odd, almost chess board like. 

http://screencast.com/t/Nb5x10dra5L8

If I add them one at a time, they don't have the checkered appearnce. Any idea on how to add them all at the same time and have them display correctly?

*Expert Elite*
TRogers
Posts: 1,206
Registered: ‎09-05-2007
Message 2 of 7 (715 Views)

Re: Odd Image Display

09-02-2012 07:35 AM in reply to: BrianHailey

I have had this happen from time to time.  Seems to be a glitch.  The way that I fixed it was to go into the Options, Select 3D Generation, and change the Generator Threads count.  I changed mine to 10 and had the issues with the images.  Then changed it to 4, restarted the program and the images were fine.

If the issue was resolved by this method, please click on "Accept As Solution"
*Civil 3DJ*
Todd Rogers

Visit my blog here.

     
Employee
konstantin.baumann
Posts: 87
Registered: ‎01-04-2011
Message 3 of 7 (708 Views)

Re: Odd Image Display

09-03-2012 01:35 AM in reply to: BrianHailey

Do your images have an alpha channel? Are your image tiles seamless or do they overlap a bit?

 

If you can provide a 3x3 tiles sample dataset I can have a deeper look into this.

*Expert Elite*
BrianHailey
Posts: 2,749
Registered: ‎04-27-2005
Message 4 of 7 (706 Views)

Re: Odd Image Display

09-03-2012 09:19 AM in reply to: konstantin.baumann

The images are just GeoTIF files that I downloaded from nationalmap.gov. I'll see if I can get a tile group together for you. Not sure how big they will be but I'll do my best.

 

I tried editing the Generator Threads as suggested by Todd with no success.

*Expert Elite*
BrianHailey
Posts: 2,749
Registered: ‎04-27-2005
Message 5 of 7 (699 Views)

Re: Odd Image Display

09-03-2012 10:11 AM in reply to: konstantin.baumann

So, I got the nine images showing the issue and here is what they look like in the model:

 

http://screencast.com/t/KD82G2t3v4

 

And this is how they look when I bring them into MAP 3D

 

http://screencast.com/t/ISHKEQ2xcs 

 

I have the files in the zip file but it's almost 1 gig. I'll contact you via e-mail about getting the files to you.

Employee
konstantin.baumann
Posts: 87
Registered: ‎01-04-2011
Message 6 of 7 (688 Views)

Re: Odd Image Display

09-05-2012 01:14 AM in reply to: BrianHailey

Reporting back to the forum:

 

The provided images have 4 color channels: red, green, blue, and a 4th one, which looks either like a near infrared or like a gray-scale version of the RGB channels.

 

In the default settings, AIM assumes to use RGB + alpha mask for a 4 channel image, which is not appropriate in this case, since the 4th channel is definitely not an alpha channel; so you have several options here to setup the import correctly:

  1. use the RGB channels only: switch to "RGB" for Raster->Band Mapping->Type
  2. use the 4th channel as grayscale: switch to "Gray" for Raster->Band Mapping->Type and select the 4th band for the "gray" channel below
  3. use the 4th channel as near infrared: switch to "RGB" for Raster->Band Mapping->Type and select the 4th band for the "red" channel below
*Expert Elite*
BrianHailey
Posts: 2,749
Registered: ‎04-27-2005
Message 7 of 7 (679 Views)

Re: Odd Image Display

09-05-2012 10:26 PM in reply to: konstantin.baumann

That did the trick! Thanks for the help!

You are not logged in.

Log into access your profile, ask and answer questions, share ideas and more. Haven't signed up yet? Register

Announcements
Are you familiar with the Autodesk Expert Elites? The Expert Elite program is made up of customers that help other customers by sharing knowledge and exemplifying an engaging style of collaboration. To learn more, please visit our Expert Elite website.

Need installation help?

Start with some of our most frequented solutions to get help installing your software.

Ask the Community