Freewheel

Reply
New Member
btimby
Posts: 2
Registered: ‎04-14-2011
Message 1 of 3 (1,533 Views)

?path=https://... not working.

1533 Views, 2 Replies
04-14-2011 01:18 PM

Hi, I am trying to use Freewheel on our site, and our site runs over SSL. Therefore the URL I pass via the path= parameter is https://. When I do this, I get the following error:

 

The requested DWF is not valid.

 

If I use http:// it works just fine. Also, I can see from my HTTP server log that I am in fact sending the file over HTTP or HTTPS, so the only difference would be the server certificate validation that is happening within your software.

 

I imagine this must be because our certificate is not valid as far as your HTTPS client is concerned. The UserAgent shows WinHttp.WinHttpRequest.5, which I assume is a Microsoft HTTP component you are using. Are you by chance missing the GlobalSign root certificate on your servers?

 

http://www.globalsign.com/support/rootinstall.html

 

Thank you for your consideration.

New Member
btimby
Posts: 2
Registered: ‎04-14-2011
Message 2 of 3 (1,528 Views)

Re: ?path=https://... not working.

04-14-2011 04:46 PM in reply to: btimby

I tried a different https:// site with a certificate from GoDaddy and it worked fine.

 

I am fairly certain now that it is this specific certificate (more accurately, the CA).

 

Thanks.

Board Manager
Posts: 1,084
Registered: ‎11-13-2006
Message 3 of 3 (1,507 Views)

Re: ?path=https://... not working.

05-02-2011 05:57 PM in reply to: btimby

Thanks for the detective work.



Scott Sheppard
Program Manager
Autodesk Labs
Autodesk, Inc.

You are not logged in.

Log into access your profile, ask and answer questions, share ideas and more. Haven't signed up yet? Register

Announcements
Welcome to the new Autodesk Community!
If this is your first visit, click here to get started and make the most of the Community. Let us know what you think of the new experience in the Community Feedback Forum.

Need installation help?

Start with some of our most frequented solutions to get help installing your software.

Ask the Community