Freewheel

Reply
New Member
Posts: 2
Registered: ‎08-31-2007
Message 1 of 4 (1,471 Views)

Is Freewheel cutting off url's resulting in a 404 error?

1471 Views, 3 Replies
03-01-2012 05:19 AM

We have been having some so called it "upgrades" so I have had to move my dwf files to a portal system that results is fairly long url's. When I try to open one in freewheel, I get the 404 - file not found error. The url in the address bar is correct but the page is displaying a cut off url. If I enter the url to my file in bitly and run it that way, it works. If there is a way around doing that for all my files, I would be much happier!

The full link:

http://freewheel.autodesk.com/dwf_S.aspx?cx=0.5&cy=0.5&scale=1&page=1&dwf=http%3a%2f%2fportal.ncdenr...

 

The file I am trying to load is:

http://portal.ncdenr.org/c/document_library/get_file?p_l_id=1169848&folderId=229599&name=DLFE-10320....

 

 

Thanks for any help!

Board Manager
Posts: 1,084
Registered: ‎11-13-2006
Message 2 of 4 (1,451 Views)

Re: Is Freewheel cutting off url's resulting in a 404 error?

03-27-2012 07:42 AM in reply to: steve.kaufman

When I navigated to the link you posted, the file opened up in Autodesk Design Review. This is to be expected since you posted an URL to a DWF. Please post the FReewheel URL you are using so we can test that. That way we can see what additional parameters you are supplying.



Scott Sheppard
Program Manager
Autodesk Labs
Autodesk, Inc.
New Member
Posts: 2
Registered: ‎08-31-2007
Message 3 of 4 (1,448 Views)

Re: Is Freewheel cutting off url's resulting in a 404 error?

03-27-2012 08:04 AM in reply to: scott.sheppard

Scott,

If I click the first link I posted, I get the 404 error - the second link is just the file name and should just open in Design Review. In the meantime, I ran all of my url's through goo.gl and put the short url in on the webpage I was running through and that seems to solve the problem.

 

Thanks,

Steve

Board Manager
Posts: 1,084
Registered: ‎11-13-2006
Message 4 of 4 (1,442 Views)

Re: Is Freewheel cutting off url's resulting in a 404 error?

03-29-2012 07:22 AM in reply to: steve.kaufman

I don't think it is a length thing. The code for Freewheel allows long URLs. I think the

 

&name=DLFE-10320.dwf

 

portion is being grabbed by Freewheel instead of by the browser request to get the DWF to pass to Freewheel. Freewheel is grabbing the argument, determining that name means nothing to it, and ignoring it.



Scott Sheppard
Program Manager
Autodesk Labs
Autodesk, Inc.

You are not logged in.

Log into access your profile, ask and answer questions, share ideas and more. Haven't signed up yet? Register

Announcements
Welcome to the new Autodesk Community!
If this is your first visit, click here to get started and make the most of the Community. Let us know what you think of the new experience in the Community Feedback Forum.

Need installation help?

Start with some of our most frequented solutions to get help installing your software.

Ask the Community