I knwo this is early days so hopefully things like this can change without too much issue.
I really think "Floor" & "Ceiling" are not good keynames in the context of design scripting.
Many Many times are people going to use this tool to define floors and ceilings and this use of terminology could confuse.
Surely some like Math.RoundUp and Math.RoundDown are preferrable, not too mention obvious as to the intent of the function??
I thought one of key elements was to bring people without any programming background into this slowly and easily, using computer terminology should be avoided where possible and this is an obvious case for new learners.
Is there any background as to why the terminology is in conflict with what Architects and Engineers will use to describe many objects???
My vote is for keeping the names as they are. Floor and Ceiling are standard mathematical notation (see http://en.wikipedia.org/wiki/Floor_and_ceiling_fun
I my view it's is more confusing to change such established names, but I suppose it all comes down to the intended target audience as mentioned above.
Well, if nothing else, they need moving out of the global namespace and into the Math namespace But that will need to wait a bit until better support for namespacing comes along...
Thanks for your input anyhow