DWF

Reply
New Member
timofeyT
Posts: 2
Registered: ‎02-28-2011
Message 1 of 3 (469 Views)

DWF Toolkit 7.6 works incorrectly on Linux 64bit

469 Views, 2 Replies
02-28-2011 11:46 PM

Hi

 

I have a problem with parsing W2D file. When I try to read objects by function process_next_object() some first opcodes read correctly (these opcodes are ASCII and Extended_Ascii), but next opcode reading failed with error "WT_Result::Corrupt_File_Error".

 

Call Stack:

WT_File::read ... at file.cpp:2846]

WT_String::materialize ... at wtstring.cpp:463]

WT_Text::materialize ... at text.cpp:292]

WT_File::get_next_object ... at file.cpp:1578]

WT_File::smileytongue:rocess_next_object ... at file.cpp:1530]

mainW2DComponentsExtraction::ExtractMainW2DComponents ... at src/MainW2DComponentsExtraction.cpp:25]

 

Sample of project is attached. Need to change path to DWF Toolkit in "Include Directories".

 

Any idea? Is it bug in DWF Toolkit?


Some comments

My operating system is Ubuntu 10.10 64bit. I compiled library independently (don't use binary files).

I try to use DWF Toolkit on Ubuntu 32bit and all is good. Document is parsed without any problem.

Employee
ordodyg
Posts: 7
Registered: ‎09-05-2007
Message 2 of 3 (391 Views)

Re: DWF Toolkit 7.6 works incorrectly on Linux 64bit

03-22-2011 01:21 PM in reply to: timofeyT

Hi,

 

I haven't looked at your smaple project, however I have compiled a project that uses the toolkit on 64 bit Ubuntu (10.10).

 

Please clarify what you have already done (eg. if my understanding is correct):

- You downloaded the toolkit :smileyhappy:

- You read the build instructions in the build folders

- You used the ./configure command then built the toolkit (eg. you built yourself and "didn't use the binary"

- You're linking the toolkit you built to your project

- It crashes during processing of 2d

 

If this is the case, can you also attach the file you're trying to process?

 

Gyuri Ordody

Autodesk

Cheers,
Gyuri Ordody
Autodesk Labs
New Member
timofeyT
Posts: 2
Registered: ‎02-28-2011
Message 3 of 3 (272 Views)

Re: DWF Toolkit 7.6 works incorrectly on Linux 64bit

10-26-2011 10:51 PM in reply to: ordodyg

Gyuri Ordody,

Sorry for late response, 64-bit app version was in low priority, but now priority is high.

 

All steps of the your checklist are done. DWF Toolkit starts parse W2D file (GraphicResource), but after reading first ASCII opcodes, I get the result WT_Result::Unsupported_DWF_Opcode.

 

I suggest the reason in reading file by bytes, possible origin is wrong.

 

I attached the drawing file. And I hope for your help.

 

Thanks

You are not logged in.

Log into access your profile, ask and answer questions, share ideas and more. Haven't signed up yet? Register

Announcements
Are you familiar with the Autodesk Expert Elites? The Expert Elite program is made up of customers that help other customers by sharing knowledge and exemplifying an engaging style of collaboration. To learn more, please visit our Expert Elite website.

Need installation help?

Start with some of our most frequented solutions to get help installing your software.

Ask the Community