Area :: Header
Interested in making Indie games?

Register for a Meet the Experts webinar with Digital-Tutors today!
Discussion Groups

Community Help

Reply
Distinguished Contributor
andrew.c
Posts: 368
Registered: ‎09-10-2005

FAQ and Common Solutions

174 Views, 36 Replies
05-30-2007 10:57 AM
This thread is a community fed list, recording solutions for common issues and answers to frequently asked questions. Please contribute!

(To ensure usability, his thread will be strictly moderated.)
Please observe the following format when posting in this thread:

Issue or question

Solution or answer (clearly described)

If you wish to further discuss any issues that are posted here, start another thread. Any posts to this thread that do not provide an issue and solution will be removed to make sure the thread remains clean and browse-able for the community.
Please use plain text.
Contributor
x_PredatorGSR
Posts: 25
Registered: ‎02-24-2007

Re: FAQ and Common Solutions

05-30-2007 07:41 PM in reply to: andrew.c
Can the admins host any images in this thread on skymatter servers and relink them so that they won't disappear if they are deleted from the original location in the future?

When baking normal and/or displacement maps, the map comes out completely black

This is an issue with UVs. Some of your UVs are straying outside of the 0,1 space. When baking, you will see that it tries to bake out two maps as well. This can be fixed by adjusting your UVs so that they are completely inside of the 0,1 space.

How to bake out normal/displacement maps for a character with multiple maps.
(Please change/add info for this one if it is not entirely correct)

First of all, your character must use a single UV set. Each group of UVs must be in a UV square in the positive UV space (i.e 0,1 0,2). When baking out the maps, you must add "%i" without quotes to the end of the file name to let Mudbox know to bake out multiple maps correctly. If you fail to add this the maps will come out black.

You need to change your UVs after sculpting in mudbox in order to bake maps.

One way to accomplish this is to export your lowest level, and your highest level. Fix the UVs in the lowest level, then import it into a new mudbox scene. Choose your bake settings, and choose your high res object from file, and pick the high res .obj that you exported. This will bake your high res maps using the UVs from your new low res.

The UVs of your smoothed mudbox sculpt are distorted and stretching across the map or your normal/displacement maps are showing similar problems.

http://konradbeerbaum.com/stretching.jpg

This may be caused by the way Mudbox handles geometry that isn't quads. When baking normal/displacement maps, you can usually avoid this issue by setting the base mesh subdivision to "none". If it is set to something other than "none", Mudbox smooths the mesh before baking, and thus your UVs will be distorted in the low res as well.

If you want to export your high res geometry, the UVs will still be messed up. I do not know a workaround for exporting the high res with good UVs.

There are stepping artifacts in your normal map.

http://konradbeerbaum.com/stepping.jpg

The reason for the artifacts is the main UVs of the low res head are "backward". That is, the UVs on the right side of the UV tile correspond with UVs on the left side of the head. In the example above, the problem was fixed by flipping the low res geometry's UVs horizontally in Maya.
Please use plain text.
Distinguished Contributor
mookiemu
Posts: 969
Registered: ‎01-16-2007

Re: FAQ and Common Solutions

05-31-2007 07:28 PM in reply to: andrew.c
Spikes created when the displacement map is applied, resulting from white spots in the displacement map that are near the area with holes. Such as eyes, ears, mouths.

Here are some ways to handle this that I know of, if anybody else has other suggestions, please feel free to email me and I will add it to this post and credit you.

The spikes result from the rays searching for a correlation between the hi-res mesh and the low-res mesh and not finding enough geometry near the holes.

Solution 0ne:
sculpt with a little extra geometry in the areas with holes. then delete a row or two of the polys where the holes are on the low res after you bake your map and before you apply it. If you do this and plan for it, It works every time.

Solution two:
Close the holes right from the beginning. ie... sculpt the eye sockets, Sculpt the mouth cavity etc... (not always practical)

Solution three:
This isn't ideal and if you have geometry on the low res that you can delete before applying the displacement map then you don't need to do this.
Edit the white spots out of the displacement map. The stamp tool in Photoshop works quite well with 32-bit floating maps and so so does the marquee and fill. Zoom way into the image and stamp away the white with a dark grey. Be very careful. This is of course the least desirable way of doing it, but it is a very quick solution works well.
*important* Don't convert the 32-bit maps to 16-bit and then back. This will ruin your displacement map.

Solution four:
Export the low-res mesh and add an extra row or two of polys to the areas with holes. Make sure these have UVs.
Then use this mesh to generate your displacement map. delete the extra polys before applying your map. (I get mixed results with this one but it works most of the time.)
Please use plain text.
Distinguished Contributor
Dennis H_1
Posts: 129
Registered: ‎06-08-2008

Re: FAQ and Common Solutions

07-17-2008 10:33 PM in reply to: andrew.c
It would be nice to have visual examples of each problem that commonly occurs along with the ways to possibly fix or work around them!
sorry this was posted in wrong area...
Please use plain text.
Distinguished Contributor
tomcushwa
Posts: 264
Registered: ‎04-04-2007

Re: FAQ and Common Solutions

10-13-2008 02:06 PM in reply to: andrew.c
Wow.. this area is very useful.. I would love to see more FAQs and solutions posted here. This is great.
Please use plain text.
New Member
aweet
Posts: 1
Registered: ‎11-18-2008

Re: FAQ and Common Solutions

11-18-2008 08:07 AM in reply to: andrew.c
I want to konw something more. but I don't know who will answer my question.
Please use plain text.
Active Contributor
kinetiknz
Posts: 33
Registered: ‎10-04-2006

Re: FAQ and Common Solutions

01-08-2009 07:00 AM in reply to: andrew.c
ISSUE: Mudbox crash when leaving expert mode.

FIX: It's an SLI Issue, turning it off fixes the problem.

I haven't looked into changing drivers as yet, this may fix the issue entirely. For now I leave SLI on, and just never use expert mode.
Please use plain text.
Active Contributor
mswertfager
Posts: 40
Registered: ‎06-15-2005

Re: FAQ and Common Solutions

07-10-2009 02:39 PM in reply to: andrew.c
It has been a while since mookiemu's post above concerning artifacts around mesh holes (E.G. eyes, mouths). Are there any new approaches or solutions in Mudbox 2009 around these displacement map dropout areas (all white in the displacement map)?

When I try the Photoshop option (stated above) with EXR files, when I save the EXR file type from Photoshop, the file size is about 20% less. I saved at 32bit RGB...that is concerning. Any thoughts on this? Is Photoshop compressing?


-Michael

Please use plain text.
Distinguished Contributor
a3dcreator
Posts: 470
Registered: ‎03-10-2011

Re: FAQ and Common Solutions

08-12-2009 08:33 PM in reply to: mswertfager
I USUALLY dont model with any holes like that anymore.
i make sure everything is closed.
Please use plain text.
Contributor
polybuilder_1
Posts: 11
Registered: ‎08-09-2008

Re: FAQ and Common Solutions

11-05-2009 01:23 AM in reply to: andrew.c
Question

Hi all... just recently bought Mudbox 2010... and the problem I m having is I cant seem to work over 2 million polygons very well at all... I paid 3K for my laptop so I thought that this would be great enough to use mudbox on... but it turns out that I have done no work in mudbox since I bought it a month ago due to running out of memory all the time... I have tried the 3GB switch in the boot.ini file... but to no avail.

2 million polys just doesn't cut it... nor 6 million for that matter as the detail for the stencils looks crap even at 6 million polys (for example the skin stencils).

here is my machine specs below:

(I have 4GB installed, even though it shows only 3GB, and as stated above, I'm already using the 3GB switch in the boot.ini file)

OPERATING SYSTEM
Name: Microsoft Windows XP Professional
Version: 5.1.2600
Service Pack: 3.0
Architecture:
Registered User: James Sinnott
Language: 1033
Domain Role: 0
Total Physical Memory: 3066 MB
Total Virtual Memory: 2939 MB

PROCESSOR
Number of Processors: 1
Logical Processors: 2
Manufacturer: Genuine Intel
Name: Intel Pentium III Xeon processor
Version: Model 7, Stepping 10
Description: x86 Family 6 Model 23 Stepping 10
Address Width: 32
Number of Cores: 2
Max Core Speed: 3058 MHz

VIDEO
Card Name: NVIDIA GeForce 9800M GTX
Memory: 1024 MB
Driver Name: nv4_disp.dll
Driver Version: 6.14.11.8585
Video Mode: 1920 x 1200 x 4294967296 colors



Question

I thought mudbox 2009 ran better than 2010... at least I think so...

If I have bought mudbox 2010... can I still download/run 2009 full version??



Question

If I upgrade from Win XP Pro(32-bit)... to Win 7 Ultimate (64-bit) will this make ant difference?? that is... will it use my 4GB of RAM more efficiently... i.e get to at around 8 to 10 million polys??

Question


... and finaly... if I was to upgrade... what would I need to do to get the 64-bit version of mudbox??



much appreciate any help on these issues... as I would love to just get my head down and enjoy working in Mudbox... and I've spent enough money as is!!



cheers
James
Please use plain text.