AutoSketch

Reply
*Harvey
Message 1 of 3 (188 Views)

R7 Bug Summary Redux.

188 Views, 2 Replies
11-28-2001 11:41 PM
Graham Howe reminded me that he had previously sent me an old post
detailing bugs found in R7. Had it lurking on the machine in a folder
and forgot where it was. Maybe the newer people would like to see it,
and we can decide how R8 has addressed things.

1. H.Alm BUG#ALM001. Negative Scaling Factor Missing.

"It is perfectly possible to have a negative scaling factor on a symbol
(in
other words to mirror it around the x- or y-axis.)

This can be achieved in many ways (using the mirror command OR
selecting
the symbol and editing the scalefactor in the edit bar OR mirror a
symbol by
selecting it and dragging the scaling handles OR ..)

So, - to my point
1) Select a symbol with negative scaling factor
2) Use the menu command: Edit\Entities\symbol (or right click and
select
the appropriate command)
x-scale and/or y-scale factor is negative in the dialog box
3) Click the OK-button
4) I'll get an errormessage: 'Value can't be less than zero (negative)'

I am using NT 4.0 sp 5 and AS 7.0 build 54
For the purpose of testing I have reset all registry entries for
HKEY_CURRENT_USER\Software\Autodesk\AutoSketch\7.0 to the values they
had
after the initial installation og AS 7.0"
___________________________________________________

2. H.Alm BUG#ALM002. Sometimes Progam Crashes When Saving As DWG.

"When using file save as DWG (AutoCAD 2000) with (and open) SKF or CAD
files
and using a filename / dwg-name which already exist, - AS 7.0 close down
completely, - even without a GPF. I just disappear. The file is not
saved.

Remark 1: This doesn't always happen. Having more than one file open
helps, - sometimes.
Remark2 : I have checked. It also happens when I try to open the same
file.

I am using NT 4.0 sp 5 and AS 7.0 build 54
For the purpose of testing I have reset all registry entries for
HKEY_CURRENT_USER\Software\Autodesk\AutoSketch\7.0 to the values they
had
after the initial installation and AS 7.0"
__________________________________________________

3. H.Alm. BUG#ALM003. Program Does Not Remember Folder Changes Between
Session.

"AS7 does not remember folder changes between sessions. (Oh, Yes I have
checked the "Save folder change" checkbox I the redesigned file open
dialogbox).

After starting AS 7 the file open box will always show the
standard .\autosketch\drawing folder (which I don't even use). This even
sometimes applies within the same working session.

PS I am using NT 4.0 sp 5 and AS 7.0 build 54
For the purpose of testing I have reset all registry entries for
HKEY_CURRENT_USER\Software\Autodesk\AutoSketch\7.0 to the values they
had
after the initial installation of AS 7.0"
_________________________________________________

4. H.Alm BUG#004. DWG Export Problems

"AS7 is much worse than AS6 when exporting to DWG.
Some of the errors:

#ALM004A)
Multiline text is incorrect with wrong coordinates and wildly incorrect
linespacing in AutoCAD (This is/was also the case in some version of
Drafix.)

#ALM004B)
Multiline text in symbols behaves like bug #ALM004A

#ALM004C)
Symbols with other scaling than 1.0 is not properly displayed in
AutoCAD.

Ex scaling 10.0 will actually become 10.0 in AutoCAD, but will display
only
with scaling 1.0. (This might be an AutoCAD bug since inserting the
very
same block (symbol) in AutoCAD with scaling 10.0 will display correct.)

To illustrate / prove my point have place the AO1.CAD file in the
customer-files area.

If you don't have AutoCAD, save it as DWG2000, close the file, and open
it
again (using mm as unit). Then you will see bug 004A .Dug 004B and 004C
will
only appears in AutoCAD 2000 (or 2000 lt)

I am using NT 4.0 sp 5 and AS 7.0 build 54
For the purpose of testing I have reset all registry entries for
HKEY_CURRENT_USER\Software\Autodesk\AutoSketch\7.0 to the values they
had
after the initial installation og AS 7.0"
___________________________________________________________

5. H.ALM ALM#005. Panebitmap Selection Handles Disappear.

"In View\Options\Current the checkbox for "Save Bitmaps for each Pane"
has
been removed (since version 6.0)

It is still possible to set the value directly in the registry in the
key;

[HKEY_CURRENT_USER\Software\Autodesk\AutoSketch\7.0\Preferences]

But setting "Panebitmaps" to "0" will make the (redesigned) selection
handles disappear.

This is a small bug, but the feature (Panebitmaps) is now undocumented,
so I'll guess we have to accept it."
_________________________________________________________

6. Ric Norris NT Bug#1-AS7 Default Paths to Drawing, Symbol and
Property Folders
"This has been documented by AutoDesk......AutoSketch Knowledge Base
Index
Document TS49677....however, it is only partly complete and what is
strange,
is that the same problem exists in QuickCAD 7 but no reference is made
in
the QuickCAD Knowledge Base. AutoDesk could perhaps take note.

Operating system is NT4 Service Pack 6 and applies to both AutoSketch 7
AND
QuickCAD 7. Please note this problem doesn't exist in Windows 95/98.

The problem is being unable to default the paths to the Drawing Folder,
Symbol Folder & Property Folder (the latter does not concern me).

The above mentioned document deals with fixing ONLY the Drawing Folder.
The
command is found in Tools>Customise Commands>Folders

Changes must be made in the Registry as follows:

HKEY_CURRENT_USER
+Software
+AutoDesk
+AutoSketch
+7
Environment
"PathDrawing" (change to correct path)
"PathSymbol" (change to correct path)

HKEY_LOCAL_MACHINE
+Software
+AutoDesk
+AutoSketch
+7
Environment
"PathDrawing" (change to correct path)
"PathSymbol" (change to correct path)

Then make sure the above changes have been automatically updated in:

HKEY_USERS
+the key with really long number - (under .DEFAULT)
+Software
+AutoDesk
+AutoSketch
+7
Environment
"PathDrawing"
"PathSymbol"

I have found that the Drawing Path can also be changed by right mouse
clicking on Desktop Shortcut to the
application...Properties>Shortcut>Start
in.

Obviously, there will not be a patch for NT4.....but it would be very
interesting to know if the above problem exists in Windows2000 and if it
does, one would then expect a patch. Are there any Windows2000 users
out
there...???"
______________________________________________________________

7. Ric Norris. NT Bug#2-AS7

"Operating system is NT4 Service Pack 6 and applies to both AutoSketch 7
AND
QuickCAD 7. Please note this problem doesn't exist in Windows 95/98.

The problem is the ArchitecuralSampler Symbol Library ALWAYS remains as
the
default symbol library. A problem you may ask...??...it is when you
have no
need for it and delete it. Therefore when launching the application,
the
following message appears:

"Can't open library C:\AutoDesk\Symbols\_ArchitecturalSampler.slb".
Need to
hit OK twice.

Then.....when launching Content Explorer the following message appears:

"Unable to locate the Current Symbol Library". Hit OK and then navigate
the
drive directories to the correct library location.

Of course, this needs to be done everytime you launch the program.

Changes must be made in the Registry as follows:

HKEY_CURRENT_USER
+Software
+AutoDesk
+AutoSketch
+7
Environment
"DefaultSymbolLibrary" (change to correct path)

HKEY_LOCAL_MACHINE
+Software
+AutoDesk
+AutoSketch
+7
Environment
"DefaultSymbolLibrary" (change to correct path)

Then make sure the above changes have been automatically updated in:

HKEY_USERS
+the key with really long number - (under .DEFAULT)
+Software
+AutoDesk
+AutoSketch
+7
Environment
"DefaultSymbolLibrary"

Obviously, there will not be a patch for NT4.....but it would be very
interesting to know if the above problem exists in Windows2000 and if it
does, one would then expect a patch. Are there any Windows2000 users
out
there...???"
_________________________________________________________________

8. NT Bug#3-AS7 Mouse Wheel - Program Lockup

"I am not totally sure of this one and have no real explanation.....it
deals
with the zooming function when using the wheel on
the Intellimouse Explorer.

The problem being....when using the wheel, the program locked up.
However, the
problem would clear when the "View
Extent All" command was issued and things were back to normal until you
used the
wheel again.

At the same time, the co-ordinates in the Dial area of the Status Bar
would
appear as follows: (I don't know whether this
image will attach...but will try anyway and have also posted the image
in CF -
"AS7 Status Bar")



The really strange thing is that the wheel zoomed perfectly when used
with files
created in QC4.11 but seized completely
when opening files created in LT2000 (saved as 2000/R14/R13) and also
when
creating new drawings and new drawings
saved in AS.

I then dived into the Intellimouse software and tried "Enable
Intellipoint wheel
support for all programs except:"....problem
still existed. Then tried "Turning off all Intellipoint software wheel
support".....problem still existed.

Then went to View>Options>Current>View Changes>Fast Zoom Percentage and
changed
the default of 200% to 150%....for
some reason....success...!!!....only 95% of the time though....still not
completely right.

Hi ho, hi ho.....in to the Registry I go.

HKEY_CURRENT_USER
+Software
+AutoDesk
+AutoSketch
+7
Preferences
"ZoomFactor"

It is a binary value, which means squiddley to me....so I changed it to
a value
that QuickCAD 4.11 used...of 1.5 (must be a
minimum value of 1....default is 2)

TOTAL success....the wheel zooms as it should....no further problems."
_____________________________________________________________

9. Ric Norris. Text Conversion To DWG Using Millimeter Units (Same As
Number 4
This Post?)

"Launch AS7 and 'Start Drawing Immediately'. Create some multiline
text of 5 or
6 lines....save the drawing as an R14 .DWG file. Close the drawing.

Then open the newly created .DWG file.

Has the text lost its grouping and scattered itself all over the
page...???"
_____________________________________________________________

10. Harrinj. Shift+Arrow Key To Move A Line Does Not Work

"I use the 'Shift & Arrow' keys to nudge entities a grid point at a
time. So
far, it works well with everything (circles, arcs, symbols, etc.) except
single
lines. Whenever I try to nudge a line, Autosketch fatally crashes with
a 'divide
by zero' error. The problem repeatedly occurs."
_____________________________________________________________

Your Welcome.
*Jackson, Paul
Message 2 of 3 (188 Views)

Re: R7 Bug Summary Redux.

11-29-2001 11:04 AM in reply to: *Harvey
Hello Harvey

I think a tick can be placed on most of those !

Paul

"Harvey" wrote in message
news:3C065723.7180D803@westnet.com...
> Graham Howe reminded me that he had previously sent me an old post
> detailing bugs found in R7. Had it lurking on the machine in a folder
> and forgot where it was. Maybe the newer people would like to see it,
> and we can decide how R8 has addressed things.
>
> 1. H.Alm BUG#ALM001. Negative Scaling Factor Missing.
>
> "It is perfectly possible to have a negative scaling factor on a symbol
> (in
> other words to mirror it around the x- or y-axis.)
>
> This can be achieved in many ways (using the mirror command OR
> selecting
> the symbol and editing the scalefactor in the edit bar OR mirror a
> symbol by
> selecting it and dragging the scaling handles OR ..)
>
> So, - to my point
> 1) Select a symbol with negative scaling factor
> 2) Use the menu command: Edit\Entities\symbol (or right click and
> select
> the appropriate command)
> x-scale and/or y-scale factor is negative in the dialog box
> 3) Click the OK-button
> 4) I'll get an errormessage: 'Value can't be less than zero (negative)'
>
> I am using NT 4.0 sp 5 and AS 7.0 build 54
> For the purpose of testing I have reset all registry entries for
> HKEY_CURRENT_USER\Software\Autodesk\AutoSketch\7.0 to the values they
> had
> after the initial installation og AS 7.0"
> ___________________________________________________
>
> 2. H.Alm BUG#ALM002. Sometimes Progam Crashes When Saving As DWG.
>
> "When using file save as DWG (AutoCAD 2000) with (and open) SKF or CAD
> files
> and using a filename / dwg-name which already exist, - AS 7.0 close down
> completely, - even without a GPF. I just disappear. The file is not
> saved.
>
> Remark 1: This doesn't always happen. Having more than one file open
> helps, - sometimes.
> Remark2 : I have checked. It also happens when I try to open the same
> file.
>
> I am using NT 4.0 sp 5 and AS 7.0 build 54
> For the purpose of testing I have reset all registry entries for
> HKEY_CURRENT_USER\Software\Autodesk\AutoSketch\7.0 to the values they
> had
> after the initial installation and AS 7.0"
> __________________________________________________
>
> 3. H.Alm. BUG#ALM003. Program Does Not Remember Folder Changes Between
> Session.
>
> "AS7 does not remember folder changes between sessions. (Oh, Yes I have
> checked the "Save folder change" checkbox I the redesigned file open
> dialogbox).
>
> After starting AS 7 the file open box will always show the
> standard .\autosketch\drawing folder (which I don't even use). This even
> sometimes applies within the same working session.
>
> PS I am using NT 4.0 sp 5 and AS 7.0 build 54
> For the purpose of testing I have reset all registry entries for
> HKEY_CURRENT_USER\Software\Autodesk\AutoSketch\7.0 to the values they
> had
> after the initial installation of AS 7.0"
> _________________________________________________
>
> 4. H.Alm BUG#004. DWG Export Problems
>
> "AS7 is much worse than AS6 when exporting to DWG.
> Some of the errors:
>
> #ALM004A)
> Multiline text is incorrect with wrong coordinates and wildly incorrect
> linespacing in AutoCAD (This is/was also the case in some version of
> Drafix.)
>
> #ALM004B)
> Multiline text in symbols behaves like bug #ALM004A
>
> #ALM004C)
> Symbols with other scaling than 1.0 is not properly displayed in
> AutoCAD.
>
> Ex scaling 10.0 will actually become 10.0 in AutoCAD, but will display
> only
> with scaling 1.0. (This might be an AutoCAD bug since inserting the
> very
> same block (symbol) in AutoCAD with scaling 10.0 will display correct.)
>
> To illustrate / prove my point have place the AO1.CAD file in the
> customer-files area.
>
> If you don't have AutoCAD, save it as DWG2000, close the file, and open
> it
> again (using mm as unit). Then you will see bug 004A .Dug 004B and 004C
> will
> only appears in AutoCAD 2000 (or 2000 lt)
>
> I am using NT 4.0 sp 5 and AS 7.0 build 54
> For the purpose of testing I have reset all registry entries for
> HKEY_CURRENT_USER\Software\Autodesk\AutoSketch\7.0 to the values they
> had
> after the initial installation og AS 7.0"
> ___________________________________________________________
>
> 5. H.ALM ALM#005. Panebitmap Selection Handles Disappear.
>
> "In View\Options\Current the checkbox for "Save Bitmaps for each Pane"
> has
> been removed (since version 6.0)
>
> It is still possible to set the value directly in the registry in the
> key;
>
> [HKEY_CURRENT_USER\Software\Autodesk\AutoSketch\7.0\Preferences]
>
> But setting "Panebitmaps" to "0" will make the (redesigned) selection
> handles disappear.
>
> This is a small bug, but the feature (Panebitmaps) is now undocumented,
> so I'll guess we have to accept it."
> _________________________________________________________
>
> 6. Ric Norris NT Bug#1-AS7 Default Paths to Drawing, Symbol and
> Property Folders
> "This has been documented by AutoDesk......AutoSketch Knowledge Base
> Index
> Document TS49677....however, it is only partly complete and what is
> strange,
> is that the same problem exists in QuickCAD 7 but no reference is made
> in
> the QuickCAD Knowledge Base. AutoDesk could perhaps take note.
>
> Operating system is NT4 Service Pack 6 and applies to both AutoSketch 7
> AND
> QuickCAD 7. Please note this problem doesn't exist in Windows 95/98.
>
> The problem is being unable to default the paths to the Drawing Folder,
> Symbol Folder & Property Folder (the latter does not concern me).
>
> The above mentioned document deals with fixing ONLY the Drawing Folder.
> The
> command is found in Tools>Customise Commands>Folders
>
> Changes must be made in the Registry as follows:
>
> HKEY_CURRENT_USER
> +Software
> +AutoDesk
> +AutoSketch
> +7
> Environment
> "PathDrawing" (change to correct path)
> "PathSymbol" (change to correct path)
>
> HKEY_LOCAL_MACHINE
> +Software
> +AutoDesk
> +AutoSketch
> +7
> Environment
> "PathDrawing" (change to correct path)
> "PathSymbol" (change to correct path)
>
> Then make sure the above changes have been automatically updated in:
>
> HKEY_USERS
> +the key with really long number - (under .DEFAULT)
> +Software
> +AutoDesk
> +AutoSketch
> +7
> Environment
> "PathDrawing"
> "PathSymbol"
>
> I have found that the Drawing Path can also be changed by right mouse
> clicking on Desktop Shortcut to the
> application...Properties>Shortcut>Start
> in.
>
> Obviously, there will not be a patch for NT4.....but it would be very
> interesting to know if the above problem exists in Windows2000 and if it
> does, one would then expect a patch. Are there any Windows2000 users
> out
> there...???"
> ______________________________________________________________
>
> 7. Ric Norris. NT Bug#2-AS7
>
> "Operating system is NT4 Service Pack 6 and applies to both AutoSketch 7
> AND
> QuickCAD 7. Please note this problem doesn't exist in Windows 95/98.
>
> The problem is the ArchitecuralSampler Symbol Library ALWAYS remains as
> the
> default symbol library. A problem you may ask...??...it is when you
> have no
> need for it and delete it. Therefore when launching the application,
> the
> following message appears:
>
> "Can't open library C:\AutoDesk\Symbols\_ArchitecturalSampler.slb".
> Need to
> hit OK twice.
>
> Then.....when launching Content Explorer the following message appears:
>
> "Unable to locate the Current Symbol Library". Hit OK and then navigate
> the
> drive directories to the correct library location.
>
> Of course, this needs to be done everytime you launch the program.
>
> Changes must be made in the Registry as follows:
>
> HKEY_CURRENT_USER
> +Software
> +AutoDesk
> +AutoSketch
> +7
> Environment
> "DefaultSymbolLibrary" (change to correct path)
>
> HKEY_LOCAL_MACHINE
> +Software
> +AutoDesk
> +AutoSketch
> +7
> Environment
> "DefaultSymbolLibrary" (change to correct path)
>
> Then make sure the above changes have been automatically updated in:
>
> HKEY_USERS
> +the key with really long number - (under .DEFAULT)
> +Software
> +AutoDesk
> +AutoSketch
> +7
> Environment
> "DefaultSymbolLibrary"
>
> Obviously, there will not be a patch for NT4.....but it would be very
> interesting to know if the above problem exists in Windows2000 and if it
> does, one would then expect a patch. Are there any Windows2000 users
> out
> there...???"
> _________________________________________________________________
>
> 8. NT Bug#3-AS7 Mouse Wheel - Program Lockup
>
> "I am not totally sure of this one and have no real explanation.....it
> deals
> with the zooming function when using the wheel on
> the Intellimouse Explorer.
>
> The problem being....when using the wheel, the program locked up.
> However, the
> problem would clear when the "View
> Extent All" command was issued and things were back to normal until you
> used the
> wheel again.
>
> At the same time, the co-ordinates in the Dial area of the Status Bar
> would
> appear as follows: (I don't know whether this
> image will attach...but will try anyway and have also posted the image
> in CF -
> "AS7 Status Bar")
>
>
>
> The really strange thing is that the wheel zoomed perfectly when used
> with files
> created in QC4.11 but seized completely
> when opening files created in LT2000 (saved as 2000/R14/R13) and also
> when
> creating new drawings and new drawings
> saved in AS.
>
> I then dived into the Intellimouse software and tried "Enable
> Intellipoint wheel
> support for all programs except:"....problem
> still existed. Then tried "Turning off all Intellipoint software wheel
> support".....problem still existed.
>
> Then went to View>Options>Current>View Changes>Fast Zoom Percentage and
> changed
> the default of 200% to 150%....for
> some reason....success...!!!....only 95% of the time though....still not
> completely right.
>
> Hi ho, hi ho.....in to the Registry I go.
>
> HKEY_CURRENT_USER
> +Software
> +AutoDesk
> +AutoSketch
> +7
> Preferences
> "ZoomFactor"
>
> It is a binary value, which means squiddley to me....so I changed it to
> a value
> that QuickCAD 4.11 used...of 1.5 (must be a
> minimum value of 1....default is 2)
>
> TOTAL success....the wheel zooms as it should....no further problems."
> _____________________________________________________________
>
> 9. Ric Norris. Text Conversion To DWG Using Millimeter Units (Same As
> Number 4
> This Post?)
>
> "Launch AS7 and 'Start Drawing Immediately'. Create some multiline
> text of 5 or
> 6 lines....save the drawing as an R14 .DWG file. Close the drawing.
>
> Then open the newly created .DWG file.
>
> Has the text lost its grouping and scattered itself all over the
> page...???"
> _____________________________________________________________
>
> 10. Harrinj. Shift+Arrow Key To Move A Line Does Not Work
>
> "I use the 'Shift & Arrow' keys to nudge entities a grid point at a
> time. So
> far, it works well with everything (circles, arcs, symbols, etc.) except
> single
> lines. Whenever I try to nudge a line, Autosketch fatally crashes with
> a 'divide
> by zero' error. The problem repeatedly occurs."
> _____________________________________________________________
>
> Your Welcome.
*Harvey
Message 3 of 3 (188 Views)

Re:

11-30-2001 02:11 AM in reply to: *Harvey
> I think a tick can be placed on most of those !

Us poor saps who purchased R7 might be grateful to see a patch for them.
Maybe next year, I should live so long.

You are not logged in.

Log into access your profile, ask and answer questions, share ideas and more. Haven't signed up yet? Register

Announcements
Welcome to the new Autodesk Community!
If this is your first visit, click here to get started and make the most of the Community. Let us know what you think of the new experience in the Community Feedback Forum.

Need installation help?

Start with some of our most frequented solutions to get help installing your software.

Ask the Community