AutoCAD Plant 3D General DIscussion

Valued Mentor
Posts: 701
Registered: ‎07-29-2005
Message 1 of 3 (152 Views)
Accepted Solution

Flange comes in backwards

152 Views, 2 Replies
07-30-2012 11:17 AM

My catalog did not have flanges for all the sizes needed.  So, I went to 'make it do it'.

1) Found the catalog dwg that the other flanges were pointing.

2) Inserted the 4" flange, exploded it.  Then I scaled it down to a 3" flange (may not be the exact dimensions, but I went with it)

3) Blocked it

4) ran the PLANTPARTCONVERT and added the two connections (I did look at another one to see how they did it)

5) Saved the dwg

6) Ran SpecEditor, edited the Catalog, added the 3" size flange and pointed to the block I had created.  Saved to catalog, got a efilesharing msg, tried a second time, and all went well

7) Tested and the flange came in backwards.

8) Went back to the dwg, reversed the order I placed the connections via the PLANTPARTCONVERT, saved the dwg

9) Ran SpecEditor again, removed the flange from the sped, opened the Catalog, repointed to the DWG/block I had reversed the order of the connections

10) Saved to the catalog (got a msg about an efilesharing, but the second time I ran it, it went fine)

11) Added from the catalog back to my spec and saved

12) tested and the flange came in backwards again


So, I am new to this and understand that I may have missed a step or even went totally the wrong way.  Any advice would be appreciated.

Valued Mentor
Posts: 701
Registered: ‎07-29-2005
Message 2 of 3 (139 Views)

Re: Flange comes in backwards

07-31-2012 05:26 AM in reply to: dennis

Maybe I figured out my problem.  I started a new testing dwg within the project and found the flanges coming in correctly.

Valued Contributor
Posts: 84
Registered: ‎07-10-2009
Message 3 of 3 (135 Views)

Re: Flange comes in backwards

07-31-2012 05:42 AM in reply to: dennis



I think you've got the hang of creating block-based fittings. :smileyhappy:


Assuming the spec updated correctly in the project, the reason for your flange not working in the original drawing, even after modification, is probably because the original version was cached in the drawing file.  If you delete all instances of the flange and purge the drawing, you may find that it now works.




You are not logged in.

Log into access your profile, ask and answer questions, share ideas and more. Haven't signed up yet? Register

Are you familiar with the Autodesk Expert Elites? The Expert Elite program is made up of customers that help other customers by sharing knowledge and exemplifying an engaging style of collaboration. To learn more, please visit our Expert Elite website.

Need installation help?

Start with some of our most frequented solutions to get help installing your software.

New AutoCAD Plant 3D Category!

The AutoCAD Plant 3D forum has moved into it's very own category page, and can no longer be found within the Additional Product Forums.

Ask the Community