AutoCAD P&ID General

Reply
Member
Posts: 4
Registered: ‎02-11-2013
Message 1 of 2 (450 Views)

How to assign the custom layer to the custom class definition?

450 Views, 1 Replies
02-19-2013 01:41 PM

My earlier pipeline tagging issue solved by cadwomen, led me to the next problem.

It turned out I can make the new pipeline class definition to tag different service pipelines with same line number strings. So, I made the new class definition, named Blow Down Pipeline. By default, it took layer 0 properties. I wanted it to be on the separate layer, so I created the new layer with the layer manager, named Blow Down. When I tried to assign this layer to the Blow Down Pipeline class definition, in the Class settings: Blow Down Pipeline Segment dialog box, under Edit Line, General Style Properties, Layer drop-down menu contained only default layers but not the one I created.

Help, please!

Mentor
craig.wood
Posts: 203
Registered: ‎02-20-2012
Message 2 of 2 (439 Views)

Re: How to assign the custom layer to the custom class definition?

02-19-2013 03:06 PM in reply to: upro

You have to create your custom layer within your drawing template used for all new drawings in your project. Or, if you want the new layer to only come in when you use it in any given drawing, you can add it to your projSymbolStyle.dwg, then assign your annotation or symbol to that layer within project setup. If you already have drawings created within your project, as most people likely would, then use the second method above. Really, the best way is to use the second method. But I would caution you to only access projSymbolStyle.dwg when everyone else is out of the project, otherwise unintended and strange things may happen inside your drawings (ie: annotations offsetting themselves to the left without warning).

 

Also, you might have to run "synchstyles" in each drawing to get it to take effect if your annotation has already been placed. You can do this automatically by running "syncstylesmode" and setting it to "1' if you're only using P&ID, otherwise set it to "63" if using both P&ID and 3D. More info on this here:http://docs.autodesk.com/PNID/2013/ENU/

 

I hope this helps!

 

Craig

You are not logged in.

Log into access your profile, ask and answer questions, share ideas and more. Haven't signed up yet? Register

Announcements
Welcome to the new Autodesk Community!
If this is your first visit, click here to get started and make the most of the Community. Let us know what you think of the new experience in the Community Feedback Forum.

Need installation help?

Start with some of our most frequented solutions to get help installing your software.

New AutoCAD P&ID Category!

The AutoCAD P&ID forum has moved into it's very own category page, and can no longer be found within the Additional Product Forums.

Ask the Community