AutoCAD P&ID General Discussion

Reply
Active Contributor
Jan-TSpD
Posts: 35
Registered: ‎07-12-2011
Message 1 of 14 (567 Views)
Accepted Solution

Valve is replaced when assigning tag

567 Views, 13 Replies
11-26-2013 06:04 AM

Hello, i have a P&ID which is copied from another P&ID. After this i assign a tag to a valve, when i click the assign button the tag is re-assigned, but also the valve is replaced by a valve from another (standard PIP) class. This valve is not one of my standard classes, so i can not substitute this valve by another.

Attached an mp4 of the situation.

 

regards, Jan

Product Support
quentin.contreras
Posts: 313
Registered: ‎03-02-2010
Message 2 of 14 (560 Views)

Re: Valve is replaced when assigning tag

11-26-2013 04:49 PM in reply to: Jan-TSpD

If you copied a P&ID dwg file from another project and are placing it in a new P&ID Project, then that might be why you are seeing the issue. The other project has it's Project Setup settings different that the Project you have copied this drawing too. If you are wanting the projects to match you should have created a new project based off the existing project where you brought the drawing from.

If my post answers your question, please mark it as an Accepted Solution, so that others can find answers quickly!



Quentin Contreras
Product Support
gersteb
Posts: 165
Registered: ‎09-20-2010
Message 3 of 14 (533 Views)

Re: Valve is replaced when assigning tag

11-29-2013 05:37 AM in reply to: Jan-TSpD

Hello Jan,

 

the reason therefore can be that symbol scale of imported P&ID was different than the one of your project. Look for the symol scale via 'Edit Symbol' of the class (see attached snapshot).

 

For a working substitution four things have to be set:

  • The classes are in the same class folder
  •  The classes have all a defined symbol
  •  The property 'Substitute' have been set to 'true'
  •  The property 'SupportedStandard' supports the same norm. Therefore select the property and click 'Edit'. Check the settings there.

Regards

Bernd



Bernd Gerstenberger
Active Contributor
Jan-TSpD
Posts: 35
Registered: ‎07-12-2011
Message 4 of 14 (499 Views)

Re: Valve is replaced when assigning tag

12-04-2013 12:11 AM in reply to: gersteb

Hello Bernd,

 

it happens also when copying a drawing from the same project with same projectsetup. It happens randomly.

Scale of all valves in the project is set to "1".

 

Regards,

Jan

 

Product Support
gersteb
Posts: 165
Registered: ‎09-20-2010
Message 5 of 14 (496 Views)

Re: Valve is replaced when assigning tag

12-04-2013 12:54 AM in reply to: Jan-TSpD

Hi Jan,

 

maybe your symbol definition has changed during the lifecycle of your project. Please, set the scale to 10 or another value for this valve symbol adn try again.

 

Regards

Bernd



Bernd Gerstenberger
Active Contributor
Jan-TSpD
Posts: 35
Registered: ‎07-12-2011
Message 6 of 14 (492 Views)

Re: Valve is replaced when assigning tag

12-04-2013 02:22 AM in reply to: gersteb

Hello Bernd,

 

no, the symbol definition did not change during the project.

 

regards, Jan

Active Contributor
Jan-TSpD
Posts: 35
Registered: ‎07-12-2011
Message 7 of 14 (491 Views)

Re: Valve is replaced when assigning tag

12-04-2013 02:28 AM in reply to: gersteb

Hello Bernd,

 

the valve from my class is replaced by a valve from the PIP class (PIP Gate Valve). This valve is not in my project at all.

 

regards, Jan

Product Support
gersteb
Posts: 165
Registered: ‎09-20-2010
Message 8 of 14 (487 Views)

Re: Valve is replaced when assigning tag

12-04-2013 02:34 AM in reply to: Jan-TSpD

Hi Jan,

 

are you able to send me the whole project? You will get a separate email with the access data for a FTP-site from me. Also name the class where I have to look for exactly.

 

Regards

Bernd



Bernd Gerstenberger
Active Contributor
Jan-TSpD
Posts: 35
Registered: ‎07-12-2011
Message 9 of 14 (485 Views)

Re: Valve is replaced when assigning tag

12-04-2013 02:37 AM in reply to: gersteb

Hello Bernd,

 

that is okay.

 

regards, Jan

Active Contributor
Jan-TSpD
Posts: 35
Registered: ‎07-12-2011
Message 10 of 14 (474 Views)

Re: Valve is replaced when assigning tag

12-04-2013 06:53 AM in reply to: gersteb

Hello Bernd,

 

the replacement only happens with P&ID's that are copied into the project, both projects have the same project setup.

When assigning a tag to a valve or substituting a valve, the valve is replaced with a PIP globe valve (which is not in the project).

 

Attached a mp4 file

 

regards, Jan

You are not logged in.

Log into access your profile, ask and answer questions, share ideas and more. Haven't signed up yet? Register

Announcements
Are you familiar with the Autodesk Expert Elites? The Expert Elite program is made up of customers that help other customers by sharing knowledge and exemplifying an engaging style of collaboration. To learn more, please visit our Expert Elite website.

Need installation help?

Start with some of our most frequented solutions to get help installing your software.

New AutoCAD P&ID Category!

The AutoCAD P&ID forum has moved into it's very own category page, and can no longer be found within the Additional Product Forums.

Ask the Community