AutoCAD P&ID General Discussion

Reply
Valued Mentor
ybogdanov
Posts: 385
Registered: ‎07-07-2011
Message 1 of 23 (1,247 Views)

Problem Off Page Connector 2014 in large project

1247 Views, 22 Replies
06-05-2013 01:49 PM

Hello,

If I create 4 new drawings in AutoCAD P&ID 2014, and in each drawing I create line with two off page connectors, and copy this any 15 times, in each drwaing (total 15x2x4=120 Off page connectors). It's imposible to connected it. The program load during connection any 15 minutes...

 

Please help!

-----------------------------------------------------------
Yury Bogdanov
ASIDEK(Grupo CT) - Partner Directo de Autodesk
Barcelona (Spain)
Mentor
craig.wood
Posts: 215
Registered: ‎02-20-2012
Message 2 of 23 (1,229 Views)

Re: Problem Off Page Connector 2014 in large project

06-06-2013 08:33 AM in reply to: ybogdanov

Same issue for us as well...We are experiencing 10-20 minute loading times for the Off-Page Connector “Create Connection” menu to appear. It is my understanding that this is due to the fact that the program queries all of the off-page connectors and their line data upfront, instead of querying an individual drawing’s connectors when that drawing is specifically selected within the “Create Connection” menu. A fix to this would seem to me that the workflow could be changed to only query a drawing’s connectors once it is selected within the “Create Connection” menu, instead of upfront, before an individual drawing is selected. All of our end-users are experiencing these long loading times consistently on our project that currently contains nearly 400 P&IDs. We have a few thousand Off-Page Connectors, which is why querying all OPCs upfront, as the program is coded to do, is not as efficient.

 

Autodesk:

Is there a hotfix in the works for Off-Page Connectors? We are definitely feeling the sting of having to wait 10+ minutes to connect each OPC. Any information you can provide would be helpful. FYI – We just migrated our project from 2013 to 2014 two weeks ago.

 

Craig

Product Support
Dan.Scales
Posts: 297
Registered: ‎03-05-2010
Message 3 of 23 (1,213 Views)

Re: Problem Off Page Connector 2014 in large project

06-11-2013 10:21 AM in reply to: ybogdanov

Hi,

 

If I create 120 unconnected OPC spread out between 4 drawings I only get a delay of 15 seconds when opening the "Create Connection" dialog.

 

I have got another project I am working on where the delay is longer so I will update this post once I have done some more testing with it.

 

Thanks,
Dan



Dan Scales
Mentor
craig.wood
Posts: 215
Registered: ‎02-20-2012
Message 4 of 23 (1,210 Views)

Re: Problem Off Page Connector 2014 in large project

06-11-2013 10:58 AM in reply to: Dan.Scales

Thanks for doing some additional testing Dan. I am currently working with Quentin to see what he can come up with as well. I will be uploading our project to the FTP site today for him to test, so feel free to also let him know your findings as well.

 

Thanks,

Craig

*Expert Elite*
Rave.Tam
Posts: 204
Registered: ‎05-19-2011
Message 5 of 23 (1,160 Views)

Re: Problem Off Page Connector 2014 in large project

06-19-2013 08:56 AM in reply to: craig.wood

Take some time to do a test today. I have 80 OPC in 40 drawings. Can you guess how many database call it made to the server when i try to connect a single OPC?

 

1000+ ! Thats a great way to overload and kill a server. There's a better way than querying each line separately and hit the database everytime. With a proper sql linq query, you can get all the line and OPC information needed with a SINGLE call to the database

 

To get more detail of my test, download and upzip the content to the same folder. Open the XML with IE. You should get the total time to show the OPC dialog, which is over 2 minutes. Open it with notepad to see the entire trace.

If my post answers your question, please click the "Accept as Solution" button.

Check out my blog http://lazcad.com
Contributor
cmcdonnell
Posts: 21
Registered: ‎02-17-2013
Message 6 of 23 (1,101 Views)

Re: Problem Off Page Connector 2014 in large project

06-29-2013 06:43 PM in reply to: ybogdanov

Im having the same problem
massive lag when connecting OPC's

ive about 40 across 20 P&ID's
you could even tolerate it except when you spot a pipe conflict it destroys the link and you have to do it again
its killing me here

Product Support
Dan.Scales
Posts: 297
Registered: ‎03-05-2010
Message 7 of 23 (1,090 Views)

Re: Problem Off Page Connector 2014 in large project

07-01-2013 02:02 AM in reply to: ybogdanov

Hi,

 

This has been logged with our developers and is currently being investigated by them.

 

Thanks,

Dan



Dan Scales
Contributor
cmcdonnell
Posts: 21
Registered: ‎02-17-2013
Message 8 of 23 (1,070 Views)

Re: Problem Off Page Connector 2014 in large project

07-02-2013 10:53 PM in reply to: Dan.Scales
that would be good dan as theres clearly an issue there
Contributor
cmcdonnell
Posts: 21
Registered: ‎02-17-2013
Message 9 of 23 (1,047 Views)

Re: Problem Off Page Connector 2014 in large project

07-09-2013 06:55 PM in reply to: cmcdonnell

Dan any update on this?

Its killing three projects we have on the go. Its clearly an issue as it happens on any project with a large number of connector arrows. We cant even connect the arrows anymore its taking so much time. 

This wasnt an issue in 2013

Mentor
craig.wood
Posts: 215
Registered: ‎02-20-2012
Message 10 of 23 (1,036 Views)

Re: Problem Off Page Connector 2014 in large project

07-10-2013 06:58 AM in reply to: cmcdonnell

cmcdonnell - check your private messages

You are not logged in.

Log into access your profile, ask and answer questions, share ideas and more. Haven't signed up yet? Register

Announcements
Are you familiar with the Autodesk Expert Elites? The Expert Elite program is made up of customers that help other customers by sharing knowledge and exemplifying an engaging style of collaboration. To learn more, please visit our Expert Elite website.

Need installation help?

Start with some of our most frequented solutions to get help installing your software.

New AutoCAD P&ID Category!

The AutoCAD P&ID forum has moved into it's very own category page, and can no longer be found within the Additional Product Forums.

Ask the Community