AutoCAD Map 3D General Discussion

Reply
Mentor
oceanside
Posts: 388
Registered: ‎08-03-2006
Message 1 of 22 (3,382 Views)
Accepted Solution

Can't Get Rid of Ribbon in Workspace

3382 Views, 21 Replies
10-24-2011 01:28 PM

There seems to be always one.......I have someone that likes the "Map Classic Workspace".  I loaded as "Planning & Analysis" when I installed.  I got the Map Classic Workspace to open when they start Map 2012 by adding /w "Map Classic Workspace" to the target but it loads with the Ribbon.  I went to CUI and Customoize the Workspace under Palettes..Ribbon to "No Show" but it is still showing when I close Map and go back in.  Where else do I need to make a change?  Why did they make something so easy so difficult?  Worked fine in past verisons....why mess with a good thing?

the best is at the beach!
Distinguished Contributor
nwray
Posts: 108
Registered: ‎03-10-2008
Message 2 of 22 (3,364 Views)

Re: Can't Get Rid of Ribbon in Workspace

10-25-2011 08:01 AM in reply to: oceanside

What version are you using?  This is apparently a known bug for Map 2012.  Take a look at this thread:

 

http://forums.autodesk.com/t5/AutoCAD-Map-3D/Workspace/td-p/3073092

 

Mentor
oceanside
Posts: 388
Registered: ‎08-03-2006
Message 3 of 22 (3,354 Views)

Re: Can't Get Rid of Ribbon in Workspace

10-25-2011 08:11 AM in reply to: oceanside

2012...Yes, I had previously seem that discussion but that was written in June so I was hoping a solution had been found.  Evidently not because everything I've tried does not work.  All I want is to get the Ribbon off the Map Classic Workspace.

the best is at the beach!
Distinguished Contributor
nwray
Posts: 108
Registered: ‎03-10-2008
Message 4 of 22 (3,346 Views)

Re: Can't Get Rid of Ribbon in Workspace

10-25-2011 09:01 AM in reply to: oceanside

I have created a work around that functions on my machine, so you could give it a try.  No promises though, since I'm still on Map 2010.  

 

The basic idea is that you can have a script file that executes automatically at startup.  Using a text editor like notepad, create a file with the following lines:

 

; Turn ribbon off
ribbonclose

; Blank line above to end the command

 

Then save the file with a .scr (autoCAD script file) extension.  You need to save the file wherever the default location is for autoCAD script files on your system.  I foud out the default on mine by clicking on "tools" then "run script" and seeing what folder it went to automatically.  For me, it's "My Documents", so that's where I saved the file.  Basically, the script will run one command (RIBBONCLOSE) when it is executed.  

 

To make the script run automatically every time you start CAD, you need to add a command line switch to the shortcut icon that you use to launch CAD.  If you right click on your CAD icon on the desktop and select "properties", you should see a space called "target".  This is where you add the command line switches.  The basic file path to start cad should be there allready, and you need to leave it there.  It will allways be something like "C:\Program Files\AutoCAD Map 3D 2010\acad.exe"  After this, input the command line switch "/b"  This switch runs a specified script at startup.  I call the script above "ribbonoff.scr", so the full contents of my "target" on the CAD shortcut are:

 

"C:\Program Files\AutoCAD Map 3D 2010\acad.exe" /b "ribbonoff"

 

All of the quotes shown in the line above are necessary.  All this line does is to launch cad and run the specified script (ribbonoff.scr) when it starts.  

 

On my system, I created a new workspace where the ribbon is set to be on.  I opened and closed it several times to make sure that it allways came up.  I then created and saved the ribbonoff.scr file and added the switch to the shortcut icon on my desktop.  Now, it still opens to the new workspace bu the ribbon is off.

 

Hope that works for you.

 

Norm

Mentor
oceanside
Posts: 388
Registered: ‎08-03-2006
Message 5 of 22 (3,322 Views)

Re: Can't Get Rid of Ribbon in Workspace

10-26-2011 08:49 AM in reply to: oceanside

Will this close the ribbon just for the Map Classic workspace or for all workspaces?

the best is at the beach!
Distinguished Contributor
nwray
Posts: 108
Registered: ‎03-10-2008
Message 6 of 22 (3,314 Views)

Re: Can't Get Rid of Ribbon in Workspace

10-26-2011 12:09 PM in reply to: oceanside

Just checked on my version, and the RIBBONCLOSE command works on all my workspaces (my custom, map classic, task based ribbon, and tool based ribbon).  I think that it's a standard command.  You can test it out from any workspace - just type in RIBBONCLOSE and hit enter (or the spacebar) and see if the ribbon closes.  If it works, then making the script file and adding the startup switch should automatically shut off the ribbon every time you start up CAD.

 

Norm

Product Support
phil_borycens
Posts: 185
Registered: ‎10-25-2011
Message 7 of 22 (3,220 Views)

Re: Can't Get Rid of Ribbon in Workspace

12-02-2011 02:04 PM in reply to: oceanside

Hi all,

This issue was resolved with the release Service Pack 1. Here is the link:

 

AutoCAD Map 3D 2012 Service Pack 1

http://usa.autodesk.com/getdoc/id=DL18021295

Be sure to have a look at the readme before applying this SP.

 

And remember these two commands whenever you want to disable/enable the ribbon for any reason, in any workspace:

RIBBONCLOSE - disables the ribbon

RIBBON - enables the ribbon

 

Thanks!

Phil



Phil Borycens
Distinguished Contributor
phmurphy
Posts: 387
Registered: ‎12-12-2003
Message 8 of 22 (3,134 Views)

Re: Can't Get Rid of Ribbon in Workspace

12-31-2011 10:51 AM in reply to: oceanside

I have installed Map 2012 and the SP1 but still can't get rid of the ribbon when I open a new file or an old one.

 

I have closed the ribbon and saved the settings to the Planning... Layout.  Apparently this is a problem too since I really want a Map Classic layout, but for some reason no matter what I do I still end up with the Planning...Layout.  I just created a Map Classic layout and saved it to the Planning... Layout.

 

How do i get the ribbon to NOT appear when I open old or new files?

 

thanks,

pat

Product Support
phil_borycens
Posts: 185
Registered: ‎10-25-2011
Message 9 of 22 (3,110 Views)

Re: Can't Get Rid of Ribbon in Workspace

01-03-2012 05:52 PM in reply to: phmurphy

Hi Pat,

 

Sorry that you're having this trouble. Sounds like the solution for you (as referenced in an above post by nwray) is to create a startup switch for your desired workspace. More on that here:

 

Map 2012: Default Workspaces

http://gisexchange.typepad.com/blog/2011/05/map-2012-default-workspaces.html



Phil Borycens
Distinguished Contributor
phmurphy
Posts: 387
Registered: ‎12-12-2003
Message 10 of 22 (3,107 Views)

Re: Can't Get Rid of Ribbon in Workspace

01-03-2012 05:57 PM in reply to: phil_borycens

Thanks,

But that link only describes how to change the workspace.  I still have to close the ribbon every time I open MAP.  Is there a switch that will close the ribbon?

 

Pat

You are not logged in.

Log into access your profile, ask and answer questions, share ideas and more. Haven't signed up yet? Register

Announcements
Are you familiar with the Autodesk Expert Elites? The Expert Elite program is made up of customers that help other customers by sharing knowledge and exemplifying an engaging style of collaboration. To learn more, please visit our Expert Elite website.

Need installation help?

Start with some of our most frequented solutions to get help installing your software.

Ask the Community