AutoCAD MEP General

Reply
New Member
russeb
Posts: 1
Registered: ‎04-17-2007
Message 1 of 6 (1,515 Views)

AutoCAD MEP 2013 Crashes loading AECGUIBASE.ARX

1515 Views, 5 Replies
03-08-2013 08:52 AM

On a windows 7 machine I have loaded the new Design Suite from from Subscription.  MEP will boot 2 or 3 time and I will start to play, then the next time I start it will crash at Loading AECGUIBASE.ARX (see screen capture).  If I try to repair the install it makes no differnece.  This has happened at least four times and I have to export the license, delete everyting and reload.  Try to start 2 or 3 times the the next time back to the same spot.  Any Ideas?  Architecture and Autocad are fine.

Product Support
bob.holland
Posts: 283
Registered: ‎02-15-2013
Message 2 of 6 (1,449 Views)

Re: AutoCAD MEP 2013 Crashes loading AECGUIBASE.ARX

03-14-2013 06:44 AM in reply to: russeb

Have you tried installing service pack 1?

http://usa.autodesk.com/adsk/servlet/ps/dl/item?siteID=123112&id=20556436&linkID=9240938

 

Bob Holland

Autodesk Product Support



Bob Holland


Product Support
byron.morales
Posts: 81
Registered: ‎10-04-2011
Message 3 of 6 (1,433 Views)

Re: AutoCAD MEP 2013 Crashes loading AECGUIBASE.ARX

03-14-2013 11:49 AM in reply to: russeb

I am sorry to hear that you are having this trouble. I see in your notes that resetting AutoCAD MEP temporally allows it to work. Are you importing custom settings or a custom profile after resetting? If so, that may be where the issue is coming from. 

See if maybe you can consolidate some of the custom paths and make sure all the paths go to a valid location. If mapping to network locations we recommend you mapped to network drives using the UNC path and not using Mapped drives. 
  
Is the crash possibly due to the permission level of the user on the system? Try testing an admin account vs. a non-admin to see if AutoCAD works in one or the other. 
  
If the above tests are not conclusive, then please do the following: 

Install the service pack for AutoCAD MEP 2013 is you haven't already: 

http://usa.autodesk.com/getdoc/id=DL20556436

If you have this already and try to install it again, it will tell you that you don't need it. 

There are two hotfixes to install after the service pack: 

http://usa.autodesk.com/getdoc/id=DL20659680
http://usa.autodesk.com/getdoc/id=DL20864100
  
Set AutoCAD to always run as administrator: 

Make sure "Hide extensions for known file types" is not checked under the View tab in Control Panel > Folder Options. 
Navigate to where AutoCAD MEP 2013 is installed (i.e., C:\Program Files\Autodesk\AutoCAD 2013). 
Right-click the acad.exe program file and choose Properties. 
Click the Compatibility tab. 
Set the option at the bottom to run as administrator. Click OK. 
  
Disable User Account Control Settings: 
  
Click the Start menu and in the search field type UAC. 
In the window that comes up, move the slider down to Never Notify. 
Click OK and then restart the computer. 
  
Turn off Windows Aero: 

Right-click the desktop and choose Personalize. 
Select either the Windows Basic or Windows Classic theme. 
Close the window. 
  
Install DirectX: 

http://www.microsoft.com/download/en/details.aspx?id=35
  
Update the video driver. Here are the links to get an update, depending on what card you have: 

http://www.nvidia.com/Download/index.aspx
http://support.amd.com/us/Pages/AMDSupportHub.aspx
http://www.intel.com/p/en_US/support/detect

You can check your video card against our graphics hardware list: 

http://www.autodesk.com/autocad-graphicscard

Usually having the latest driver from the manufacturer is best, but sometimes this is not the latest version that we have tested. You can download the tested drivers at the above link. Even if you do have the current/correct video driver, I would suggest uninstalling and re installing it anyway. 

Let me know if the above steps helps you resolve the issue.



Byron Morales
Valued Contributor
Tcaddy
Posts: 53
Registered: ‎04-30-2007
Message 4 of 6 (1,196 Views)

Re: AutoCAD MEP 2013 Crashes loading AECGUIBASE.ARX

04-18-2013 04:03 AM in reply to: russeb

Byron

 

I have a similar problem. We have a custom profile that works OK when it is loaded from within the program.

It also works OK when you state the name of the profile in the startup shortcut in Vanila AutoCAD. However, whenever I use the profile in the AutoCAD MEP target start up shortcut, the program crashes on startup. I made the mods you suggested and for one start up I got the error message [Customisation file load failed. File not found: 'path to cui'], where 'path to cui' stands in for the actual path and file name. However, the next time this did not appear and the software appears to stop working when loading AecGuiBase.arx. So in this instance it would appear to be the custom cui that is causing the problem. My next problem is finding out what's going on:the person that set up the cui has just left the company. Any pointers?

 

Product Support
bob.holland
Posts: 283
Registered: ‎02-15-2013
Message 5 of 6 (1,186 Views)

Re: AutoCAD MEP 2013 Crashes loading AECGUIBASE.ARX

04-18-2013 12:06 PM in reply to: Tcaddy

Tcaddy,

 

Can you please post the string that you are using for your target line for AutoCAD MEP.

 

Thank you.

 

Bob Holland

Autodesk Product Support



Bob Holland


Valued Contributor
Tcaddy
Posts: 53
Registered: ‎04-30-2007
Message 6 of 6 (1,177 Views)

Re: AutoCAD MEP 2013 Crashes loading AECGUIBASE.ARX

04-19-2013 12:31 AM in reply to: bob.holland

Bob

 

Thanks for your reply. Just to advise that I didn't post the string because it contains company confidential information, which is why I used the substitute.

 

I also tried changing the saved file paths to UNC paths but this did not work.

 

I have now tried opening the program from a default profile and setting up my personal profile so that it is working fine from within the program. If I then shut down and start up with the target "C:\Program Files\Autodesk\AutoCAD 2013\acad.exe" it still crashes. I have spoken further with our support team they have advised that the cui is only suitable for AutoCAD 2013 and not AutoCAD MEP 2013 so I'm going to investigate further today why this is so.

You are not logged in.

Log into access your profile, ask and answer questions, share ideas and more. Haven't signed up yet? Register

Announcements
Are you familiar with the Autodesk Expert Elites? The Expert Elite program is made up of customers that help other customers by sharing knowledge and exemplifying an engaging style of collaboration. To learn more, please visit our Expert Elite website.

Need installation help?

Start with some of our most frequented solutions to get help installing your software.

New AutoCAD MEP Category!

The AutoCAD MEP forum has moved into it's very own category page, and can no longer be found within the Additional Product Forums.

Ask the Community